Other repos cause trouble with package searching/updating?

If none of the more specific forums is the right place to ask

Other repos cause trouble with package searching/updating?

Postby bentHnau » 2018-10-15 21:43

I have added the Trisquel distro's latest release stable repo to my /etc/apt/sources.list.d/

I use only one package from this repo (Icecat), but I want to keep that package updated, so I want to keep the repo enabled. However, am I going to run into trouble with other Trisquel packages being offered when I apt-get upgrade or apt-cache search? I don't want to install other Trisquel packages by mistake. This might not be a big deal since Trisquel is based on Debian stable, but...I don't know what kinds of problems this might cause.
Debian Stretch x64 on a Dell XPS 17 laptop
bentHnau
 
Posts: 123
Joined: 2014-01-07 01:43
Location: California

Re: Other repos cause trouble with package searching/updatin

Postby bw123 » 2018-10-15 21:57

depends, what is url of the repo? did you go there and look at it? does it only contain icecat pkg? what does apt policy say about it's priority? Did you search the internet for the best way to use icecat on debian?

for myself, I resist the temptation, hoping that one day debian will have a stable/secure/privacy-oriented/free modern browser in the repo.
User avatar
bw123
 
Posts: 3532
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Other repos cause trouble with package searching/updatin

Postby bentHnau » 2018-10-15 22:15

bw123 wrote:depends, what is url of the repo? did you go there and look at it? does it only contain icecat pkg? what does apt policy say about it's priority? Did you search the internet for the best way to use icecat on debian?

for myself, I resist the temptation, hoping that one day debian will have a stable/secure/privacy-oriented/free modern browser in the repo.


The mirror is https://mirror.fsf.org/trisquel/, and yes, there are other packages there.

I'm not sure how to find the priority. I did this
Code: Select all
apt-cache policy icecat
:

Code: Select all
icecat:
  Installed: 52.3.0-gnu1+8.0trisquel3
  Candidate: 52.3.0-gnu1+8.0trisquel3
  Version table:
 *** 52.3.0-gnu1+8.0trisquel3 500
        500 https://mirror.fsf.org/trisquel flidas-updates/main amd64 Packages
        100 /var/lib/dpkg/status


I don't know what you mean by "the best way to run icecat." I installed it so that I could run it in Firejail without all changes being discarded and my stylesheet and UI config being ignored every time I ran it (this was the problem with running the binary). I found some directions for installing from source, but they were poorly written and the process failed and was a huge headache. So this is the best way I know to run it.
Debian Stretch x64 on a Dell XPS 17 laptop
bentHnau
 
Posts: 123
Joined: 2014-01-07 01:43
Location: California

Re: Other repos cause trouble with package searching/updatin

Postby bw123 » 2018-10-15 22:22

I would not mix it with stable, let me know how it goes?
The mirror is https://mirror.fsf.org/trisquel/, and yes, there are other packages there.
User avatar
bw123
 
Posts: 3532
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Other repos cause trouble with package searching/updatin

Postby bentHnau » 2018-10-15 22:47

bentHnau wrote:his might not be a big deal since Trisquel is based on Debian stable,

Correction: it is based on Ubuntu
Debian Stretch x64 on a Dell XPS 17 laptop
bentHnau
 
Posts: 123
Joined: 2014-01-07 01:43
Location: California

Re: Other repos cause trouble with package searching/updatin

Postby bw123 » 2018-10-15 22:56

Since you have it installed, would you be kind enough to look into the default preferences and post them? It should be a file ending with .js somewhere like /etc/icecat/something.js

Also, what extensions/plugins/addons are installed and enabled by defaut? Since you have v 52x is this an older ver that isn't based on the new v60 firefox-esr?

thanks
User avatar
bw123
 
Posts: 3532
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Other repos cause trouble with package searching/updatin

Postby bentHnau » 2018-10-15 23:06

bw123 wrote:Since you have it installed, would you be kind enough to look into the default preferences and post them? It should be a file ending with .js somewhere like /etc/icecat/something.js

// This file can be used to configure global preferences for IceCat
// Example: Homepage
//pref("browser.startup.homepage", "http://www.weebls-stuff.com/wab/");

Also, what extensions/plugins/addons are installed and enabled by defaut? Since you have v 52x is this an older ver that isn't based on the new v60 firefox-esr?

LibreJS, Spyblock, HTTPS Everywhere, a custom about:home page, reveal hidden HTML, something to get MCdonald's wifi, and a few that seem to help websites work despite LibreJS breaking them.
Debian Stretch x64 on a Dell XPS 17 laptop
bentHnau
 
Posts: 123
Joined: 2014-01-07 01:43
Location: California

Re: Other repos cause trouble with package searching/updatin

Postby bw123 » 2018-10-15 23:09

bentHnau wrote:... something to get MCdonald's wifi,...


lmao! rms had that problem posted for months, the dude got it done, freakin genius.

if you like icecat, maybe send him some email an volunteer for one of the tasks on the home page?
http://www.stallman.org/
User avatar
bw123
 
Posts: 3532
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Other repos cause trouble with package searching/updatin

Postby stevepusser » 2018-10-16 18:02

It's probably safer to use the prebuilt Icecat binary from the GNU site than a package that was built from source on Ubuntu like the Trisquel packages. If it is based on Firefox Quantum, and requires rustc and cargo build-depends that don't appear in apt for Stretch (yet are in the Debian repo), I can't build it for Stretch on the openSUSE build service. Maybe for MX Linux on my own machine, though, by manually installing those rustc and cargo debs first.

Edit: Looks like Trisquel doesn't have the latest release, either: https://repology.org/metapackage/icecat/versions
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Cinnamon 3.8, Midori 6.0
User avatar
stevepusser
 
Posts: 10136
Joined: 2009-10-06 05:53

Re: Other repos cause trouble with package searching/updatin

Postby None1975 » 2018-10-17 14:03

bentHnau wrote:I have added the Trisquel distro's latest release stable repo to my /etc/apt/sources.list.d/
This might not be a big deal since Trisquel is based on Debian stable,

Trisquel is not Debian.
bentHnau wrote:I don't know what kinds of problems this might cause.

You already have a problem because you made a FrankenDebian
Image
OS: Debian 9.5 / WM: Xmonad
Debian Wiki | DontBreakDebian, My config files in github
Linux User #607425
User avatar
None1975
 
Posts: 673
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius


Return to General Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable