Problem with gksu, dconf and gnome lockingup in Sid

If none of the more specific forums is the right place to ask

Problem with gksu, dconf and gnome lockingup in Sid

Postby sagittarrii » 2013-12-20 21:23

Hello everyone,

I hope this is the right place to ask about this. I have run into a problem with gnome locking up after I use gksu. Currently running a fresh install of debian sid.

What happens is after I run a program with gksu twice the permissions of /run/user/1000/deconf/user get changed to root:root then if I do anyhting in gnome it locks up and i have to ctrl alt F2, change the premissions back and restart gdm3.

The exact steps I use to repduce this are:

- open a terminal
- run "gksu gedit"
- close gedit
- run "gksu gedit"
- close gedit
- use the topleft hot corner in gnome

I'm kind of at a los on how to fix this.
sagittarrii
 
Posts: 1
Joined: 2013-12-20 21:09

Re: Problem with gksu, dconf and gnome lockingup in Sid

Postby miklosq » 2014-10-21 19:35

Hi,

I am having the exact same issue with a more recent Debian Jessie. I did a quick research, I found bug https://bugs.debian.org/724731 which looks related and developers claim they have resolved it. Very similar issue - which is similar to ours - resurfaced again in bug https://bugs.debian.org/732209 and it still appears to be unresolved. :cry:

The glitch is the same. The file permission of /run/user/1000/dconf/user get's always changed to root:root and I have to change it back by switching to text-based terminal window using F2 and log-on as root and update the permission setting on the file to my logon user ID permission, which happens to be 1000 (I do not have superuser rights for that user). :P

I have not been able to find the root cause, I still need to get my packages updated to the latest Jessie, currently experiencing with versions:

    gnome-shell 3.12.2-3
    gdm3 3.12.2-4
    gnome 1:3.8+8

but my workaround is the following :wink: (in most cases this solves it temporarily):

1. Switch back to a text-based terminal session using F2 and logon as 'root'.
2. Update the file permissions to the logon user id permission.
3. Logon as the user on another text-based terminal and send the HUP signal to the /usr/bin/gnome-shell process.
4. Switch back to your gnome session.

I will update later after I have found the fix...
Regards,
--
miklosq
"In the middle of the difficulty lies the opportunity." - Albert Einstein
User avatar
miklosq
 
Posts: 4
Joined: 2012-03-17 17:01
Location: Hungary

Re: Problem with gksu, dconf and gnome lockingup in Sid

Postby miklosq » 2014-12-03 22:23

Here is a few lines I use to recover from this bug when it happens. Most of the time it works :wink:

1. Switch back to text-based terminal with CTRL-ALT-F1 and log on as 'root'.
2. Issue command:
Code: Select all
chown 1000:1000 /run/user/1000/dconf/user 

3. Issue command:
Code: Select all
pkill -f /usr/bin/gnome-shell -HUP

4. Switch back to your GNOME graphical session with CTRL-ALT-F7 .

Hope it helps until this bug is completely fixed and finally gone.
Regards,
--
miklosq
"In the middle of the difficulty lies the opportunity." - Albert Einstein
User avatar
miklosq
 
Posts: 4
Joined: 2012-03-17 17:01
Location: Hungary


Return to General Questions

Who is online

Users browsing this forum: d76 and 17 guests

fashionable