Recent upgrade in jessie broke gdm

If none of the more specific forums is the right place to ask

Recent upgrade in jessie broke gdm

Postby JAndyP » 2014-10-28 13:34

As always, I ran apt-get upgrade && apt-get dist-upgrade first thing after booting today. While those commands ran, I started a graphical java program. For a while everything went ok, until I closed said program and tried to start it anew, which crashed as soon as it got to the lwjgl part. So I figured I'd reboot, which is where we come to the actual problem:

Instead of getting gdm's login screen, I got an "Oh no! Something has gone wrong" error message covering the screen, with only one button, which rebooted the pc.
I figured something might have gone wrong with the upgrade, so I tried apt-get install -f (in tty1), which actually did something, but didn't solve the problem.
Since I thought I had seen something about nvidia in the terminal where the upgrade was done and don't have an nvidia but an intel graphics card, I tried purging all nvidia packages.
As that didn't help either, I tried to circumvent the problem by using xdm. It got me to a very rudimentary login screen (after curiously printing out that it had failed to start Gnome Display Manager), but logging in produced the same error screen.
Using screen and lynx in tty1, I managed to search for the error and possible log locations on google, but nothing I found was recent enough to help.
Eventually, I tried installing and using kdm instead, which was finally met with success. But much like xdm, kdm started after printing out that it had fauled to start Gnome Display Manager, except that message appeared 3-4 times until kdm's login screen covered it, so I removed gdm3.

Now that I can safely log in (albeit with a different DM), I went to check /var/log/dpkg.log
Here are the logs of the relevant time slice:
Code: Select all
$ cat /var/log/dpkg.log | grep '2014-10-28 09' | grep -P ':\d\d upgrade|:\d\d install '
2014-10-28 09:49:12 upgrade libsasl2-modules-db:i386 2.1.26.dfsg1-11 2.1.26.dfsg1-12
2014-10-28 09:49:13 upgrade libsasl2-modules-db:amd64 2.1.26.dfsg1-11 2.1.26.dfsg1-12
2014-10-28 09:49:14 upgrade libsasl2-2:i386 2.1.26.dfsg1-11 2.1.26.dfsg1-12
2014-10-28 09:49:15 upgrade libsasl2-2:amd64 2.1.26.dfsg1-11 2.1.26.dfsg1-12
2014-10-28 09:49:16 upgrade libsqlite3-0:amd64 3.8.6-1 3.8.7-1
2014-10-28 09:49:18 upgrade libhunspell-1.3-0:amd64 1.3.3-2 1.3.3-3
2014-10-28 09:49:20 upgrade libqt5webkit5:amd64 5.3.2+dfsg-2 5.3.2+dfsg-3
2014-10-28 09:49:23 upgrade bsdmainutils:amd64 9.0.5 9.0.6
2014-10-28 09:49:25 upgrade libgirepository1.0-dev:amd64 1.42.0-2 1.42.0-2.2
2014-10-28 09:49:26 upgrade gobject-introspection:amd64 1.42.0-2 1.42.0-2.2
2014-10-28 09:49:28 upgrade libgirepository-1.0-1:amd64 1.42.0-2 1.42.0-2.2
2014-10-28 09:49:29 upgrade gir1.2-freedesktop:amd64 1.42.0-2 1.42.0-2.2
2014-10-28 09:49:30 upgrade gir1.2-glib-2.0:amd64 1.42.0-2 1.42.0-2.2
2014-10-28 09:49:31 upgrade libjetty-java:all 6.1.26-3 6.1.26-4
2014-10-28 09:49:33 upgrade libmx4j-java:all 3.0.2-13 3.0.2-14
2014-10-28 09:49:34 upgrade libsasl2-modules:i386 2.1.26.dfsg1-11 2.1.26.dfsg1-12
2014-10-28 09:49:35 upgrade libsasl2-modules:amd64 2.1.26.dfsg1-11 2.1.26.dfsg1-12
2014-10-28 09:49:36 upgrade python-dateutil:all 1.5+dfsg-1 2.2-2
2014-10-28 09:49:38 upgrade unattended-upgrades:all 0.82.10 0.83
2014-10-28 09:49:39 upgrade svn-buildpackage:all 0.8.5 0.8.5+nmu1
2014-10-28 09:51:53 install nvidia-installer-cleanup:amd64 <keine> 20131102+1
2014-10-28 09:51:57 install glx-diversions:amd64 <keine> 0.4.2
2014-10-28 09:51:58 install nvidia-support:amd64 <keine> 20131102+1
2014-10-28 09:52:00 install libcuda1:amd64 <keine> 340.46-3
2014-10-28 09:52:02 install libcuda1:i386 <keine> 340.46-3
2014-10-28 09:52:03 install libnvidia-eglcore:amd64 <keine> 340.46-3
2014-10-28 09:52:06 install libegl1-nvidia:amd64 <keine> 340.46-3
2014-10-28 09:52:07 upgrade nvidia-opencl-icd:amd64 340.46-1 340.46-3
2014-10-28 09:52:09 upgrade nvidia-opencl-common:amd64 340.46-1 340.46-3
2014-10-28 09:52:10 upgrade libnvidia-compiler:amd64 340.46-1 340.46-3
2014-10-28 09:52:12 install glx-alternative-mesa:amd64 <keine> 0.4.2
2014-10-28 09:52:13 install glx-alternative-nvidia:amd64 <keine> 0.4.2
2014-10-28 09:52:14 install nvidia-modprobe:amd64 <keine> 340.46-1
2014-10-28 09:52:15 install nvidia-alternative:amd64 <keine> 340.46-3
2014-10-28 09:52:16 install libgl1-nvidia-glx:amd64 <keine> 340.46-3
2014-10-28 09:52:19 install libgl1-nvidia-glx:i386 <keine> 340.46-3
2014-10-28 09:52:22 install libgles1-nvidia:amd64 <keine> 340.46-3
2014-10-28 09:52:23 install libgles2-nvidia:amd64 <keine> 340.46-3
2014-10-28 09:52:24 install libjansson4:amd64 <keine> 2.7-1
2014-10-28 09:52:25 install libnvidia-ml1:amd64 <keine> 340.46-3
2014-10-28 09:52:26 install libnvidia-ml1:i386 <keine> 340.46-3
2014-10-28 09:52:27 install xserver-xorg-video-nvidia:amd64 <keine> 340.46-3
2014-10-28 09:52:28 install nvidia-vdpau-driver:amd64 <keine> 340.46-3
2014-10-28 09:52:29 install nvidia-kernel-common:amd64 <keine> 20131102+1
2014-10-28 09:52:30 install nvidia-kernel-dkms:amd64 <keine> 340.46-3
2014-10-28 09:52:32 install nvidia-driver:amd64 <keine> 340.46-3
2014-10-28 09:52:33 install libxnvctrl0:amd64 <keine> 340.46-1
2014-10-28 09:52:33 install nvidia-settings:amd64 <keine> 340.46-1
2014-10-28 09:52:35 install libcuda1-i386:i386 <keine> 340.46-3
2014-10-28 09:52:36 install libgl1-nvidia-glx-i386:i386 <keine> 340.46-3
2014-10-28 09:52:36 install libmail-java:all <keine> 1.5.2-2
2014-10-28 09:52:38 upgrade libjetty-extra-java:all 6.1.26-3 6.1.26-4
2014-10-28 09:52:39 upgrade libjetty-extra:amd64 6.1.26-3 6.1.26-4
2014-10-28 09:52:40 install nvidia-smi:i386 <keine> 340.46-3

Here the same without restirction to "upgrade" and "install"
http://pastebin.com/kNw2P9MU

As you can see, there is nothing related to gnome in there (or nothing that sounds like it's related to gnome/gdm).
Which leads me to believe that either some package had new dependiencies that got installed upon (dist-)upgrading that didn't agree with my hardware or itself changed in a way that broke things. In any case I'd assume it to be one of the above packages.

PS: The java program works again. Might be unrelated, might be due to removing all nvidia-related packages.

Edit:
This is the output of systemctl -l status gdm.service (output identical with systemctl -l status gdm3.service):
Code: Select all
# systemctl -l status gdm.service
● gdm.service - GNOME Display Manager
   Loaded: loaded (/lib/systemd/system/gdm.service; static)
  Drop-In: /run/systemd/generator/gdm3.service.d
           └─50-gdm3-$x-display-manager.conf
   Active: failed (Result: start-limit) since Die 2014-10-28 18:23:33 CET; 8min ago
  Process: 1319 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/gdm3" ] (code=exited, status=1/FAILURE)

Okt 28 18:23:31 ferret2 systemd[1]: Failed to start GNOME Display Manager.
Okt 28 18:23:31 ferret2 systemd[1]: Unit gdm.service entered failed state.
Okt 28 18:23:31 ferret2 systemd[1]: Starting GNOME Display Manager...
Okt 28 18:23:33 ferret2 systemd[1]: gdm.service holdoff time over, scheduling restart.
Okt 28 18:23:33 ferret2 systemd[1]: Stopping GNOME Display Manager...
Okt 28 18:23:33 ferret2 systemd[1]: Starting GNOME Display Manager...
Okt 28 18:23:33 ferret2 systemd[1]: gdm.service start request repeated too quickly, refusing to start.
Okt 28 18:23:33 ferret2 systemd[1]: Failed to start GNOME Display Manager.
Okt 28 18:23:33 ferret2 systemd[1]: Unit gdm.service entered failed state.
JAndyP
 
Posts: 1
Joined: 2014-10-28 12:54

Re: Recent upgrade in jessie broke gdm

Postby peterrabbit » 2014-10-29 02:42

I'm think I experienced the same issue, but for me purging all of the nvidia drivers and reinstalling gdm3 allowed me to at least log in. I was getting errors in my .xsession like this:
Code: Select all
Xlib:  extension "GLX" missing on display ":0".

Followed by a gnome handler reporting an error code.
Unfortunately now that I can log in the gnome gui wont respond to user input.
peterrabbit
 
Posts: 4
Joined: 2011-03-08 03:53

Re: Recent upgrade in jessie broke gdm

Postby dilberts_left_nut » 2014-10-29 06:01

Welcome to testing :D
You get to keep the pieces, or glue them back together, as you like.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4591
Joined: 2009-10-05 07:54
Location: enzed

Re: Recent upgrade in jessie broke gdm

Postby peterrabbit » 2014-10-29 07:37

Usually I just med-flight my home directory and obliterate the thing with my trust usb installer. Either way, its still better than waiting a year for bugs to be fixed and the newest libraries to be included in the package archives.

For anyone else who runs into trouble, after you wipe the NVIDIA packages you need to modify the xsession configuration files to include gnome as the start up manager, in my case they were blank. Gnome-do was also one of the pieces that was broken, I had to purge it to have a usable session.
peterrabbit
 
Posts: 4
Joined: 2011-03-08 03:53


Return to General Questions

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable