ntfs-3g Input/output error

If none of the more specific forums is the right place to ask

ntfs-3g Input/output error

Postby vortex636 » 2014-10-31 05:33

Hello,

I have two disks formated with NTFS, which I can no longer read or write under Debian Jessie.
I may have broken the installation, or it may have broken by a recent upgrade/dist-upgrade, I really can't tell.
At first I thought my HD was corrupt, gone or otherwise fubar.

However: the disk can be read and written under: Windows 7, Mac OSX, Backtrack 5. So, I doubt its a problem with the disk, which I did check for errors.
Also, another NTFS external disk cannot be read, and out of curiosity, after formatting a usb stick with NTFS, it too can no longer be read or written.
The error I keep getting is:
Code: Select all
ls: cannot access lex: Input/output error

or
Code: Select all
ls -l
ls: cannot access lex: Input/output error
total 0
-????????? ? ? ? ?            ? lex



Which by itself doesn't say much. I have ruled out disk errors by running on all disks both ntfsfix & chkdisk under win 7.
on my Syslog, I get:

Code: Select all
Oct 31 05:09:26 ntfs-3g[1765]: Version 2014.2.15AR.2 integrated FUSE 28
Oct 31 05:09:26 ntfs-3g[1765]: Mounted /dev/sdd1 (Read-Write, label "RESCUE", NTFS 3.1)
Oct 31 05:09:26 ntfs-3g[1765]: Cmdline options: rw
Oct 31 05:09:26 ntfs-3g[1765]: Mount options: rw,allow_other,nonempty,relatime,fsname=/dev/sdd1,blkdev,blksize=4096
Oct 31 05:09:26 ntfs-3g[1765]: Ownership and permissions disabled, configuration type 7


Other than that, I get no errors from dmesg, messages, or other log file.
Can anyone please help?
vortex636
 
Posts: 53
Joined: 2010-11-24 02:39

Re: ntfs-3g Input/output error

Postby dilberts_left_nut » 2014-10-31 08:55

debianxfce wrote:"upgrade/dist-upgrade"

Do not do that for clean Jessie distro installations.

This works well with windows partitions:
cdimage.debian.org/cdimage/jessie_di_beta_2/i386/iso-cd/debian-jessie-DI-b2-i386-xfce-CD-1.iso

Stop being a tool.
Of course a testing system should be upgraded.

@OP
Looks odd.

Check for recent upgrades of ntfs-3g or related packages.
If rolling back to the previous version fixes the problem then file a bug against it (if there isn't one already).
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5080
Joined: 2009-10-05 07:54
Location: enzed

Re: ntfs-3g Input/output error

Postby vortex636 » 2014-10-31 16:32

I took my question to Tuxera support forum, as I have a feeling they may be better suited for helping me with this.

I've updated and upgraded all packages related (glibc, libfuse, ntfs-3g) and still have the same problem.
vortex636
 
Posts: 53
Joined: 2010-11-24 02:39

[SOLVED] Re: ntfs-3g Input/output error

Postby vortex636 » 2014-10-31 19:26

I can confirm that I have solved the problem.
This appears to be a bug with
Code: Select all
ntfs-3g 1:2014.2.15AR.2-1

I downgraded to Wheezy's
Code: Select all
1:2012.1.15AR.5-2.1

And ntfs disks work again.
vortex636
 
Posts: 53
Joined: 2010-11-24 02:39


Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable