Debian Wheezy Update screw up and solution

If none of the more specific forums is the right place to ask

Debian Wheezy Update screw up and solution

Postby kujirasan » 2015-04-14 01:13

Updated/Upgraded Debian today and got error messages and blocking of synaptic etc , here is a solution that worked for me
go to :
/usr/share/doc/libxrender1/, then delete changelog.Debian.gz and do an apt-get -f install



cd /
cd /usr/share/doc/libxrender1

then rm -f changelog.Debian.gz
and do an apt-get -f install
kujirasan
 
Posts: 182
Joined: 2009-03-08 23:07

Re: Debian Wheezy Update screw up and solution

Postby aplistir » 2015-04-14 09:52

I had the same problem.

There is already a bug-report of it, and here is a similar solution for the problem using dpkg --force-overwrite -i...
https://www.mail-archive.com/debian-bug ... 14478.html

Just make sure you overwrite the version of your secondary architecture..
eg. my achitecture is amd64 so I let the amd64 -version overwrite the i386 -version and not the vice versa.
Dont know if it matters though.

It will propably be fixed quickly, because apt-get upgrade should NOT break in debian stable...
aplistir
 
Posts: 133
Joined: 2014-03-26 22:11


Return to General Questions

Who is online

Users browsing this forum: No registered users and 20 guests

fashionable