Debian 8 XFCE lost all sound

If none of the more specific forums is the right place to ask

Debian 8 XFCE lost all sound

Postby nsxnsxnsx » 2015-05-11 09:20

Hi

I recently freshly installed Debian 8 (stable) XFCE.

Everything was working fine. I installed Skype (using the instructions in the Debian wiki) and that worked no problem. I then installed libavcodec56-extra (just to have the extra codecs ready in case needed), and Synaptic also installed the i386 version also.

After that, no sound (anywhere at all).

I reinstalled libavcodec-56 (and the i386 version) to try to rectify the problem, but the sound has not returned.

As per a google seacrh, i installed pulse audio. This showed me that the the 'levels' were moving in line with the sounds which should have been playing, but no amount of tweaking managed to get the sound to come out.

I have Mint installed on the same machine and the sound works fine here so i know for sure it is not a hardware issue.

If there are any ideas on how i can get the sound working please let mw know.
nsxnsxnsx
 
Posts: 12
Joined: 2015-02-12 08:50

Re: Debian 8 XFCE lost all sound

Postby kc1di » 2015-05-11 09:49

Hello nsxnsxnsx,
Did you install the pavucontrol?
if you did what look in the upper right corner of the display and make sure the output is not muted.
Dave
Morse Code -An Early digital mode !
Jessie
John 3:16
Registered Linux User # 462608
User avatar
kc1di
 
Posts: 207
Joined: 2007-03-12 12:52
Location: Somewhere In Maine

Re: Debian 8 XFCE lost all sound

Postby peter_irich » 2015-05-11 12:41

I not use pusleaudio in Debian 8.0 in xfce, I use alsa.
I lost sound too. Usually i use alsamixer, there is xfce Audio Mixer applet on panel too.
I found out what sound appeared when I allows Front Mic in Mixer, though I not use it,
I use Rear Mic and it is one of the Source in alsamixer.
Try make the same in pavucontrol and check is an all itmes are allowed.

Peter.
peter_irich
 
Posts: 1169
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: Debian 8 XFCE lost all sound

Postby guram » 2015-05-11 17:54

nsxnsxnsx wrote:Hi

I recently freshly installed Debian 8 (stable) XFCE.

Everything was working fine. I installed Skype (using the instructions in the Debian wiki) and that worked no problem. I then installed libavcodec56-extra (just to have the extra codecs ready in case needed), and Synaptic also installed the i386 version also.

After that, no sound (anywhere at all).

I reinstalled libavcodec-56 (and the i386 version) to try to rectify the problem, but the sound has not returned.

As per a google seacrh, i installed pulse audio. This showed me that the the 'levels' were moving in line with the sounds which should have been playing, but no amount of tweaking managed to get the sound to come out.

I have Mint installed on the same machine and the sound works fine here so i know for sure it is not a hardware issue.

If there are any ideas on how i can get the sound working please let mw know.


I had such a problem, this command help me resolve problem :

amixer -c 0 set Master playback 100% unmute

i think there is mute/unmute small bug in jessie ( in xfce ), if problem no solved, you should give more details like the contents of your /proc/asound/cards and the output of lspci and lsmod | grep snd
I love jessie ; )
User avatar
guram
 
Posts: 12
Joined: 2015-05-05 19:31

Re: Debian 8 XFCE lost all sound

Postby nsxnsxnsx » 2015-05-12 11:48

thanks all - will test these suggestions tonight. I have already fiddled with Pulse Audio to no avail.

The thing is - i have hotkeys on my laptop for mute/unmute, and these are displayed on screen, i.e.e muting and unmutung symbols, but with no change in sound output.
nsxnsxnsx
 
Posts: 12
Joined: 2015-02-12 08:50

Re: Debian 8 XFCE lost all sound

Postby nsxnsxnsx » 2015-05-12 17:19

doesn't seem to have worked:

this is what i get:

Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 127
Mono: Playback 127 [100%] [0.00dB] [on]
nsxnsxnsx
 
Posts: 12
Joined: 2015-02-12 08:50

Re: Debian 8 XFCE lost all sound

Postby nsxnsxnsx » 2015-05-12 17:31

This is fixed now.

I maximised the Pavucontrol window and saw the full screen of settings - this made a lot more sense. Previously i only saw it in the very small default window which made no sense.

Thanks for your help.
nsxnsxnsx
 
Posts: 12
Joined: 2015-02-12 08:50

Re: Debian 8 XFCE lost all sound

Postby stevepusser » 2015-05-12 18:14

The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8533
Joined: 2009-10-06 05:53

Re: [FIXED] Debian 8 XFCE lost all sound

Postby nsxnsxnsx » 2015-05-14 10:18

Given that the the sound muted itself without user instruction and needed a new package to achieve unmute should this be reported as a bug??
nsxnsxnsx
 
Posts: 12
Joined: 2015-02-12 08:50

Re: [FIXED] Debian 8 XFCE lost all sound

Postby guram » 2015-05-15 21:45

nsxnsxnsx wrote:Given that the the sound muted itself without user instruction and needed a new package to achieve unmute should this be reported as a bug??


This mute/unmute bug annoying most people and this thing makes xfce very poor, this that made me change windows manager
I love jessie ; )
User avatar
guram
 
Posts: 12
Joined: 2015-05-05 19:31

Re: Debian 8 XFCE lost all sound

Postby stevepusser » 2015-05-15 21:59

Or at least make sure that pavucontrol is installed with pulseaudio--it's only a suggested package.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8533
Joined: 2009-10-06 05:53

Re: Debian 8 XFCE lost all sound

Postby Edward_Guyatt » 2015-08-06 15:42

I had the problem of sound dropping to zero when I turned it down and having to use various mixers and controls to get it back. It didn't even seem consistent what control would unmute it either; sometimes unmuting in alsamixer was the thing, other times some certain thing in pavucontrol, etc. Some of the behaviour was really weird... like the problem would occur when I was using Banshee alone but not when it was with another audio player like Exaile or mpg123.

Anyway, it seems that now I've stopped using Banshee Media Player, the problem has gone away. Another thing I've done is set sound_card in xfce4 settings editor to different things listed under sound_cards, which may have changed something. Banshee caused the same muting problem in GNOME too; I just didn't notice because I tend not to use Banshee in GNOME.
Edward_Guyatt
 
Posts: 2
Joined: 2015-04-09 20:07

Re: Debian 8 XFCE lost all sound

Postby jpstill » 2015-08-25 19:18

I've just encountered this problem fot the first time today - thanks for the advice here!
I've been using the mute hotkey for a while, with no problems, until today.
I installed pavucontrol, on the advice above, and found that the third tab along "Output Devices", lower panel "Built-in Analog Audio Stereo", this mute/unmute button is the only one that unmutes the audio! But at least I've got my sound back!
Thanks again!
jpstill
 
Posts: 2
Joined: 2015-08-25 19:07

Re: Debian 8 XFCE lost all sound

Postby jpstill » 2015-08-25 19:22

Actually, I've just realised that I'd only been using VLC player before, but I started trying out xine player for the first time today. The problem started today, so this must be part of the problem.
jpstill
 
Posts: 2
Joined: 2015-08-25 19:07

Re: Debian 8 XFCE lost all sound

Postby xinu » 2017-08-07 12:29

guram wrote:
I had such a problem, this command help me resolve problem :

amixer -c 0 set Master playback 100% unmute

i think there is mute/unmute small bug in jessie ( in xfce ), if problem no solved, you should give more details like the contents of your /proc/asound/cards and the output of lspci and lsmod | grep snd


thx a lot dude !
May the FORK be with you!

i puke slackware ! !
xinu
 
Posts: 72
Joined: 2016-01-26 13:54


Return to General Questions

Who is online

Users browsing this forum: berzo84 and 6 guests

fashionable