Upgrade Error

If none of the more specific forums is the right place to ask

Upgrade Error

Postby Bugs318 » 2016-08-29 20:10

Hi,

Was away for a week and a half, so behind on a few updates. Ran update and upgrade, and receive this error message:

Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
systemd : Breaks: rdnssd (< 1.0.1-5) but 1.0.1-1+b1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Note that I am running testing, NOT unstable. Any idea how to help? Thanks in advance!
Bugs318
 
Posts: 31
Joined: 2010-05-25 18:48

Re: Upgrade Error

Postby GarryRicketson » 2016-08-29 20:42

if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Is the most likely reason,......

https://www.debian.org/doc/manuals/debian-faq/ch-choosing.en.html
3.1.6 You are talking about testing being broken. What do you mean by that?

Sometimes, a package might not be installable through package management tools. Sometimes, a package might not be available at all, maybe it was (temporarily) removed due to bugs or unmet dependencies. Sometimes, a package installs but does not behave in the proper way.

When these things happen, the distribution is said to be broken (at least for this package).


by Bugs318 » Note that I am running testing, NOT unstable.

"testing" is testing, it is NOT stable, there for it is unstable , unstable and testing,
all though a little different, are in the same "class" so to speak.
From the same , link above:
3.1.5 Could you tell me whether to install stable, testing or unstable?

No. This is a rather subjective issue. There is no perfect answer as it depends on your software needs, your willingness to deal with possible breakage, and your experience in system administration. Here are some tips:

Stable is rock solid. It does not break and has full security support. But it not might have support for the latest hardware.

Testing has more up-to-date software than Stable, and it breaks less often than Unstable. But when it breaks, it might take a long time for things to get rectified. Sometimes this could be days and it could be months at times. It also does not have permanent security support.

See also : https://wiki.debian.org/DebianTesting
=====================
The following packages have unmet dependencies:
systemd : Breaks: rdnssd (< 1.0.1-5) but 1.0.1-1+b1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

The error message is pretty clear, self explanatory, you could wait a week or 2 and see, maybe by then the broken package will be fixed, I suppose,
Or you could read some documentation, and try to repair sooner:
https://www.debian.org/doc/manuals/debian-reference/ch02.en.html

and ...................
https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_tracking_literal_testing_literal_with_some_packages_from_literal_unstable_literal
This is a pretty good "tutorial" also:
https://raphaelhertzog.com/2011/02/21/debian-cleanup-tip-4-find-broken-packages-and-reinstall-them/
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4263
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Upgrade Error

Postby Bugs318 » 2016-09-06 20:31

Thanks for the tips and reading. Have been following up somewhat. Tried to install later rdnssd manually (as so far, waiting has not resulted in resolution), but got the following message. Surely this rdnssd update must not necessitate removing gnome and all of those network managers? If so, can I be the only experiencing an issue here? Any further suggestions, beyond wait?

According to "dpkg --get-selections | grep hold" I am not holding back packages, so it is strictly on apt policy, as far as I can tell. Output below.

The following packages will be REMOVED:
gnome network-manager network-manager-gnome network-manager-openvpn network-manager-openvpn-gnome
The following packages will be upgraded:
rdnssd
1 upgraded, 0 newly installed, 5 to remove and 433 not upgraded.
Need to get 43.4 kB of archives.
After this operation, 22.7 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
derek@derek-laptop2: 1779: /etc/apt/sources.list.d$upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
systemd : Breaks: rdnssd (< 1.0.1-5) but 1.0.1-1+b1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Bugs318
 
Posts: 31
Joined: 2010-05-25 18:48

Re: Upgrade Error

Postby dilberts_left_nut » 2016-09-06 20:39

So why do you think you are running testing, and why is your system trying to install the version from stable?
Code: Select all
apt-cache policy systemd rdnssd
?
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4658
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrade Error

Postby Bugs318 » 2016-09-06 21:27

Well, I installed testing and my repos all point to testing, as shown in the output from that (posted below). I have no idea why apt is pointing towards that.

derek@derek-laptop2: 1780: /etc/apt/sources.list.d$apt-cache policy systemd rdnssd
systemd:
Installed: 230-7
Candidate: 231-4
Version table:
231-4 500
500 http://ftp.us.debian.org/debian testing/main amd64 Packages
*** 230-7 100
100 /var/lib/dpkg/status
rdnssd:
Installed: 1.0.1-1+b1
Candidate: 1.0.1-6
Version table:
1.0.1-6 500
500 http://ftp.us.debian.org/debian testing/main amd64 Packages
*** 1.0.1-1+b1 100
100 /var/lib/dpkg/status
Bugs318
 
Posts: 31
Joined: 2010-05-25 18:48

Re: Upgrade Error

Postby fireExit » 2016-09-06 22:37

Bugs318 wrote:1 upgraded, 0 newly installed, 5 to remove and 433 not upgraded

Bugs318 wrote:Was away for a week and a half, so behind on a few updates

Bugs318 wrote:Ran update and upgrade

Bugs318 wrote:Note that I am running testing

dist-upgrade?
User avatar
fireExit
 
Posts: 559
Joined: 2014-11-20 11:22

Re: Upgrade Error

Postby dilberts_left_nut » 2016-09-07 00:42

Wow, yeah missed the 'not upgraded' count.
@OP Your claims about the origin and state of your system aren't adding up - the package you have installed is from stable and was never in testing.
If you know why but aren't telling us, then good luck, i'm out.
If you don't know why, you should just install stable and be happy ever after.
(edit: or get busy trying to remember or work out how it got there :D)
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4658
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrade Error

Postby Bugs318 » 2016-09-07 21:46

Yep, that was dist-upgrade (it's an alias) and I have a system from zareason. They claim to have installed testing as per my request. The install disc they sent with my install was, indeed, testing. The repos do and always have pointed to testing, so how this got there, I am not certain. That isn't to say I may not have made a change somewhere, somehow and forgotten in getting another package to run, but I cannot find any sign of a package being held nor of any repo that isn't labelled testing.

If you have suggestions of where and how I could check further for such causation, I'll be happy to oblige, but as far as I can recall or see, there is no obvious reason for a package that was never in testing and the system has been updating well for 14-15 months since purchase with all repos pointing to testing.
Bugs318
 
Posts: 31
Joined: 2010-05-25 18:48

Re: Upgrade Error

Postby Bugs318 » 2016-09-07 21:48

Note: when this problem arose, I was nowhere near 443 packages in need of upgrade, but none will upgrade and without any ideas for resolution, the upgrades grow.
Bugs318
 
Posts: 31
Joined: 2010-05-25 18:48

Re: Upgrade Error

Postby dilberts_left_nut » 2016-09-07 22:28

So install the updated rdnssd.
aptitude might help.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4658
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrade Error

Postby dasein » 2016-09-08 00:15

If the OP has done a dist-upgrade (or multiple dist-upgrades) with a Stable repo enabled, this is almost certainly not a one-off issue. (And absent reliable reporting, there's just no way to know for sure.)
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Upgrade Error

Postby Bugs318 » 2016-09-08 01:46

Will try the aptitude install and post back. For the record, though, my /etc/apt/sources.list I have never enabled a stable repo for a dist-upgrade:

# deb cdrom:[Debian GNU/Linux 8.0.0 _Jessie_ - Official amd64 DVD Binary-1 20150425-12:54]/ jessie contrib main

# deb cdrom:[Debian GNU/Linux 8.0.0 _Jessie_ - Official amd64 DVD Binary-1 20150425-12:54]/ jessie contrib main

deb http://ftp.us.debian.org/debian/ testing main non-free contrib
deb-src http://ftp.us.debian.org/debian/ testing main

deb http://security.debian.org/ testing/updates main contrib
deb-src http://security.debian.org/ testing/updates main contrib

# jessie-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ testing-updates main contrib
deb-src http://ftp.us.debian.org/debian/ testing-updates main contrib
Bugs318
 
Posts: 31
Joined: 2010-05-25 18:48

Re: Upgrade Error

Postby Bugs318 » 2016-09-08 01:50

Just as with apt-get, aptitude says it will uninstall gnome and all network manager and vpn software.
Bugs318
 
Posts: 31
Joined: 2010-05-25 18:48

Re: Upgrade Error

Postby dilberts_left_nut » 2016-09-08 06:18

... and the other options?
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4658
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrade Error

Postby dasein » 2016-09-08 09:58

Bugs318 wrote:For the record... I have never enabled a stable repo for a dist-upgrade:

You have at least one package installed from Stable. It didn't spontaneously install itself, and I don't believe in gremlins. You report routinely performing a repo update followed by a dist-upgrade, and 30 seconds at Google strongly suggests that this issue is indeed unique to you.

Image

If aptitude can't come up with a solution, your path seems clear.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Next

Return to General Questions

Who is online

Users browsing this forum: peter_irich and 10 guests

fashionable