[SOLVED] Debian drive not in BIOS

If none of the more specific forums is the right place to ask

[SOLVED] Debian drive not in BIOS

Postby pawRoot » 2017-02-24 23:47

Hi

My current config:

1) SSD with Debian Stretch, Legacy mode, Grub2 edited to list Windows 10 aswell.
2) HDD with Windows 10, Legacy mode, with own bootloader.

Problem is, i go to BIOS to set SSD as first boot priority, but it's not there..., to be able to boot SSD i have to press F11 while booting my PC and select it on the list.

This is a weird problem and i'm not sure if it's Debian related or just stupid BIOS.

Any ideas? :roll:
Last edited by pawRoot on 2017-02-24 23:58, edited 1 time in total.
OS: Debian testing stretch
Kernel: x86_64 Linux 4.8.0-2-amd64
DE: Gnome
CPU: Intel Core i5-4690K CPU @ 3.9GHz
GPU: GeForce GTX 970/PCIe/SSE2
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 125
Joined: 2016-12-28 18:26
Location: Poland

Re: Debian drive not in BIOS

Postby bw123 » 2017-02-24 23:53

what shows up in bios if you disconnect the hdd?

MSI Z97 Gaming 3


Did you check out this mobo? uefi or other proprietary issues?
jessie/KDE4.14.2 plasma netbook, 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
User avatar
bw123
 
Posts: 2378
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Debian drive not in BIOS

Postby pawRoot » 2017-02-24 23:57

bw123 wrote:what shows up in bios if you disconnect the hdd?

MSI Z97 Gaming 3


Did you check out this mobo? uefi or other proprietary issues?


Fixed!

I disconnected the HDD, went into BIOS, and suddenly SSD was there

Thanks :)
OS: Debian testing stretch
Kernel: x86_64 Linux 4.8.0-2-amd64
DE: Gnome
CPU: Intel Core i5-4690K CPU @ 3.9GHz
GPU: GeForce GTX 970/PCIe/SSE2
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 125
Joined: 2016-12-28 18:26
Location: Poland

Re: [SOLVED] Debian drive not in BIOS

Postby bw123 » 2017-02-25 00:25

These msi machines are really awesome I saw three different models the other day side by side. Smoking hot, really nice builds, I'm glad to hear that debian works. I don't know, I sure would like to but wow, that'a lot of cash...
jessie/KDE4.14.2 plasma netbook, 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
User avatar
bw123
 
Posts: 2378
Joined: 2011-05-09 06:02
Location: TN_USA

Re: [SOLVED] Debian drive not in BIOS

Postby pawRoot » 2017-02-25 01:12

My MSI mobo was advertised as SteamOS ready (which is modified Debian), although i had sound problems with any Linux distro, and even on OS X.
I messaged MSI and they said it might be Realtek fault, anyway i ditched Linux for some time, and months later it suddenly started to work.

Anyway since that time i don't trust them so much :roll:
OS: Debian testing stretch
Kernel: x86_64 Linux 4.8.0-2-amd64
DE: Gnome
CPU: Intel Core i5-4690K CPU @ 3.9GHz
GPU: GeForce GTX 970/PCIe/SSE2
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 125
Joined: 2016-12-28 18:26
Location: Poland


Return to General Questions

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable