Broken packages in Jessie

If none of the more specific forums is the right place to ask

Broken packages in Jessie

Postby oldboy » 2017-02-25 16:02

I have been using testing since wheezy becomes stable. At the time, testing is Jessie. My sources.list has testing in all the lines. Since about June 2016, I have been having boot errors, and have done updates to try and correct them, but they persisted. However, the system still works as usual, so I just ignored the boot errors. I would like your help to fix them so I can have a clean system.
Here is what I have done. I changed my sources.list to replace testing with jessie. Update and dist-upgrade. Reboot and same error messages.

While booting, the error messages are
failed to start raise network interface, then
failed to start load kernel module, then
A start job is running for dev-disk-by ...... (1m 30s)
eventually it would boot.

Here are some details from dmesg:

Code: Select all
networking.service        loaded    failed   failed    Raise network interfaces
  NetworkManager-wait-online.service loaded    active   exited    Network Manager Wait Online
  NetworkManager.service    loaded    active   running   Network Manager


Code: Select all
 postgresql@9.4-main.service loaded    failed   failed    PostgreSQL Cluster 9.4-main
● postgresql@9.5-main.service loaded    failed   failed    PostgreSQL Cluster 9.5-main
  pppd-dns.service          loaded    inactive dead      Restore /etc/resolv.conf if the system crashe


Code: Select all
systemd-modules-load.service loaded    failed   failed    Load Kernel Modules
  systemd-quotacheck.service loaded    inactive dead      File System Quota Check
  systemd-random-seed.service loaded    active   exited    Load/Save Random Seed
  systemd-reboot.service    loaded    inactive dead      Reboot   
  systemd-remount-fs.service loaded    active   exited    Remount Root and Kernel File Systems
  systemd-rfkill.service    loaded    inactive dead      Load/Save RF Kill Switch Status
  systemd-sysctl.service    loaded    active   exited    Apply Kernel Variables
● systemd-sysusers.service  not-found inactive dead      systemd-sysusers.service
  systemd-timesyncd.service loaded    inactive dead      Network Time Synchronizatio


There are also a number of packages not found, here is a sample:
Code: Select all
apparmor.service          not-found inactive dead      apparmor.service
  apt-daily.service         loaded    inactive dead      Daily apt activities
  atd.service               loaded    active   running   Deferred execution scheduler
● auditd.service            not-found inactive dead      auditd.service
  auth-rpcgss-module.service loaded    inactive dead      Kernel Module supporting RPCSEC_GSS
  avahi-daemon.service      loaded    active   running   Avahi mDNS/DNS-SD Stack
  bind9.service             loaded    active   running   BIND Domain Name Server
  binfmt-support.service    loaded    active   exited    Enable support for additional executable bina
● clamav-daemon.service     not-found inactive dead      clamav-daemon.service


I looked at the Synaptic Module Manager, and there are no broken packages. However, In Aptitude, it shows there are 45 broken , and it is trying to resolve dependencies which went on for a long time, and I ended it.

Please advice what I can do. TIA.

Another thing that came up, my /boot is getting full. Here is the content. Can I delete all files relating to 3.16...4.7.0-1 since I am using 4.8.0-1?
Code: Select all
root@debian:/boot# ls
config-3.16.0-4-amd64      lost+found
config-3.16-2-amd64      System.map-3.16.0-4-amd64
config-4.3.0-1-amd64      System.map-3.16-2-amd64
config-4.4.0-1-amd64      System.map-4.3.0-1-amd64
config-4.5.0-1-amd64      System.map-4.4.0-1-amd64
config-4.5.0-2-amd64      System.map-4.5.0-1-amd64
config-4.6.0-1-amd64      System.map-4.5.0-2-amd64
config-4.7.0-1-amd64      System.map-4.6.0-1-amd64
config-4.8.0-1-amd64      System.map-4.7.0-1-amd64
grub            System.map-4.8.0-1-amd64
initrd.img-3.16.0-4-amd64  vmlinuz-3.16.0-4-amd64
initrd.img-3.16-2-amd64    vmlinuz-3.16-2-amd64
initrd.img-4.3.0-1-amd64   vmlinuz-4.3.0-1-amd64
initrd.img-4.4.0-1-amd64   vmlinuz-4.4.0-1-amd64
initrd.img-4.5.0-1-amd64   vmlinuz-4.5.0-1-amd64
initrd.img-4.5.0-2-amd64   vmlinuz-4.5.0-2-amd64
initrd.img-4.6.0-1-amd64   vmlinuz-4.6.0-1-amd64
initrd.img-4.7.0-1-amd64   vmlinuz-4.7.0-1-amd64
initrd.img-4.8.0-1-amd64   vmlinuz-4.8.0-1-amd64
root@debian:/boot#
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 684
Joined: 2007-08-09 12:45

Re: Broken packages in Jessie

Postby stevepusser » 2017-02-25 18:54

I suspect that testing was stretch for a long time before you changed it to jessie. As such, you really can't downgrade to jessie if you have a lot of Stretch packages--so I suggest you change "jessie" to "stretch" and wait until it goes stable.

You can get rid of the unused kernels' files in /boot. Have you also checked to make sure how many kernels you have installed?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.4, Pale Moon 27.3.0, Liquorix kernel 4.11-4, mpv 0.25.0, Kodi 17.1, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8220
Joined: 2009-10-06 05:53

Re: Broken packages in Jessie

Postby oldboy » 2017-02-25 23:22

I did leave the sources.list with testing, i.e., did not change anything. I did update and dist-upgrade, and it cannot boot. If I do nothing, leaving testing in, how would I go about correcting all the missing packages, and the broken packages identified ny aptitude?
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 684
Joined: 2007-08-09 12:45


Return to General Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable