Third pool php5-fpm is not working on debian 8

If none of the more specific forums is the right place to ask

Third pool php5-fpm is not working on debian 8

Postby anto60 » 2017-03-10 10:12

I have a problem on my debian 8 server: i have configurated three php-fpm pool but only two are working, on error log file i got the following messages (test2 is the name of pool with problem):

[proxy:error] [pid 579] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/run/php5-fpm-test2.sock (127.0.0.1) failed
proxy:error] [pid 579] AH00959: ap_proxy_connect_backend disabling worker for (127.0.0.1) for 60s
[proxy_fcgi:error] [pid 579] [client ip:59382] AH01079: failed to make connection to backend: httpd-UDS, referer: http://test2.it/info.php

I followed the recommendations of "High-performance PHP on apache httpd 2.4.x using mod_proxy_fcgi and php-fpm" on https://wiki.apache.org

This is the configuration of php-fpm pool:

; Start a new pool named 'www'.
; the variable $pool can we used in any directive and will be replaced by the
; pool name ('www' here)
[test2]
………………………………….
; Unix user/group of processes
; Note: The user is mandatory. If the group is not set, the default user's group
; will be used.
user = test2
group = test2
;user = www-data
;group = www-data
………………….
listen = /var/run/php5-fpm-test2.sock
…………………..
listen.owner = test2
listen.owner = test2
;listen.group = www-data
;listen.group = www-data
listen.mode = 0660

These are the output's check on my configuration:

1) service apache2 status:
● apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2)
Drop-In: /lib/systemd/system/apache2.service.d
└─forking.conf
Active: active (running) since ven 2017-03-10 11:32:17 CET; 2min 32s ago
Process: 445 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/apache2.service
├─510 /usr/sbin/apache2 -k start
├─576 /usr/sbin/apache2 -k start
├─577 /usr/sbin/apache2 -k start
├─579 /usr/sbin/apache2 -k start
├─582 /usr/sbin/apache2 -k start
└─583 /usr/sbin/apache2 -k start

mar 10 11:32:17 webtest apache2[445]: Starting web server: apache2.
mar 10 11:32:17 webtest systemd[1]: Started LSB: Apache2 web server.


2) service php5-fpm status:
php5-fpm.service - The PHP FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php5-fpm.service; enabled)
Active: active (running) since ven 2017-03-10 11:32:16 CET; 3min 24s ago
Process: 439 ExecStartPre=/usr/lib/php5/php5-fpm-checkconf (code=exited, status=0/SUCCESS)
Main PID: 598 (php5-fpm)
Status: "Processes active: 0, idle: 4, Requests: 0, slow: 0, Traffic: 0req/sec"
CGroup: /system.slice/php5-fpm.service
├─598 php-fpm: master process (/etc/php5/fpm/php-fpm.conf)
├─657 php-fpm: pool test1
├─658 php-fpm: pool test1
├─659 php-fpm: pool test2
└─660 php-fpm: pool test2

mar 10 11:32:14 webtest systemd[1]: Starting The PHP FastCGI Process Manager...
mar 10 11:32:16 webtest systemd[1]: Started The PHP FastCGI Process Manager.

3) ps aux | grep php:
root 653 0.0 0.8 409912 35748 ? Ss 10:08 0:00 php-fpm: master process (/etc/php5/fpm/php-fpm.conf)
test1 655 0.0 0.2 409904 10748 ? S 10:08 0:00 php-fpm: pool test1
test1 656 0.0 0.2 409904 10748 ? S 10:08 0:00 php-fpm: pool test1
www-data 657 0.0 0.2 409904 10752 ? S 10:08 0:00 php-fpm: pool test2
www-data 668 0.0 0.2 409904 10752 ? S 10:08 0:00 php-fpm: pool test2
root 860 0.0 0.0 12748 2160 pts/0 S+ 10:20 0:00 grep php

4) lsof -U | grep php
php5-fpm 598 root 6u unix 0xffff880036e1c400 0t0 10848 socket
php5-fpm 598 root 7u unix 0xffff8800bb3ab080 0t0 10849 socket
php5-fpm 598 root 8u unix 0xffff88013a416c00 0t0 10850 /var/run/php5-fpm-test1.sock
php5-fpm 598 root 9u unix 0xffff88013a416840 0t0 10853 /var/run/php5-fpm.sock
php5-fpm 657 test1 0u unix 0xffff88013a416c00 0t0 10850 /var/run/php5-fpm-test1.sock
php5-fpm 658 test1 0u unix 0xffff88013a416c00 0t0 10850 /var/run/php5-fpm-test1.sock
php5-fpm 659 www-data 0u unix 0xffff88013a416840 0t0 10853 /var/run/php5-fpm.sock
php5-fpm 660 www-data 0u unix 0xffff88013a416840 0t0 10853 /var/run/php5-fpm.sock

5) apache2ctl -S:
VirtualHost configuration:
*:80 is a NameVirtualHost
default server webtest.it (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost webtest.it (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost test1.it (/etc/apache2/sites-enabled/test1.conf:1)
port 80 namevhost test2.it (/etc/apache2/sites-enabled/test2.conf:1)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex proxy: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33
Group: name="www-data" id=33

Any help, please?
Thank you!

Antonino
anto60
 
Posts: 9
Joined: 2016-12-04 16:34

Re: Third pool php5-fpm is not working on debian 8

Postby anto60 » 2017-03-15 08:36

I have solved, it was an error of parameter listen on configuration of third php pool.

Bye.
anto60
 
Posts: 9
Joined: 2016-12-04 16:34


Return to General Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable