[Rasbian Jessie]MiniDLNA does not access a folder on Ext HDD

If none of the more specific forums is the right place to ask

[Rasbian Jessie]MiniDLNA does not access a folder on Ext HDD

Postby Cyrics » 2017-03-28 15:31


I use Rasbian Jessie on a Raspberry 3 Model B V1.2 and I have trouble with MiniDLNA, I want it to use a specific Folder on my external HDD.

Here's my config:

Code: Select all
# This is the configuration file for the MiniDLNA daemon, a DLNA/UPnP-AV media
# server.
# Unless otherwise noted, the commented out options show their default value.
# On Debian, you can also refer to the minidlna.conf(5) man page for
# documentation about this file.

# Specify the user name or uid to run as.

# Path to the directory you want scanned for media files.
# This option can be specified more than once if you want multiple directories
# scanned.
# If you want to restrict a media_dir to a specific content type, you can
# prepend the directory name with a letter representing the type (A, P or V),
# followed by a comma, as so:
#   * "A" for audio    (eg. media_dir=A,/var/lib/minidlna/music)
#   * "P" for pictures (eg. media_dir=P,/var/lib/minidlna/pictures)
#   * "V" for video    (eg. media_dir=V,/var/lib/minidlna/videos)


# Path to the directory that should hold the database and album art cache.

# Path to the directory that should hold the log file.

# Type and minimum level of importance of messages to be logged.
# The types are "artwork", "database", "general", "http", "inotify",
# "metadata", "scanner", "ssdp" and "tivo".
# The levels are "off", "fatal", "error", "warn", "info" or "debug".
# "off" turns of logging entirely, "fatal" is the highest level of importance
# and "debug" the lowest.
# The types are comma-separated, followed by an equal sign ("="), followed by a
# level that applies to the preceding types. This can be repeated, separating
# each of these constructs with a comma.
# The default is to log all types of messages at the "warn" level.

# Use a different container as the root of the directory tree presented to
# clients. The possible values are:
#   * "." - standard container
#   * "B" - "Browse Directory"
#   * "M" - "Music"
#   * "P" - "Pictures"
#   * "V" - "Video"
# If you specify "B" and the client device is audio-only then "Music/Folders"
# will be used as root.

# Network interface(s) to bind to (e.g. eth0), comma delimited.
# This option can be specified more than once.

# IPv4 address to listen on (e.g.
# If omitted, the mask defaults to 24. The IPs are added to those determined
# from the network_interface option above.
# This option can be specified more than once.

# Port number for HTTP traffic (descriptions, SOAP, media transfer).
# This option is mandatory (or it must be specified on the command-line using
# "-p").

# URL presented to clients (e.g. http://example.com:80).

# Name that the DLNA server presents to clients.
# Defaults to "hostname: username".

# Serial number the server reports to clients.
# Defaults to 00000000.

# Model name the server reports to clients.
model_name=Raspberry Pi

# Model number the server reports to clients.
# Defaults to the version number of minidlna.

# Automatic discovery of new files in the media_dir directory.

# List of file names to look for when searching for album art.
# Names should be delimited with a forward slash ("/").
# This option can be specified more than once.

# Strictly adhere to DLNA standards.
# This allows server-side downscaling of very large JPEG images, which may
# decrease JPEG serving performance on (at least) Sony DLNA products.

# Support for streaming .jpg and .mp3 files to a TiVo supporting HMO.

# Notify interval, in seconds.

# Path to the MiniSSDPd socket, for MiniSSDPd support.

I have verified that if I add a media_dir such as: /home/pi/Music, it works flawlessly but if I use "/media/pi/FTP/FileCenter/Media"
where FTP is my Ext-HDD, it doesn't work, it doesn't show/scan the files I put there

I thought when I installed MiniDLNA it will create a user as well and that user will not have access to the path above and here's what I tried so far:
Adding MiniDLNA to group: pi

and then
Code: Select all
sudo usermod -a -G pi minidlna
sudo chgrp -R pi /media/pi/FTP/FileCenter/Media
sudo chmod -R g+w /media/pi/FTP/FileCenter/Media
sudo find /media/pi/FTP/FileCenter/Media -type d -exec chmod 2775 {} \;   
sudo find /media/pi/FTP/FileCenter/Media -type f -exec chmod ug+rw {} \;
sudo service minidlna restart
sudo service minidlna force-reload

and no luck, any help please?
Posts: 1
Joined: 2017-03-28 15:20

Re: [Rasbian Jessie]MiniDLNA does not access a folder on Ext

Postby arochester » 2017-03-28 16:00

"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN." - oswaldkelso
Posts: 1184
Joined: 2010-12-07 19:55

Re: [Rasbian Jessie]MiniDLNA does not access a folder on Ext

Postby pylkko » 2017-03-28 19:22

maybe the user you are using cannot access the mount point because of the mounting settings?
User avatar
Posts: 1235
Joined: 2014-11-06 19:02

Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests