[SOLVED]Steam Install Worry - Will remove video driver, xser

If none of the more specific forums is the right place to ask

[SOLVED]Steam Install Worry - Will remove video driver, xser

Postby BrassMan » 2017-03-31 00:04

So I'm following the directions to install Steam according to https://wiki.debian.org/Steam#A64-bit_s ... 28amd64.29 - and when I go to install the 32-bit library, it warns me that it's going to remove a whole bunch of really important stuff:

Code: Select all
ryan@kepler:~$ sudo aptitude install libgl1-nvidia-glx:i386
[sudo] password for ryan:
The following NEW packages will be installed:
  glx-alternative-nvidia:i386{ab} glx-diversions:i386{ab} libatk1.0-0:i386{a} libaudit1:i386{a} libavahi-client3:i386{a} libavahi-common-data:i386{a}
  libavahi-common3:i386{a} libbz2-1.0:i386{a} libcairo2:i386{a} libcomerr2:i386{a} libcups2:i386{a} libdatrie1:i386{a} libdbus-1-3:i386{a} libegl1-mesa:i386{a}
  libegl1-mesa-drivers:i386{a} libegl1-nvidia:i386{a} libepoxy0:i386{ab} libfontconfig1:i386{a} libfontenc1:i386{a} libfreetype6:i386{a} libgbm1:i386{a} libgcrypt20:i386{a}
  libgdk-pixbuf2.0-0:i386{a} libgl1-nvidia-glx:i386 libgles1-nvidia:i386{a} libgles2-nvidia:i386{a} libglib2.0-0:i386{a} libgmp10:i386{a} libgnutls-deb0-28:i386{a}
  libgpg-error0:i386{a} libgraphite2-3:i386{a} libgssapi-krb5-2:i386{a} libgtk2.0-0:i386{a} libharfbuzz0b:i386{a} libhogweed2:i386{a} libjansson4:i386{a} libjasper1:i386{a}
  libjbig0:i386{a} libjpeg62-turbo:i386{a} libk5crypto3:i386{a} libkeyutils1:i386{a} libkrb5-3:i386{a} libkrb5support0:i386{a} liblzma5:i386{a} libnettle4:i386{a}
  libnvidia-eglcore:i386{ab} libnvidia-ml1:i386{ab} libopenvg1-mesa:i386{a} libp11-kit0:i386{a} libpango-1.0-0:i386{a} libpangocairo-1.0-0:i386{a} libpangoft2-1.0-0:i386{a}
  libpcre3:i386{a} libpixman-1-0:i386{a} libpng12-0:i386{a} libselinux1:i386{a} libtasn1-6:i386{a} libthai0:i386{a} libtiff5:i386{a} libvdpau1:i386{ab}
  libwayland-client0:i386{a} libwayland-egl1-mesa:i386{a} libwayland-server0:i386{a} libxcb-render0:i386{a} libxcb-shape0:i386{a} libxcb-shm0:i386{a} libxcb-xfixes0:i386{a}
  libxcomposite1:i386{a} libxcursor1:i386{a} libxfont1:i386{a} libxi6:i386{a} libxnvctrl0:i386{ab} libxrandr2:i386{a} libxrender1:i386{a} nvidia-alternative:i386{ab}
  nvidia-driver:i386{ab} nvidia-driver-bin:i386{ab} nvidia-kernel-common:i386{ab} nvidia-kernel-dkms:i386{ab} nvidia-modprobe:i386{ab} nvidia-settings:i386{ab}
  nvidia-vdpau-driver:i386{ab} pkg-config{a} xserver-xorg-core:i386{ab} xserver-xorg-video-nvidia:i386{ab}
0 packages upgraded, 85 newly installed, 0 to remove and 0 not upgraded.
Need to get 49.5 MB of archives. After unpacking 183 MB will be used.
The following packages have unmet dependencies:
 nvidia-alternative : Breaks: nvidia-driver:i386 (< 343.22-2~) but 340.101-1 is to be installed.
                      Conflicts: nvidia-alternative:i386 but 340.101-1 is to be installed.
 nvidia-alternative:i386 : Conflicts: nvidia-alternative but 375.26-1~bpo8+1 is installed.
 libnvidia-cfg1 : Breaks: libgl1-nvidia-glx:i386 (< 355.11-5) but 340.101-1 is to be installed.
 nvidia-driver : Conflicts: nvidia-driver:i386 but 340.101-1 is to be installed.
 nvidia-driver:i386 : Conflicts: nvidia-driver but 375.26-1~bpo8+1 is installed.
 libepoxy0 : Conflicts: libepoxy0:i386 but 1.2-1 is to be installed.
 libepoxy0:i386 : Conflicts: libepoxy0 but 1.2-1 is installed.
 libegl1-glvnd-nvidia : Conflicts: libegl1-nvidia:i386 but 340.101-1 is to be installed.
 xserver-xorg-video-nvidia : Breaks: glx-alternative-nvidia (< 0.6.91) but 0.7.3~bpo8+1 is installed.
                             Breaks: glx-alternative-nvidia:i386 (< 0.6.91) but 0.5.1 is to be installed.
                             Conflicts: xserver-xorg-video-nvidia:i386 but 340.101-1 is to be installed.
 xserver-xorg-video-nvidia:i386 : Conflicts: xserver-xorg-video-nvidia but 375.26-1~bpo8+1 is installed.
 nvidia-settings : Conflicts: nvidia-settings:i386 but 340.46-2 is to be installed.
 nvidia-settings:i386 : Conflicts: nvidia-settings but 375.26-3~bpo8+1 is installed.
 libnvidia-glcore : Breaks: libgl1-nvidia-glx:i386 (< 355.11-5) but 340.101-1 is to be installed.
 nvidia-modprobe : Conflicts: nvidia-modprobe:i386 but 340.46-1 is to be installed.
 nvidia-modprobe:i386 : Conflicts: nvidia-modprobe but 358.09-1~bpo8+1 is installed.
 xserver-xorg-core : Conflicts: xserver-xorg-core:i386 but 2:1.16.4-1 is to be installed.
 xserver-xorg-core:i386 : Conflicts: xserver-xorg-core but 2:1.16.4-1 is installed.
 libgles1-glvnd-nvidia : Breaks: libgles1-nvidia:i386 (< 361) but 340.101-1 is to be installed.
 nvidia-kernel-support : Breaks: glx-alternative-nvidia (< 0.6.91) but 0.7.3~bpo8+1 is installed.
                         Breaks: glx-alternative-nvidia:i386 (< 0.6.91) but 0.5.1 is to be installed.
 libgles2-glvnd-nvidia : Breaks: libgles2-nvidia:i386 (< 361) but 340.101-1 is to be installed.
 glx-diversions : Conflicts: glx-diversions:i386 but 0.5.1 is to be installed.
 glx-diversions:i386 : Conflicts: glx-diversions but 0.7.3~bpo8+1 is installed.
 nvidia-kernel-dkms : Conflicts: nvidia-kernel-dkms:i386 but 340.101-1 is to be installed.
 nvidia-kernel-dkms:i386 : Conflicts: nvidia-kernel-dkms but 375.26-1~bpo8+1 is installed.
 libnvidia-ml1 : Breaks: libnvidia-ml1:i386 (!= 375.26-1~bpo8+1) but 340.101-1 is to be installed.
 libnvidia-ml1:i386 : Breaks: libnvidia-ml1 (!= 340.101-1) but 375.26-1~bpo8+1 is installed.
 glx-alternative-nvidia : Breaks: nvidia-alternative (< 341) but 375.26-1~bpo8+1 is installed.
                          Breaks: nvidia-alternative:i386 (< 341) but 340.101-1 is to be installed.
                          Conflicts: glx-alternative-nvidia:i386 but 0.5.1 is to be installed.
 glx-alternative-nvidia:i386 : Conflicts: glx-alternative-nvidia but 0.7.3~bpo8+1 is installed.
 nvidia-vdpau-driver : Breaks: nvidia-vdpau-driver:i386 (!= 375.26-1~bpo8+1) but 340.101-1 is to be installed.
 nvidia-vdpau-driver:i386 : Breaks: nvidia-vdpau-driver (!= 340.101-1) but 375.26-1~bpo8+1 is installed.
 nvidia-driver-bin : Breaks: nvidia-driver:i386 (< 343.22-2~) but 340.101-1 is to be installed.
                     Conflicts: nvidia-driver-bin:i386 but 340.101-1 is to be installed.
 nvidia-driver-bin:i386 : Conflicts: nvidia-driver-bin but 375.26-1~bpo8+1 is installed.
 nvidia-kernel-common : Conflicts: nvidia-kernel-common:i386 but 20141201+1 is to be installed.
 nvidia-kernel-common:i386 : Conflicts: nvidia-kernel-common but 20151021+1~bpo8+1 is installed.
 libvdpau1 : Breaks: libvdpau1:i386 (!= 1.1.1-1~bpo8+1) but 0.8-3+deb8u2 is to be installed.
 libvdpau1:i386 : Breaks: libvdpau1 (!= 0.8-3+deb8u2) but 1.1.1-1~bpo8+1 is installed.
 libgl1-glvnd-nvidia-glx : Conflicts: libgl1-nvidia-glx:i386 but 340.101-1 is to be installed.
 libnvidia-eglcore : Breaks: libnvidia-eglcore:i386 (!= 375.26-1~bpo8+1) but 340.101-1 is to be installed.
 libnvidia-eglcore:i386 : Breaks: libnvidia-eglcore (!= 340.101-1) but 375.26-1~bpo8+1 is installed.
 libxnvctrl0 : Breaks: libxnvctrl0:i386 (!= 375.26-3~bpo8+1) but 340.46-2 is to be installed.
 libxnvctrl0:i386 : Conflicts: libxnvctrl0 but 375.26-3~bpo8+1 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                                                                   
1)      libepoxy0                                                                                     
2)      nvidia-driver                                                                                 
3)      nvidia-kernel-common                                                                           
4)      nvidia-kernel-dkms                                                                             
5)      nvidia-kernel-support                                                                         
6)      nvidia-modprobe                                                                               
7)      task-desktop                                                                                   
8)      task-lxde-desktop                                                                             
9)      xorg                                                                                           
10)     xserver-xorg                                                                                   
11)     xserver-xorg-core                                                                             
12)     xserver-xorg-input-all                                                                         
13)     xserver-xorg-input-evdev                                                                       
14)     xserver-xorg-input-mouse                                                                       
15)     xserver-xorg-input-synaptics                                                                   
16)     xserver-xorg-input-vmmouse                                                                     
17)     xserver-xorg-input-wacom                                                                       
18)     xserver-xorg-video-all                                                                         
19)     xserver-xorg-video-ati                                                                         
20)     xserver-xorg-video-cirrus                                                                     
21)     xserver-xorg-video-fbdev                                                                       
22)     xserver-xorg-video-intel                                                                       
23)     xserver-xorg-video-mach64                                                                     
24)     xserver-xorg-video-mga                                                                         
25)     xserver-xorg-video-modesetting                                                                 
26)     xserver-xorg-video-neomagic                                                                   
27)     xserver-xorg-video-nouveau                                                                     
28)     xserver-xorg-video-nvidia                                                                     
29)     xserver-xorg-video-openchrome                                                                 
30)     xserver-xorg-video-qxl                                                                         
31)     xserver-xorg-video-r128                                                                       
32)     xserver-xorg-video-radeon                                                                     
33)     xserver-xorg-video-savage                                                                     
34)     xserver-xorg-video-siliconmotion                                                               
35)     xserver-xorg-video-sisusb                                                                     
36)     xserver-xorg-video-tdfx                                                                       
37)     xserver-xorg-video-trident                                                                     
38)     xserver-xorg-video-vesa                                                                       
39)     xserver-xorg-video-vmware                                                                     

      Keep the following packages at their current version:                                           
40)     glx-alternative-nvidia:i386 [Not Installed]                                                   
41)     glx-diversions:i386 [Not Installed]                                                           
42)     libegl1-nvidia:i386 [Not Installed]                                                           
43)     libgl1-nvidia-glx:i386 [Not Installed]                                                         
44)     libgles1-nvidia:i386 [Not Installed]                                                           
45)     libgles2-nvidia:i386 [Not Installed]                                                           
46)     libnvidia-eglcore:i386 [Not Installed]                                                         
47)     libnvidia-ml1:i386 [Not Installed]                                                             
48)     libvdpau1:i386 [Not Installed]                                                                 
49)     libxnvctrl0:i386 [Not Installed]                                                               
50)     nvidia-alternative:i386 [Not Installed]                                                       
51)     nvidia-driver:i386 [Not Installed]                                                             
52)     nvidia-driver-bin:i386 [Not Installed]                                                         
53)     nvidia-settings:i386 [Not Installed]                                                           
54)     nvidia-vdpau-driver:i386 [Not Installed]                                                       
55)     xserver-xorg-video-nvidia:i386 [Not Installed]                                                 

      Leave the following dependencies unresolved:                                                     
56)     lightdm recommends xserver-xorg                                                               
57)     lxde recommends xserver-xorg                                                                   
58)     xinit recommends xserver-xorg | xserver                                                       
59)     xserver-xorg-input-all recommends xserver-xorg-input-wacom                                     
60)     nvidia-driver-bin recommends nvidia-driver                                                     
61)     nvidia-kernel-dkms recommends nvidia-driver (>= 375.26) | libcuda1 (>= 375.26)                 
62)     nvidia-vdpau-driver recommends nvidia-kernel-dkms (= 375.26-1~bpo8+1) | nvidia-kernel-375.26   
63)     nvidia-settings:i386 recommends libgl1-nvidia-glx:i386                                         
64)     nvidia-driver-bin:i386 recommends nvidia-driver:i386                                           
65)     nvidia-kernel-dkms:i386 recommends nvidia-driver:i386 (>= 340.101) | libcuda1:i386 (>= 340.101)
66)     xserver-xorg-video-nvidia:i386 recommends nvidia-driver:i386 (>= 340.101)                     


Accept this solution? [Y/n/q/?]


That doesn't seem right......can someone who knows a little more of what they're doing than I do help out? I don't want to screw up my system, especially after I just spent a couple hours figuring out how to get my displays to work properly & create an xorg.conf etc.. Any advice?
Last edited by BrassMan on 2017-03-31 20:47, edited 1 time in total.
BrassMan
 
Posts: 3
Joined: 2017-03-30 23:57

Re: Steam Install Worry - Will remove video driver, xserver

Postby stevepusser » 2017-03-31 00:55

The following packages have unmet dependencies:
nvidia-alternative : Breaks: nvidia-driver:i386 (< 343.22-2~) but 340.101-1 is to be installed.
Conflicts: nvidia-alternative:i386 but 340.101-1 is to be installed.
nvidia-alternative:i386 : Conflicts: nvidia-alternative but 375.26-1~bpo8+1 is installed.
libnvidia-cfg1 : Breaks: libgl1-nvidia-glx:i386 (< 355.11-5) but 340.101-1 is to be installed


It looks like you have messed around with jessie-backports, so what version of the Nvidia driver did you end up installing on 64-bit?

Also, aptitude offers multiple solutions to work around a mess with multiple versions, so try a few more before giving up.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.4, Pale Moon 27.3.0, Liquorix kernel 4.11-4, mpv 0.25.0, Kodi 17.1, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8217
Joined: 2009-10-06 05:53

Re: Steam Install Worry - Will remove video driver, xserver

Postby pendrachken » 2017-03-31 04:09

/!\ Installing the 32-bit OpenGL libraries may uninstall the 64-bit drivers you may have previously installed. Installing the AMD graphics or NVIDIA graphics drivers for your system is recommended. The appropriate OpenGL library will be installed along with those drivers. If you installed these drivers from jessie-backports be sure to also install the 32 bit library from jessie-backports.



Taken direct from the wiki page. Had another ask about the same thing a month ago or so and this took care of it.
fortune -o
Your love life will be... interesting.
:twisted: How did it know?

The U.S. uses the metric system too, we have tenths, hundredths and thousandths of inches :-P
pendrachken
 
Posts: 1250
Joined: 2007-03-04 21:10
Location: U.S.A. - WI.

Re: Steam Install Worry - Will remove video driver, xserver

Postby GarryRicketson » 2017-03-31 04:57

by BrassMan » I don't want to screw up my system, especially after I just spent a couple hours figuring out how to get my displays to work properly & create an xorg.conf etc.. Any advice?


I am not able to really give any advice on installing Steam, so I won't try on that,..
but, if you are really concerned about possibly screwing up your system, and
it is a very valid concern,
Murphies Law: If anything can go wrong it will (or something like that)

Before you go any further, make a good backup of you system, it is not that hard, but
if you need help on that, start another topic , and get that worked out first.
My kid did manage to install Steam, on his laptop, I did not help, and I don't use it
nor have on my computers,...but any way, I did help him make a good backup, and
he did actually end up using it a few times, before he finally got Steam installed and
working. So that is my advice,...take it or leave it, I don't really care.
From: https://en.wikipedia.org/wiki/Murphy's_lawThe contemporary form of Murphy's law goes back as far as 1952, as an epigraph to a mountaineering book by John Sack, who described it as an "ancient mountaineering adage":

Anything that can possibly go wrong, does.[9]
User avatar
GarryRicketson
 
Posts: 3861
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Steam Install Worry - Will remove video driver, xserver

Postby BrassMan » 2017-03-31 13:18

stevepusser wrote:It looks like you have messed around with jessie-backports, so what version of the Nvidia driver did you end up installing on 64-bit?

Also, aptitude offers multiple solutions to work around a mess with multiple versions, so try a few more before giving up.


I followed the instructions here https://wiki.debian.org/NvidiaGraphicsD ... ckports.29

pendrachken wrote:Taken direct from the wiki page. Had another ask about the same thing a month ago or so and this took care of it.


I had seen that but for some reason it didn't click last night. Now that I'm caffeinated, let me ask better questions XD

I am dual booting for the purpose of gaming on linux for a weekly stream dedicated to it. Due to that, I assumed the most recent driver would be the way to go. Should I undo those steps and go with the 340.96 driver from the regular non-free repo and hope it has everything I need? My other option is to force aptitude to use jessie-backports for the library - however, a (admittedly brief) look at the man page didn't turn up anything about choosing which repository to use (I'm assuming that's what the wiki means by what pendrachken quoted)

Thanks for all the responses!

EDIT I figured out the aptitude part by *gasp* further reading the man page and reviewing the steps I took so far. I'm assuming that the following would accomplish what I need:

Code: Select all
sudo aptitude install -t jessie-backports libgl1-nvidia-glx:i386


I'll give this a shot when I get home.
BrassMan
 
Posts: 3
Joined: 2017-03-30 23:57

Re: Steam Install Worry - Will remove video driver, xserver

Postby BrassMan » 2017-03-31 20:46

BrassMan wrote:...Thanks for all the responses!

EDIT I figured out the aptitude part by *gasp* further reading the man page and reviewing the steps I took so far. I'm assuming that the following would accomplish what I need:

Code: Select all
sudo aptitude install -t jessie-backports libgl1-nvidia-glx:i386


I'll give this a shot when I get home.


Alright, so as an update (I'll mark this thread as solved after posting) for anyone who finds this in the future:

I ran the command quoted above, and aptitude still wanted to take out some stuff I wasn't comfortable with. What I did (which stevepusser stated earlier) was hit "n" at the solutions prompt until I found something that didn't remove packages I felt were necessary to keep.

Thread TL/DR
- Make sure you're forcing aptitude to download from the same repo from which you got your original drivers, etc
- Cycle through proposed solutions and find something that works & won't bork your stuff :)

Thanks again for all the replies. Appreciate it!
BrassMan
 
Posts: 3
Joined: 2017-03-30 23:57


Return to General Questions

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable