Synaptic will not upgrade libjbig2dec0

If none of the more specific forums is the right place to ask

Synaptic will not upgrade libjbig2dec0

Postby mr.Lauren » 2017-04-01 20:10

I am dumbfounded! For several days I have been getting the notice that I needed to update libjbig2dec0. I was
preparing to post the following:
I have tried approximately 5 times to upgrade libjbig2dec0. This last time it has been going 24 hours! The
only way I can stop it is to reboot or kill synaptic from the System Monitor Process Table. My Operating System is
Debian 8.6.

A couple days ago I decided I would just uninstall libjbig2dec0. It proceeded to remind me that it would also remove a
gigantic list of programs including Gimp, Ocular ----- just a minute --- I'll kill this thing and expand the list.
There are 35 programs to be removed, including cups, evince, gimp, gnome, hplip, kde-standard, okular, 9
printer-drivers, including -gutenprint, -hpcups, and -postscript-hp. Besides that, it's going to install
foomatic-filters! Duuhhhh-----why bother, my operating system would be empty!


When I was about ready with the above, the upgrade notice returned. I noticed that it had a button with a label like
"Analysis" or "Review". I clicked it to get its input, and then saw another button "Apply", which I pressed. Five to
10 seconds later, it was done! I had discovered "Apper"!

I am left with the question "What is wrong with Synaptic?" Does it have a bug, or is it just my copy that has a bug?
Shall I remove it and re-install it? Thanks for any suggestions.
mr.Lauren
 
Posts: 68
Joined: 2006-10-20 22:50
Location: Cedar Rapids, IA

Re: Synaptic will not upgrade libjbig2dec0

Postby Thorny » 2017-04-02 12:23

mr.Lauren wrote:My Operating System is Debian 8.6. .....Thanks for any suggestions.

At this point, your system should probably be at version 8.7, mine is and I have seen other posts that suggest that is current. Maybe you should make sure your system is fully upgraded and then see if Synaptic still seems to have a bug.
Thorny
 
Posts: 275
Joined: 2011-02-27 13:40

Re: Synaptic will not upgrade libjbig2dec0

Postby debiman » 2017-04-03 18:13

i don't think synaptic is broken, but to give others (here on the forums) a better overview, it's better to use the command line:
Code: Select all
$ su
# apt-get update
# apt-get upgrade

...and if that doesn't go smoothly, also throw in
Code: Select all
cat /etc/apt/sources.list /etc/apt/sources.list.d/*
User avatar
debiman
 
Posts: 834
Joined: 2013-03-12 07:18

Re: Synaptic will not upgrade libjbig2dec0

Postby MALsPa » 2017-04-04 03:56

My Synaptic history shows libjbig2dec0 (0.11+20120125-1) upgraded to 0.13-4~deb8u1 on 3/26/17. That's in Debian 8.7. That's the current package, according to Debian Packages (https://packages.debian.org/search?keyw ... ection=all). Hope that helps.
MALsPa
 
Posts: 576
Joined: 2007-12-07 19:20
Location: albuquerque


Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable