Support for libstdc++.so.6.0.21 or higher on Jessie?

If none of the more specific forums is the right place to ask

Support for libstdc++.so.6.0.21 or higher on Jessie?

Postby HydraGene » 2017-04-02 11:35

So I have some issue running software. CloakCoin v2 needs libstdc++.so.6.0.21 or higher. Debian Jessie comes only with libstdc++.so.6.0.20.

I tried getting the file from Stretch, which is 6.0.22. I copied it to the right directory, and created a new symlink to it. The system continues running fine.

The software now tells me:
Code: Select all
/opt/Cloakcoin/cloakcoin-qt: symbol lookup error: /opt/Cloakcoin/cloakcoin-qt: undefined symbol: _ZNK18QAbstractListModel7siblingEiiRK11QModeIndex


Is this a solvable issue? Can anyone help me get CloakCoin v2 running? Upgrading to the Stretch version via apt-get or Synaptic requires me to upgrade the whole system to Stretch, which is not what I want..

I'll revert the libstdc++ version if there is nothing we can do about this..
HydraGene
 
Posts: 7
Joined: 2015-10-28 19:58

Re: Support for libstdc++.so.6.0.21 or higher on Jessie?

Postby sunrat » 2017-04-02 23:28

You may incur a world of pain changing core files such as this one. If you need to run software that needs the Stretch version, then do the full upgrade to Stretch.
https://wiki.debian.org/DontBreakDebian/
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 1866
Joined: 2006-08-29 09:12
Location: Melbourne, Australia


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable