Extra typographic characters with 3rd level chooser key

If none of the more specific forums is the right place to ask

Extra typographic characters with 3rd level chooser key

Postby mef » 2017-04-14 14:22

Hello everyone. I'm new to Debian and to Linux as well. Previous distributions that I have used were Ubuntu and Kubuntu. Both allowed to set a key to choose 3rd level characters and enable "extra typographic characters" in keyboard settings. Now I've installed Debian (Jessie) with LXDE, and can't find a way to set up this behavior. I've looked for solutions on the internet, but other than setting
Code: Select all
XKBOPTIONS="lv3:ralt_switch"
in /etc/default/keyboard or
Code: Select all
setxkbmap -option lv3:ralt_switch
in the terminal nothing can be found.
Even these options don't let me enter extra typographic characters.
How can I achieve it?
mef
 
Posts: 27
Joined: 2017-04-14 13:42

Re: Extra typographic characters with 3rd level chooser key

Postby debiman » 2017-04-15 04:30

i'm not quite sure i understood correctly; why are the above commands not satisfactory? do they not achieve what you want?

PS:
i like the implication that ubuntu is not linux. :wink:
User avatar
debiman
 
Posts: 1619
Joined: 2013-03-12 07:18

Re: Extra typographic characters with 3rd level chooser key

Postby mef » 2017-04-15 07:37

I guess, these commands set th 3rd level chooser, but to achieve my goal I need to also change the layout to one with special typography characters enabled. Because now when I type letters with Right Alt pressed i get those same letters and not special characters. Isn't there a special "en" layout with typography symbols (maybe something like that is used in Ubuntu)? Or maybe there's a way to create my own layout with the symbols that I need (modify the default layout)?
mef
 
Posts: 27
Joined: 2017-04-14 13:42

Re: Extra typographic characters with 3rd level chooser key

Postby mef » 2017-04-15 18:46

Well, I've come up with a solution that works. At least for now, I don't know, maybe it could potentially damage my installation (that would be a pity).

For those who are interested, here's my solution.
1. Edit the file /etc/default/keyboard so that the XKBOPTIONS include lv3:ralt_switch and misc:typo. Mine looks like this:
Code: Select all
XKBOPTIONS="grp:alt_shift_toggle,lv3:ralt_switch,misc:typo"

2. Place into /usr/share/X11/xkb/symbols directory the file "typo", which inludes Typographic Keyboard Layout by Sergei Stolyarov, which I took from the Kubuntu distribution (you can extract it yourself, download and run a LiveCD, then copy it out of /usr/share/X11/xkb/symbols, I am not allowed to attach it here).
3. Reboot.

It works for me. I can enter symbols like ™ (ralt+t), © (ralt+c), ←(ralt+(), — (ralt+-), etc.
This is the only feature that I missed in my Debian-LXDE installation. Now I'm happy and ready to use it as my primary OS.
I would appreciate any feedback, I'm worried that I could screw up my installation with this setup. :roll:
mef
 
Posts: 27
Joined: 2017-04-14 13:42


Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable