My secondary monitor not working after reboot

If none of the more specific forums is the right place to ask

My secondary monitor not working after reboot

Postby magisu » 2017-04-24 00:09

I am working on a thinkpad x1 carbon, together with a dell monitor. I had an upgrade with aptitude, and installed wine, and then restarted my laptop with sudo reboot on terminal. Now the secondary monitor is not working anymore. It might not be a hardware problem since during the reboot, I have not touched the HDMI cable, and it was working before the reboot.

I have my xrandr result attached here:
Code: Select all
Screen 0: minimum 320 x 200, current 2560 x 1440, maximum 8192 x 8192
eDP-1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 310mm x 174mm
   2560x1440     60.00*+
   1920x1440     60.00 
   1856x1392     60.01 
   1792x1344     60.01 
   1920x1200     59.95 
   1920x1080     59.93 
,,,,
   512x384       60.00 
   400x300       60.32    56.34 
   320x240       60.05 
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)


So obviously X11 did not detect the monitor. For the inspection, any idea where should I start?
magisu
 
Posts: 3
Joined: 2017-04-24 00:00

Re: My secondary monitor not working after reboot

Postby debiman » 2017-04-24 05:38

magisu wrote:
Code: Select all
,,,,


first things first:
i've never seen xrandr output commas like this.
are you sure you posted the full xrandr output?

the monitor is seen, but disconnected?

i would start by trying laptop-specific hotkeys, maybe Fn+F4?
User avatar
debiman
 
Posts: 1017
Joined: 2013-03-12 07:18

Re: My secondary monitor not working after reboot

Postby magisu » 2017-04-25 06:42

debiman wrote:
magisu wrote:
Code: Select all
,,,,


first things first:
i've never seen xrandr output commas like this.
are you sure you posted the full xrandr output?

the monitor is seen, but disconnected?

i would start by trying laptop-specific hotkeys, maybe Fn+F4?


For the xrandr issue, I am bypassing some of the resolutions to prevent putting a too long list.
On the other hand, the monitor is NOT seen, it was HDMI1 before.
magisu
 
Posts: 3
Joined: 2017-04-24 00:00

Re: My secondary monitor not working after reboot

Postby debiman » 2017-04-25 15:28

magisu wrote:On the other hand, the monitor is NOT seen, it was HDMI1 before.

but xrandr sees HDMI-1?
User avatar
debiman
 
Posts: 1017
Joined: 2013-03-12 07:18

Re: My secondary monitor not working after reboot

Postby magisu » 2017-04-26 09:02

debiman wrote:
magisu wrote:On the other hand, the monitor is NOT seen, it was HDMI1 before.

but xrandr sees HDMI-1?

No, it reported "disconnected"
magisu
 
Posts: 3
Joined: 2017-04-24 00:00


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable