grub timer problem

If none of the more specific forums is the right place to ask

grub timer problem

Postby pkladisios » 2017-05-04 12:01

Greetings! I am currently facing a minor problem with grub on a very old computer with debian 7.11. Timer is missing from the grub load screen. I have to physically select an option, else it will stay on the load screen.
I have found this thread, which i think is pertinent:

https://ubuntuforums.org/showthread.php?t=2267733

According to it, it might have something to do with a recordfail marker in /boot/grub/grubenv. Typing the following commands:

Code: Select all
sudo grub-editenv list


Code: Select all
sudo grub-editenv - unset recordfail


resolves the issue temporarily. If i reboot, timer and default option works fine. If i shut down and power the computer on again, grub reverts back to its previously static behavior. Any ideas?

grub version as given by:

Code: Select all
grub-install -v


is

Code: Select all
 grub-install (GRUB) 1.99-27+deb7u3


These are the contents of /etc/default/grub:

Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
pkladisios
 
Posts: 26
Joined: 2016-10-18 13:04

Re: grub timer problem

Postby wizard10000 » 2017-05-04 13:47

That's just weird.

You are running
Code: Select all
update-grub
as root after making changes to /etc/default/grub, yes?
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1187
Joined: 2011-05-09 20:02
Location: midwestern us

Re: grub timer problem

Postby Dai_trying » 2017-05-04 15:01

If you want to remove the timeout set it to -1 (GRUB_TIMEOUT=-1) and update grub and you should be set.
Dai_trying
 
Posts: 316
Joined: 2016-01-07 12:25

Re: grub timer problem

Postby wizard10000 » 2017-05-04 15:13

Dai_trying wrote:If you want to remove the timeout set it to -1 (GRUB_TIMEOUT=-1) and update grub and you should be set.


OT but I set mine to two seconds so I can get in there and grab a menu selection if I need to. I have byobu set to keep two kernels so if the new one breaks I have a fallback :)
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1187
Joined: 2011-05-09 20:02
Location: midwestern us

Re: grub timer problem

Postby Dai_trying » 2017-05-04 16:18

Looking back at the OP I can see I mis-read the original problem, sorry about that. :oops:
Dai_trying
 
Posts: 316
Joined: 2016-01-07 12:25

Re: grub timer problem

Postby debiman » 2017-05-04 16:27

i think grub does that (disable automatic booting after timeout) if something went wrong either at that moment or during the last boot or shutdown...
sorry it's a little vague.
closely watch the messages during startup/shutdown
User avatar
debiman
 
Posts: 1202
Joined: 2013-03-12 07:18

Re: grub timer problem

Postby pkladisios » 2017-05-04 16:40

@Dai_trying

I am trying to bring back the timer and default selection after timeout. It is highly inconvenient for remote control situations.

@wizard10000

True, but what changes must i do?

@debiman

From what i understand, that is most likely the case. I am currently away from said computer. Since the problem resurfaces after each shutdown, i'll check the messages during that time.
pkladisios
 
Posts: 26
Joined: 2016-10-18 13:04

Re: grub timer problem

Postby pkladisios » 2017-05-05 08:28

I've just attempted to read the shutdown messages. There weren't that many since it is a minimal installation. All i managed to read was about shutting down network and samba and unmounting swap file. I saw no errors of any kind.
pkladisios
 
Posts: 26
Joined: 2016-10-18 13:04


Return to General Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable