gpg problems on newly installed debian machines

If none of the more specific forums is the right place to ask

gpg problems on newly installed debian machines

Postby obry » 2017-05-08 09:01

tl:dr: I'm sure I have a public and secret key imported but engimail knows both my public and private key, but still I get "gpg: decryption failed: No secret key" from enigmail.

... pgp. What a mess :/

ok so here is my problem. I really hope someone knows how to fix this properly.


I have a pgp keypair in the file keys.asc. The contents are structured like this:
Code: Select all
-----BEGIN PGP PUBLIC KEY BLOCK-----

...blablabla...
-----END PGP PUBLIC KEY BLOCK-----
-----BEGIN PGP PRIVATE KEY BLOCK-----

....blublublub....
-----END PGP PRIVATE KEY BLOCK-----


I do
Code: Select all
b@bossy1312:~/Documents/pgp_sm$ gpg --import keys.asc
gpg: key ...: "... <...@...>" 1 new signature
gpg: key ...: "... <...@...>" not changed
gpg: key ...: secret key imported
gpg: Total number processed: 2
gpg:              unchanged: 1
gpg:         new signatures: 1
gpg:       secret keys read: 1
gpg:  secret keys unchanged: 1
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:   3  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   3  signed:   0  trust: 2-, 0q, 0n, 0m, 1f, 0u
gpg: next trustdb check due at 2017-06-28


It seems I imported both public and private keys before, which I have. ( It took me some time to get it so far, still...)

I installed thunderbird and enigmail (both via apt-get)
If i open an encrypted email I get:
Code: Select all
Error - decryption failed

gpg: decryption failed: No secret key

Note: The message is encrypted for the following User ID's / Keys:
  .... (... <...@...>),
  ... (... <...@...>)


Yet, in Enigmails keymanagement I see the key that received the message with bold print and the property "type" reads "key pair".
I have "ultimate" trust selected for the above keypair in enigmail.

:?
:(
obry
 
Posts: 53
Joined: 2013-10-05 12:51

Re: gpg problems on newly installed debian machines

Postby obry » 2017-05-14 17:48

the user thetablt on reddit solved it here:

https://www.reddit.com/r/debian/comment ... s/dhia56y/

solution is:

Code: Select all
sudo apt-get install pinentry-gtk2
sudo update-alternatives --set pinentry /usr/bin/pinentry-gtk-2


restart x and log out user and it works
obry
 
Posts: 53
Joined: 2013-10-05 12:51


Return to General Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable
cron