Aptitude upgrade: following packages will be REMOVED

If none of the more specific forums is the right place to ask

Aptitude upgrade: following packages will be REMOVED

Postby andmon » 2017-06-15 16:19

Dear all,

I am running Debian/Sid. After the last upgrade I get the following message
Code: Select all
root@debian:/home/andrea/Downloads# aptitude upgrade
The following packages will be REMOVED: 
  appstream-index{u} docutils-common{u} docutils-doc{u} espeak-data{u}
  firebird2.5-common{u} firebird2.5-common-doc{u} firebird2.5-server-common{u}
  firebird3.0-common{u} firebird3.0-common-doc{u} freespacenotifier{u}
  gdebi-core{u} htdig{u} imagemagick-common{u} iproute{u} kde-base-artwork{u}
  kde-style-oxygen{u} kde-window-manager{u} kde-workspace-kgreet-plugins{u}
  kdepimlibs-kio-plugins{u} kdm{u} libakonadi-kabc4{u} libakonadi-kcal4{u}
  libakonadi-notes4{u} libalgorithm-c3-perl{u} libamd2.3.1{u} libappstream1{u}
  libarchive-extract-perl{u} libasprintf0c2{u} libastro1{u} libavcodec56{u}
  libavresample2{u} libavutil54{u} libb-hooks-endofscope-perl{u} libbaloocore4{u}
  libbaloofiles4{u} libbaloopim4{u} libbalooqueryparser4{u} libbaloowidgets4{u}
  libbalooxapian4{u} libbasicusageenvironment0{u} libbind9-90{u}
  libboost-program-options1.55.0{u} libboost-system1.55.0{u}
  libboost-thread1.55.0{u} libcalendarsupport4{u} libcamd2.3.1{u}
  libcanberra-gtk3-0{u} libcanberra-gtk3-module{u} libccolamd2.8.0{u}
  libcholmod2.1.2{u} libchromaprint0{u} libclass-c3-perl{u} libclass-c3-xs-perl{u}
  libclass-method-modifiers-perl{u} libclass-xsaccessor-perl{u} libcolamd2.8.0{u}
  libcpan-changes-perl{u} libcpan-meta-perl{u} libdata-optlist-perl{u}
  libdata-perl-perl{u} libdata-section-perl{u} libdbus-1-dev{u}
  libdevel-caller-perl{u} libdevel-globaldestruction-perl{u}
  libdevel-lexalias-perl{u} libdns100{u} libdvbpsi9{u} libegl1-mesa-drivers{u}
  libelfg0{u} libenca0{u} libept1.4.12{u} libespeak1{u} libestools2.1{u}
  libexiv2-13{u} libexporter-tiny-perl{u} libfbclient2{u} libfbembed2.5{u}
  libfile-slurp-perl{u} libfollowupreminder4{u} libfreerdp-cache1.1{u}
  libfreerdp-client1.1{u} libfreerdp-codec1.1{u} libfreerdp-common1.1.0{u}
  libfreerdp-core1.1{u} libfreerdp-crypto1.1{u} libfreerdp-gdi1.1{u}
  libfreerdp-locale1.1{u} libfreerdp-primitives1.1{u} libfreerdp-rail1.1{u}
  libfreerdp-utils1.1{u} libgconf2-4{u} libgee-0.8-2{u}
  libgetopt-long-descriptive-perl{u} libgif4{u} libgles1-nvidia{u}
  libgles2-nvidia{u} libglew1.10{u} libgnome2-0{u} libgphoto2-port10{u}
  libgrantlee-core0{u} libgrantlee-gui0{u} libgroupsock1{u}
  libgstreamer-vaapi1.0-0{u} libhunspell-1.3-0{u} libical1a{u} libilmbase6{u}
  libimport-into-perl{u} libincidenceeditorsng4{u} libintl-perl{u}
  libintl-xs-perl{u} libio-stringy-perl{u} libisc95{u} libisccc90{u} libisccfg90{u}
  libjasper1{u} libjim0.75{u} libkactivities-models1{u} libkalarmcal2{u}
  libkateinterfaces4{u} libkblog4{u} libkcal4{u} libkdcraw-data{u} libkdcraw23{u}
  libkdecorations4abi2{u} libkdepim4{u} libkdepimdbusinterfaces4{u}
  libkdgantt2-0{u} libkephal4abi1{u} libkfilemetadata4{u} libkgapi2-2{u}
  libkimap4{u} libkleo4{u} libkmanagesieve4{u} libkmbox4{u}
  libkontactinterface4a{u} libkpgp4{u} libkscreen1{u} libkscreensaver5{u}
  libksieve4{u} libksignalplotter4{u} libktnef4{u} libkutils4{u}
  libkwineffects1abi5{u} libkwinglesutils1{u} libkwinglutils1abi2{u}
  liblircclient0{u} liblist-moreutils-perl{u} liblistaller-glib0{u}
  liblivemedia23{u} libllvm3.5{u} liblog-message-perl{u}
  liblog-message-simple-perl{u} liblwres90{u} libmarblewidget-qt5-25{u}
  libmessagecomposer4{u} libmessagecore4{u} libmessageviewer4{u}
  libmodemmanagerqt1{u} libmodule-build-perl{u} libmodule-implementation-perl{u}
  libmodule-load-conditional-perl{u} libmodule-pluggable-perl{u}
  libmodule-runtime-perl{u} libmodule-signature-perl{u} libmoo-perl{u}
  libmoox-handlesvia-perl{u} libmro-compat-perl{u} libmsn0.3{u}
  libmusicbrainz5-1{u} libmysqlclient18{u} libnamespace-autoclean-perl{u}
  libnamespace-clean-perl{u} libnetworkmanagerqt1{u} libnm-glib-vpn1{u}
  libnm-glib4{u} libnm-util2{u} libntdb1{u} liboath0{u} libokularcore5{u}
  libopenexr6{u} libopenjpeg5{u} libopenraw1{u} libopenvg1-mesa{u}
  liborcus-0.8-0{u} libpackage-constants-perl{u} libpackage-stash-perl{u}
  libpackage-stash-xs-perl{u} libpackagekitqt4-0{u} libpadwalker-perl{u}
  libparams-classify-perl{u} libparams-util-perl{u} libparams-validate-perl{u}
  libpath-tiny-perl{u} libpimcommon4{u} libplasmagenericshell4{u} libplist2{u}
  libpng12-0{u} libpod-latex-perl{u} libpod-markdown-perl{u} libpod-readme-perl{u}
  libpoppler46{u} libpostproc52{u} libprocessui4a{u} libpth20{u} libqapt-runtime{u}
  libqapt1{u} libqapt3{u} libqapt3-runtime{u} libqextserialport1{u} libqgpgme1{u}
  libqmi-glib1{u} libqoauth1{u} libqpdf13{u} libqt5positioning5{u}
  libqt5serialport5{u} libqtassistantclient4{u} libqtlocation1{u}
  libqtruby4shared2{u} libquazip1{u} libraw10{u} libregexp-common-perl{u}
  libreoffice-sdbc-firebird{u} librole-tiny-perl{u} libschroedinger-1.0-0{u}
  libsctp1{u} libsendlater4{u} libshp2{u} libsmokeqtdbus4-3{u}
  libsmokeqtopengl4-3{u} libsmokeqtsql4-3{u} libsmokeqtsvg4-3{u}
  libsmokeqtxml4-3{u} libsoftware-license-perl{u} libstreams0{u}
  libstrictures-perl{u} libsub-exporter-perl{u} libsub-exporter-progressive-perl{u}
  libsub-identify-perl{u} libsub-install-perl{u} libswscale3{u}
  libtemplateparser4{u} libterm-ui-perl{u} libtext-soundex-perl{u}
  libtext-template-perl{u} libtidy-0.99-0{u} libtommath0{u} libtry-tiny-perl{u}
  libturbojpeg1{u} libtype-tiny-perl{u} libtype-tiny-xs-perl{u} libumfpack5.6.2{u}
  libunicode-utf8-perl{u} libusageenvironment1{u} libusbmuxd2{u} libuuid-perl{u}
  libva-glx1{u} libvariable-magic-perl{u} libvpx1{u} libvte-2.90-9{u}
  libvte-2.90-common{u} libwebp5{u} libwebpdemux1{u} libwebpmux1{u}
  libwebrtc-audio-processing-0{u} libwinpr-crt0.1{u} libwinpr-crypto0.1{u}
  libwinpr-dsparse0.1{u} libwinpr-environment0.1{u} libwinpr-file0.1{u}
  libwinpr-handle0.1{u} libwinpr-heap0.1{u} libwinpr-input0.1{u}
  libwinpr-interlocked0.1{u} libwinpr-library0.1{u} libwinpr-path0.1{u}
  libwinpr-pool0.1{u} libwinpr-registry0.1{u} libwinpr-rpc0.1{u}
  libwinpr-sspi0.1{u} libwinpr-synch0.1{u} libwinpr-sysinfo0.1{u}
  libwinpr-thread0.1{u} libwinpr-utils0.1{u} libwps-0.3-3{u} libx264-142{u}
  libxapian22{u} libxcb-xtest0{u} libzip2{u} listaller{u} lksctp-tools{u}
  lockfile-progs{u} marble-data{u} marble-plugins{u} pkg-config{u}
  plasma-scriptengine-python{u} plasma-scriptengine-superkaramba{u}
  plasma-scriptengine-webkit{u} plasma-widget-folderview{u} python-cups{u}
  python-dbus{u} python-dbus-dev{u} python-defusedxml{u} python-docutils{u}
  python-gi{u} python-imaging{u} python-kde4{u} python-libxml2{u} python-pexpect{u}
  python-ptyprocess{u} python-qt4{u} python-qt4-dbus{u} python-renderpm{u}
  python-reportlab{u} python-reportlab-accel{u} python-roman{u} python-sip{u}
  python-smbc{u} python-soappy{u} python-wstools{u} python3-pykde4{u}
  python3-pyqt4{u} qapt-batch{u} ruby-qt4{u} vlc{u} vlc-l10n{u} vlc-nox{u}
  vlc-plugin-notify{u} vlc-plugin-qt{u} vlc-plugin-samba{u} vlc-plugin-skins2{u}
  vlc-plugin-video-splitter{u} vlc-plugin-visualization{u}
0 packages upgraded, 0 newly installed, 332 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 359 MB will be freed.
Do you want to continue? [Y/n/?] n


Clearly I do not want to remove all that stuff. Is there a way to fix that, please?
andmon
 
Posts: 58
Joined: 2008-06-24 07:12
Location: Milan (Italy)

Re: Aptitude upgrade: following packages will be REMOVED

Postby wizard10000 » 2017-06-15 17:02

andmon wrote:Clearly I do not want to remove all that stuff. Is there a way to fix that, please?


Sure there is. If an upgrade doesn't look safe don't upgrade :mrgreen:

If you're running Sid it's kinda expected that something like this would stop you in your tracks. You should have apt-listbugs, apt-listchanges and reportbug installed if you're running Unstable and should pay attention to output.

Chances are that packages are in transition. Try again tomorrow or the next day and things should look better - but today is the day packages will start to move from Sid to Buster instead of Stretch as it's now too late to get them into the new Stable. The package flood has started and you're going to have to pay extremely close attention to what apt offers to do to your machine.

But again, if an upgrade doesn't look safe leave it alone; when it does look safe then upgrade :)
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1182
Joined: 2011-05-09 20:02
Location: midwestern us

Re: Aptitude upgrade: following packages will be REMOVED

Postby andmon » 2017-06-16 07:39

Thank uou for your reply.

I am running Debian Sid for 15 years and that's the first time I've got this message. Anyway, for the moment I will not remove those packages!
andmon
 
Posts: 58
Joined: 2008-06-24 07:12
Location: Milan (Italy)

Re: Aptitude upgrade: following packages will be REMOVED

Postby roseway » 2017-06-16 10:22

Have you tried using apt instead of aptitude?
Eric
User avatar
roseway
 
Posts: 1473
Joined: 2007-12-31 22:50
Location: Kent, UK

Re: Aptitude upgrade: following packages will be REMOVED

Postby wizard10000 » 2017-06-16 12:20

andmon wrote:I am running Debian Sid for 15 years and that's the first time I've got this message.


Interesting. I've also run Sid for years and neither apt nor aptitude has offered to remove any of the KDE packages you have listed there. I also have VLC installed from Sid repos and it hasn't offered to break that either. My guess is there are some non-Debian repos enabled.
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1182
Joined: 2011-05-09 20:02
Location: midwestern us

Re: Aptitude upgrade: following packages will be REMOVED

Postby andmon » 2017-07-03 10:04

wizard10000 wrote:
andmon wrote:I am running Debian Sid for 15 years and that's the first time I've got this message.


Interesting. I've also run Sid for years and neither apt nor aptitude has offered to remove any of the KDE packages you have listed there. I also have VLC installed from Sid repos and it hasn't offered to break that either. My guess is there are some non-Debian repos enabled.


I've got only one row in my sources.list

deb http://ftp.de.debian.org/debian/ unstable main contrib non-free
andmon
 
Posts: 58
Joined: 2008-06-24 07:12
Location: Milan (Italy)

Re: Aptitude upgrade: following packages will be REMOVED

Postby andmon » 2017-07-03 10:06

roseway wrote:Have you tried using apt instead of aptitude?

Yes, I did. I got the same message. For the moment I am using apt-get ugrade to avoid removing those packages
andmon
 
Posts: 58
Joined: 2008-06-24 07:12
Location: Milan (Italy)


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable