apt-get install stucked by systemd-tty-ask-password-agent

If none of the more specific forums is the right place to ask

apt-get install stucked by systemd-tty-ask-password-agent

Postby jpmo » 2017-07-09 14:00

Hello,

I just created a new lxc container with debian/jessie . (the host is ubuntu 16.04.02)

First task was to update it (apt-get update ; apt-get upgrade ; reboot)
All worked fine and container is running.

Now I want to install a tool that is installing some basic packages.
But the installation is stucked with fail2ban :

Code: Select all
root      5406  0.0  0.8  70228 32708 ?        S+   20:28   0:09      \_ apt-get -y install locate tar telnet wget logrotate fail2ban dos2unix ntpdate htop iotop vim iftop s
root      6092  0.0  0.1  19604  4064 pts/0    Ss+  20:28   0:00          \_ /usr/bin/dpkg --status-fd 19 --configure libpopt0:amd64 libgpm2:amd64 libmagic1:amd64 libsqlite3
root      6439  0.0  0.0   4336  1532 pts/0    S+   20:29   0:00              \_ /bin/sh /var/lib/dpkg/info/fail2ban.postinst configure
root      6473  0.0  0.0   4336  1584 pts/0    S+   20:29   0:00                  \_ /bin/sh /usr/sbin/invoke-rc.d fail2ban start
root      6503  0.0  0.0  24172  2708 pts/0    S+   20:29   0:00                      \_ systemctl start fail2ban.service
root      6504  0.0  0.0  13176  1620 pts/0    S+   20:29   0:00                          \_ [b]/bin/systemd-tty-ask-password-agent --watch[/b]

Code: Select all
systemctl list-jobs
 JOB UNIT               TYPE    STATE
3409 dbus.service       start   waiting
3313 getty@tty1.service restart waiting
3361 getty@tty4.service restart waiting
3456 getty@tty3.service restart waiting
3265 getty@tty2.service restart waiting
3888 fail2ban.service   start   waiting


I can run systemctl daemon-reexec than seems to solve momentaly the issue.
Code: Select all
Setting up fail2ban (0.8.13-1) ...
Warning! D-Bus connection terminated.
Failed to wait for response: Success
invoke-rc.d: initscript fail2ban, action "start" failed.
dpkg: error processing package fail2ban (--configure):
 subprocess installed post-installation script returned error exit status 1

But later I have the same issue for rsync !

Running systemctl daemon-reexec can let the installation to go on but I have no idea what is the state fail2ban and rsync.

Worst than that, now installation is stucked but for dbus ! Not exactly same reason.
Code: Select all
root      7709  0.0  0.8  70184 32620 ?        S+   20:55   0:44      \_ apt-get -y install software-properties-common
root      7720  0.0  0.2  32832 10548 pts/0    Ss+  20:55   0:02          \_ /usr/bin/dpkg --status-fd 19 --unpack --auto-deconfigure /var/cache/apt/archives/libapt-inst1.5_
root      7987  0.0  0.0   4336   816 pts/0    S+   20:55   0:00              \_ /bin/sh /var/lib/dpkg/info/dbus.postinst triggered /etc/dbus-1/system.d /usr/share/dbus-1/sy
root      7988  0.0  0.0   8728   804 pts/0    S+   20:55   0:00                  \_ dbus-send --print-reply --system --type=method_call --dest=org.freedesktop.DBus / org.fr


In /var/log I have not found anything.
Not found something meaningful on internet about similar issue.

What is wrong with my fresh install ?
Where to investigate ?

TIA

JPM
jpmo
 
Posts: 2
Joined: 2017-07-09 13:31

Re: apt-get install stucked by systemd-tty-ask-password-agen

Postby jpmo » 2017-07-09 14:24

I rebooted my server.
Now each time I want to add a package, it tries to configure fail2ban and rsync and of course, I have same issue :
Code: Select all
dpkg --configure -a
Setting up python-apt-common (0.9.3.12) ...
Setting up fail2ban (0.8.13-1) ...
Failed to execute operation: Connection timed out
Warning! D-Bus connection terminated.
Failed to wait for response: Success
invoke-rc.d: initscript fail2ban, action "start" failed.
dpkg: error processing package fail2ban (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up iso-codes (3.57-1) ...
Setting up libglib2.0-0:amd64 (2.42.1-1+b1) ...
No schema files found: doing nothing.
Setting up lsb-release (4.1+Debian13+nmu1) ...
Setting up libgirepository-1.0-1:amd64 (1.42.0-2.2) ...
Setting up rsync (3.1.1-3) ...
Warning! D-Bus connection terminated.
Failed to wait for response: Success
invoke-rc.d: initscript rsync, action "restart" failed.
dpkg: error processing package rsync (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libpython3.4-minimal:amd64 (3.4.2-1) ...


I have to run systemctl daemon-reexec twice but nothing solved...
jpmo
 
Posts: 2
Joined: 2017-07-09 13:31


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable