Help with PacketFence?

If none of the more specific forums is the right place to ask

Help with PacketFence?

Postby pomtom44 » 2017-07-11 08:06

Hey everyone
Sorry if this isnt the right place to ask this, I have tried asking the developers but they seem to be real slow at replying, and I can't find anything on google to help me

I am trying to install packetFence on a VM
I have started with Debian 8.8 as they support it, and started the install process.
After a few issues (apt-key not downloading, and curl timing out) I quickly fixed those, but then had other problems.
So changed over to Debian 7, also supported, and tried again, but ran into other issues.

I was just wondering if anyone has been able to get it working, and if so, whats the magic tricks.

Im using a fresh build for both 8 and 7, nothing installed, and up to date.

Im happy to post logs of whats happening with either version if someone wants to try help me to get it to work.

Thanks in advance.
Tom
pomtom44
 
Posts: 2
Joined: 2017-07-11 08:01

Re: Help with PacketFence?

Postby TonyT » 2017-07-11 22:28

Well you don't state what specific issues you had, thus what kind of advice can you get here?
Curl should not be involved...
https://packetfence.org/support/faq/art ... no_cache=1
TonyT
 
Posts: 466
Joined: 2006-09-04 11:57

Re: Help with PacketFence?

Postby pomtom44 » 2017-07-12 01:36

Here is the rundown of what has happened, which I sent to their support mail-list (Still waiting for a reply from them)

First I installed Debian 8, updated everything and started the install instructions from here
https://packetfence.org/doc/PacketFence ... Guide.html
The first problem I kept running into was getting the key from keys.gnupg.net (kept timing out)
I fixed this by pinging the server and using the IP that it returned rather then the domain
(Although the domain worked fine this last time I did it while writing these notes)

The next problem is when downloading what I assume is the FingerBank Database
fingerbank_Upstream.db, always times out with the error
“curl: (18) transfer closed with 719998577 bytes remaining to read”
I have managed to fix it by going into
/var/lib/dpkg/info/fingerbank.postinst
and changing the curl command to the following
curl -o $FINGERBANK/db/fingerbank_Upstream.db https://fingerbank.inverse.ca/api/v1/download?key=${_APIKEY} --compressed
This allows it to shrink the file enough to download it.
(From aprox 1.5GB to 382MB)
This is where I am upto with Debian 8

first comes a long list of errors similar to this
insserv: warning: current start runlevel(s) (empty) of script `freeradius' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `freeradius' overrides LSB defaults (0 1 6).

Then
Could not write namespace config::
Could not write namespace interfaces
Quite a few lines of this

Followed by a few lines of
BEGIN failed--compilation aborted at /usr/local/pf/lib/pf/dal/iterator.pm line 19.
Compilation failed in require at /usr/local/pf/lib/pf/dal.pm line 25.

And finally
Job for packetfence-httpd.admin.service failed.

Full PasteBin Here
https://pastebin.com/ygpJ43nk

I have tried Debian 7 as well, and gotten different errors
(Cant remember which off the top of my head, but I can redo it if you need logs)

And the Virtual Appliance (OVF) file Imports fine into my VM
Then hangs on
A start job is running for dev-mapp...100.device
I have left it for half an hour which I know is excessive but nothing changed
pomtom44
 
Posts: 2
Joined: 2017-07-11 08:01


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable