[PARTLY SOLVED] NVIDIA Driver Won't Let My Computer Wake Up

If none of the more specific forums is the right place to ask

[PARTLY SOLVED] NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-20 02:49

I recently migrated from Jessie to Stretch. My favorite game (Pharaoh, under WINE) wouldn't work, and nvidia-detect suggested I install nvidia-driver, so I did.

My Power management options are set to Put computer to sleep when inactive for 10 minutes, and Put display to sleep when inactive for 10 minutes. So I walk away from my computer for at least that long, and then all is quiet.

But when I come back and press Ctrl, the processor box clicks and whirrs, with blue lights coming active, but the monitor stays dark. I can only get out of this state with the reset button.

There was a new strange bootup message:

[FAILED] Failed to start Load Kernel Modules.

A Google search suggested the command

systemctl status systemd-modules-load.service

which yielded, among other messages,

modprobe: FATAL: module nvidia-current-modeset not found in directory /lib/modules/4.9.0-3-amd64
modprobe: FATAL: module nvidia-current-drm not found in directory /lib/modules/4.9.0-3-amd64

I could not find any binaries with those names but I did find folders named nvidia-modeset and nvidia-drm under /var/lib/dkms/nvidia-current/375.66/source. Does that mean I'm looking at building from source? I've done that before but I'm not really comfortable with it.

Prior to installing nvidia-driver, allowing the computer to fall asleep and then waking it up worked fine. I could even shut the power at the power strip, turn it back on later, and wake the computer up (does this mean it was hibernating rather than just sleeping?)

Under Jessie (without nvidia-driver) I had no problem letting it hibernate and then waking it up again. But I couldn't tell it to hibernate now, that never worked -- I had to let it put itself to bed after 10 minutes.

Possibly related: another game, Quadrapassel, worked before I installed nvidia-driver, but now that I've installed it, Quadrapassel won't work at all. (But Pharaoh under WINE works fine now.)

I took system backups just before installing nvidia-driver so unupgrading this change is no problem. But I really want to get Pharaoh to work, and it's been a long time since this driver was upgraded, so I do want to make that happen.

Any suggestions?

Caitlin
Last edited by Caitlin on 2017-08-07 10:04, edited 1 time in total.
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby stevepusser » 2017-07-20 03:47

It would doubtless be helpful for us to know exactly how you went about installing the nvidia-driver. Even better if you (re)-installed it on the command line and posted the output.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8935
Joined: 2009-10-06 05:53

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-20 03:57

Steve,

I just did a normal apt-get install. I did a purge and a new install, to get the output:

Code: Select all
# apt-get purge nvidia-driver

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  nvidia-driver*
0 upgraded, 0 newly installed, 1 to remove and 6 not upgraded.
After this operation, 1,169 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 169403 files and directories currently installed.)
Removing nvidia-driver (375.66-1) ...

# apt-get install nvidia-driver --no-install-recommends

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Recommended packages:
  nvidia-settings nvidia-persistenced
The following NEW packages will be installed:
  nvidia-driver
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B/464 kB of archives.
After this operation, 1,169 kB of additional disk space will be used.
Selecting previously unselected package nvidia-driver.
(Reading database ... 169341 files and directories currently installed.)
Preparing to unpack .../nvidia-driver_375.66-1_amd64.deb ...
Unpacking nvidia-driver (375.66-1) ...
Setting up nvidia-driver (375.66-1) ...

Caitlin
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby stevepusser » 2017-07-20 16:42

What is your hardware? Do you possibly have a dual GPU system, like an Optimus laptop?

Still some things are lacking from what you are telling us...did you follow the wiki and install the compilers and kernel headers? The driver build will fail if those aren't installed.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8935
Joined: 2009-10-06 05:53

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-20 18:40

stevepusser wrote:What is your hardware? Do you possibly have a dual GPU system, like an Optimus laptop?

Still some things are lacking from what you are telling us...did you follow the wiki and install the compilers and kernel headers? The driver build will fail if those aren't installed.

What build? What wiki? All I know is that the installation of nvidia-driver was "recommended". I did an apt-get to install it; that, to me, is an installation.

I have build-essentials and gcc; what else do I need? Is a build really required? How come there was no mention of this before (in the docs I researched)?

I have a generic tower case with 2 CPUs; I think there are two graphics circuits; one on the motherboard and one on a daughterboard. They don't work together, however; the second replaces the first.

Do you need more detailed hardware info? Where do I get that?

Caitlin
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby stevepusser » 2017-07-21 03:57

Yes, the Debian wiki has a entry on the procedure to install a "Debianized" version of the proprietary Nvidia driver from the non-free section of the repo. Part of the procedure ends up installing a package on your system that will build a kernel module for the driver, and that requires the kernel headers. I suspected from the failure of the driver that it did not build correctly due to the lack of headers--that's why I was trying to pry the complete output of the commands from you, and I still don't think you gave the complete output.

To make sure you are set up to build modules, install module-assistant and run as root or with sudo:

Code: Select all
m-a prepare


For system information, I like inxi--install that and give the output of

Code: Select all
inxi -F


as the regular user, please.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8935
Joined: 2009-10-06 05:53

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-21 05:34

Dear Steve,

Let me make this totally clear in big shouty capitals: I DID NOT DO ANY BUILDS !

The ONLY commands I entered were "apt-get install nvidia-detect --no-install-recommends" and apt-get install nvidia-driver --no-install-recommends". The output of the second is posted 4 posts before this one. I never posted the output of the first one, but I can get it for you if you want it. There is no other output.

Shouldn't installing the binaries be enough?

I found the wiki you're talking about under https://wiki.debian.org/NvidiaGraphicsDrivers#CUDA and looked at it. (This, just a few minutes ago, is the first time I've ever seen the wiki.) I'll have to study it some more.

Here is the output of inxi:

Code: Select all
System:    Host: Blackbird Kernel: 4.9.0-3-amd64 x86_64 (64 bit)
           Desktop: MATE 1.16.2  Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop Mobo: Gigabyte model: GA-880GMA-USB3 v: x.x
           BIOS: Award v: F3 date: 10/20/2011
CPU:       Dual core AMD Athlon II X2 250 (-MCP-) cache: 2048 KB
           clock speeds: max: 3000 MHz 1: 1800 MHz 2: 1800 MHz
Graphics:  Card: NVIDIA GF108 [GeForce GT 430]
           Display Server: X.org 1.19.2 drivers: vesa,nouveau (unloaded: modesetting,fbdev)
           tty size: 80x24 Advanced Data: N/A for root
Audio:     Card-1 NVIDIA GF108 High Definition Audio Controller
           driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-3-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp3s0 state: up speed: 100 Mbps duplex: full
           mac: 50:e5:49:37:a8:50
Drives:    HDD Total Size: 2000.4GB (60.9% used)
           ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB
           ID-2: USB /dev/sdb model: 2115 size: 1000.2GB
Partition: ID-1: / size: 19G used: 4.5G (26%) fs: ext4 dev: /dev/sda7
           ID-2: /home size: 9.2G used: 2.6G (31%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 6.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda8
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 139 Uptime: 37 min Memory: 567.0/3953.6MB
           Init: systemd runlevel: 5 Client: Shell (bash) inxi: 2.3.5

Caitlin
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby stevepusser » 2017-07-21 17:16

Never heard ofthe wiki before? viewtopic.php?f=11&t=47078

sigh...

Also, nvidia-driver depends on nvidia-kernel-dkms (ref. https://packages.debian.org/stretch/nvidia-driver,) which automatically will try a BUILD of the source in the dkms package.
https://packages.debian.org/stretch/nvidia-kernel-dkms

You got a build failure in the output of the command when you installed nvidia-driver, but ignored it. That happens a lot. That's why I kept trying to get you to show the complete output!

Inxi also shows you are still running the free xorg nouveau driver, not the nvidia driver. This is no doubt due to the build failure. When it succeeds, you would see a message telling you that nouveau is blacklisted and advising a reboot.

Forget it...help yourself, read the wiki.

Your Wine issue is probably due to your running 64-bit, but the games are 32-bit, so you have to enable i386 multiarch and install the i386 openGL libraries. The Steam entry in the wiki shows how to do this.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8935
Joined: 2009-10-06 05:53

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-21 17:27

Steve,

I tried purge/install (both with and without --no-install-recommends) several times and didn't see any attempt to build anything. Believe me, whatever came out of apt-get I posted.

It's getting late here; I'll look at the wiki some more tomorrow.

Caitlin
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby cfb » 2017-07-22 06:16

You may be tricked by the fact that "nvidia-driver" is a meta package. Therefore, purging and installing it will not do much. If you read the Debian Wiki https://wiki.debian.org/NvidiaGraphicsDrivers#Backing_out_in_case_of_failure, you will see, that uninstalling should be done using the command
Code: Select all
# apt-get purge nvidia.
including the "dot" at the end.
Then reinstall "nvidia-driver" and check output for building errors, as Steve mentioned.
cfb
 
Posts: 20
Joined: 2017-01-08 16:39

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-22 16:05

cfb wrote:You may be tricked by the fact that "nvidia-driver" is a meta package. ...

I did the purge, and here's what I got:

Code: Select all
# apt-get purge nvidia.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'boinc-nvidia-cuda' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-fbc1' for regex 'nvidia.'
Note, selecting 'libnvidia-ptxjitcompiler' for regex 'nvidia.'
Note, selecting 'nvidia-325-updates' for regex 'nvidia.'
Note, selecting 'nvidia-346-updates' for regex 'nvidia.'
Note, selecting 'nvidia-driver-binary' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-smi' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-375.66' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-cuda1' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-304.135' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver-bin' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-375.66' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-340.102' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-mps' for regex 'nvidia.'
Note, selecting 'nvidia-support' for regex 'nvidia.'
Note, selecting 'libxvmcnvidia1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver-bin' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-support-any' for regex 'nvidia.'
Note, selecting 'libgles-nvidia1' for regex 'nvidia.'
Note, selecting 'libgles-nvidia2' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-common' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-alternative--kmod-alias' for regex 'nvidia.'
Note, selecting 'nvidia-glx' for regex 'nvidia.'
Note, selecting 'nvidia-cg-toolkit' for regex 'nvidia.'
Note, selecting 'libnvidia-ml1' for regex 'nvidia.'
Note, selecting 'nvidia-vulkan-icd' for regex 'nvidia.'
Note, selecting 'nvidia-driver-libs-i386' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver-libs' for regex 'nvidia.'
Note, selecting 'nvidia-egl-icd' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-340xx-glx-i386:i386' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-compiler' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-304.135' for regex 'nvidia.'
Note, selecting 'xserver-xorg-video-nvidia-any' for regex 'nvidia.'
Note, selecting 'nvidia-driver' for regex 'nvidia.'
Note, selecting 'nvidia-367-updates' for regex 'nvidia.'
Note, selecting 'xserver-xorg-video-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'nvidia-modprobe' for regex 'nvidia.'
Note, selecting 'nvidia-settings-legacy-340xx' for regex 'nvidia.'
Note, selecting 'libegl1-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'nvidia-texture-tools' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-ifr1' for regex 'nvidia.'
Note, selecting 'nvidia-alternative-legacy-173xx' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-cfg1' for regex 'nvidia.'
Note, selecting 'nvidia-xconfig' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-vdpau-driver' for regex 'nvidia.'
Note, selecting 'nvidia-alternative--kmod-alias' for regex 'nvidia.'
Note, selecting 'nvidia-349-updates' for regex 'nvidia.'
Note, selecting 'nvidia-vulkan-common' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-340.102' for regex 'nvidia.'
Note, selecting 'libnvidia-encode1' for regex 'nvidia.'
Note, selecting 'nvidia-310-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-smi' for regex 'nvidia.'
Note, selecting 'nvidia-331-updates' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-compiler' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-vdpau-driver' for regex 'nvidia.'
Note, selecting 'nvidia-vdpau-driver' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glvnd-glx' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-support' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-alternative--kmod-alias' for regex 'nvidia.'
Note, selecting 'libnvidia-cfg1-any' for regex 'nvidia.'
Note, selecting 'glvnd-nvidia-abi-375.20' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-304.135' for regex 'nvidia.'
Note, selecting 'libgles1-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'libglx-nvidia0' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-opencl-icd' for regex 'nvidia.'
Note, selecting 'nvidia-smi' for regex 'nvidia.'
Note, selecting 'nvidia-313-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-dkms' for regex 'nvidia.'
Note, selecting 'nvidia-334-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-source' for regex 'nvidia.'
Note, selecting 'nvidia-detect' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-opencl-icd' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-eglcore' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver-libs' for regex 'nvidia.'
Note, selecting 'libnvidia-egl-wayland-375.66' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-glcore' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-dkms' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver-libs-i386' for regex 'nvidia.'
Note, selecting 'nvidia-current-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-alternative' for regex 'nvidia.'
Note, selecting 'xserver-xorg-video-nvidia-legacy-304xx' for regex 'nvidia.'
Note, selecting 'libegl-nvidia0' for regex 'nvidia.'
Note, selecting 'nvidia-settings-legacy-304xx' for regex 'nvidia.'
Note, selecting 'nvidia-egl-common' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver-libs-i386' for regex 'nvidia.'
Note, selecting 'libnvidia-egl-wayland' for regex 'nvidia.'
Note, selecting 'nvidia-nsight' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-cuda1-i386' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx' for regex 'nvidia.'
Note, selecting 'nvidia-352-updates' for regex 'nvidia.'
Note, selecting 'libnvidia-cfg1' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-340xx-glx' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-check' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-cuda1-i386' for regex 'nvidia.'
Note, selecting 'nvidia-opencl-common' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-375.66' for regex 'nvidia.'
Note, selecting 'libnvidia-fatbinaryloader' for regex 'nvidia.'
Note, selecting 'libnvidia-fbc1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-304.135' for regex 'nvidia.'
Note, selecting 'nvidia-355-updates' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-any' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-304.135' for regex 'nvidia.'
Note, selecting 'libgles2-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-304xx-glx' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-support' for regex 'nvidia.'
Note, selecting 'nvidia-current' for regex 'nvidia.'
Note, selecting 'nvidia-profiler' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler' for regex 'nvidia.'
Note, selecting 'nvidia-337-updates' for regex 'nvidia.'
Note, selecting 'nvidia-358-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-340.102' for regex 'nvidia.'
Note, selecting 'nvidia-alternative-legacy-96xx' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-toolkit' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver' for regex 'nvidia.'
Note, selecting 'nvidia-driver-libs' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-source' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-support' for regex 'nvidia.'
Note, selecting 'nvidia-319-updates' for regex 'nvidia.'
Note, selecting 'nvidia-glx-any' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-nvcuvid1' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-375.66' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-encode1' for regex 'nvidia.'
Note, selecting 'nvidia-visual-profiler' for regex 'nvidia.'
Note, selecting 'nvidia-persistenced' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-i386:i386' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-340.102' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-304xx-glx-i386:i386' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-375.66' for regex 'nvidia.'
Note, selecting 'libnvidia-ifr1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-support--v1' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-glcore' for regex 'nvidia.'
Note, selecting 'nvidia-304-updates' for regex 'nvidia.'
Note, selecting 'nvidia-installer-cleanup' for regex 'nvidia.'
Note, selecting 'libgl1-glvnd-nvidia-glx' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-dev' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-doc' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-ml1' for regex 'nvidia.'
Note, selecting 'nvidia-340-updates' for regex 'nvidia.'
Note, selecting 'nvidia-361-updates' for regex 'nvidia.'
Note, selecting 'nvidia-libopencl1-dev' for regex 'nvidia.'
Note, selecting 'nvidia-opencl-dev' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-dkms' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-340.102' for regex 'nvidia.'
Note, selecting 'boinc-client-nvidia-cuda' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore-340.102' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-nvcuvid1' for regex 'nvidia.'
Note, selecting 'nvidia-cg-dev' for regex 'nvidia.'
Note, selecting 'nvidia-cg-doc' for regex 'nvidia.'
Note, selecting 'nvidia-libopencl1' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-gdb' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-304' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-310' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-313' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-319' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-325' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-331' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-334' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-337' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-340' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-343' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-346' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-349' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-352' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-355' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-358' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-361' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-364' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-367' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-alternative' for regex 'nvidia.'
Note, selecting 'nvidia-343-updates' for regex 'nvidia.'
Note, selecting 'nvidia-364-updates' for regex 'nvidia.'
Note, selecting 'nvidia-304' for regex 'nvidia.'
Note, selecting 'nvidia-310' for regex 'nvidia.'
Note, selecting 'nvidia-313' for regex 'nvidia.'
Note, selecting 'nvidia-319' for regex 'nvidia.'
Note, selecting 'nvidia-325' for regex 'nvidia.'
Note, selecting 'nvidia-331' for regex 'nvidia.'
Note, selecting 'nvidia-334' for regex 'nvidia.'
Note, selecting 'nvidia-337' for regex 'nvidia.'
Note, selecting 'nvidia-340' for regex 'nvidia.'
Note, selecting 'nvidia-343' for regex 'nvidia.'
Note, selecting 'nvidia-346' for regex 'nvidia.'
Note, selecting 'nvidia-349' for regex 'nvidia.'
Note, selecting 'nvidia-352' for regex 'nvidia.'
Note, selecting 'nvidia-355' for regex 'nvidia.'
Note, selecting 'nvidia-358' for regex 'nvidia.'
Note, selecting 'nvidia-361' for regex 'nvidia.'
Note, selecting 'nvidia-364' for regex 'nvidia.'
Note, selecting 'nvidia-367' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-cfg1' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-ml1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-support--v1' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-support--v1' for regex 'nvidia.'
Note, selecting 'nvidia-settings' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-cuda1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-source' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore-375.66' for regex 'nvidia.'
Note, selecting 'nvidia-opencl-icd' for regex 'nvidia.'
Note, selecting 'nvidia-alternative' for regex 'nvidia.'
Note, selecting 'libnvtt-bin' instead of 'nvidia-texture-tools'
Package 'nvidia-libopencl1-dev' is not installed, so not removed
Package 'nvidia-current' is not installed, so not removed
Package 'nvidia-current-updates' is not installed, so not removed
Package 'boinc-nvidia-cuda' is not installed, so not removed
Package 'nvidia-driver-binary' is not installed, so not removed
Package 'nvidia-304' is not installed, so not removed
Package 'nvidia-304-updates' is not installed, so not removed
Package 'nvidia-experimental-304' is not installed, so not removed
Package 'nvidia-310' is not installed, so not removed
Package 'nvidia-310-updates' is not installed, so not removed
Package 'nvidia-experimental-310' is not installed, so not removed
Package 'nvidia-313' is not installed, so not removed
Package 'nvidia-313-updates' is not installed, so not removed
Package 'nvidia-experimental-313' is not installed, so not removed
Package 'nvidia-319' is not installed, so not removed
Package 'nvidia-319-updates' is not installed, so not removed
Package 'nvidia-experimental-319' is not installed, so not removed
Package 'nvidia-325' is not installed, so not removed
Package 'nvidia-325-updates' is not installed, so not removed
Package 'nvidia-experimental-325' is not installed, so not removed
Package 'nvidia-331' is not installed, so not removed
Package 'nvidia-331-updates' is not installed, so not removed
Package 'nvidia-experimental-331' is not installed, so not removed
Package 'nvidia-334' is not installed, so not removed
Package 'nvidia-334-updates' is not installed, so not removed
Package 'nvidia-experimental-334' is not installed, so not removed
Package 'nvidia-337' is not installed, so not removed
Package 'nvidia-337-updates' is not installed, so not removed
Package 'nvidia-experimental-337' is not installed, so not removed
Package 'nvidia-340' is not installed, so not removed
Package 'nvidia-340-updates' is not installed, so not removed
Package 'nvidia-experimental-340' is not installed, so not removed
Package 'nvidia-343' is not installed, so not removed
Package 'nvidia-343-updates' is not installed, so not removed
Package 'nvidia-experimental-343' is not installed, so not removed
Package 'nvidia-346' is not installed, so not removed
Package 'nvidia-346-updates' is not installed, so not removed
Package 'nvidia-experimental-346' is not installed, so not removed
Package 'nvidia-349' is not installed, so not removed
Package 'nvidia-349-updates' is not installed, so not removed
Package 'nvidia-experimental-349' is not installed, so not removed
Package 'nvidia-352' is not installed, so not removed
Package 'nvidia-352-updates' is not installed, so not removed
Package 'nvidia-experimental-352' is not installed, so not removed
Package 'nvidia-355' is not installed, so not removed
Package 'nvidia-355-updates' is not installed, so not removed
Package 'nvidia-experimental-355' is not installed, so not removed
Package 'nvidia-358' is not installed, so not removed
Package 'nvidia-358-updates' is not installed, so not removed
Package 'nvidia-experimental-358' is not installed, so not removed
Package 'nvidia-361' is not installed, so not removed
Package 'nvidia-361-updates' is not installed, so not removed
Package 'nvidia-experimental-361' is not installed, so not removed
Package 'nvidia-364' is not installed, so not removed
Package 'nvidia-364-updates' is not installed, so not removed
Package 'nvidia-experimental-364' is not installed, so not removed
Package 'nvidia-367' is not installed, so not removed
Package 'nvidia-367-updates' is not installed, so not removed
Package 'nvidia-experimental-367' is not installed, so not removed
Package 'nvidia-alternative-legacy-173xx' is not installed, so not removed
Package 'nvidia-alternative-legacy-96xx' is not installed, so not removed
Note, selecting 'nvidia-kernel-dkms' instead of 'nvidia-kernel-375.66'
Note, selecting 'libgldispatch0-nvidia' instead of 'glvnd-nvidia-abi-375.20'
Note, selecting 'libnvidia-compiler' instead of 'libnvidia-compiler-375.66'
Note, selecting 'libnvidia-egl-wayland' instead of 'libnvidia-egl-wayland-375.66'
Note, selecting 'libnvidia-eglcore' instead of 'libnvidia-eglcore-375.66'
Package 'libgl1-nvidia-glx-375.66' is not installed, so not removed
Note, selecting 'libnvidia-glcore' instead of 'libnvidia-glcore-375.66'
Note, selecting 'nvidia-alternative' instead of 'nvidia-alternative--kmod-alias'
Package 'nvidia-glx' is not installed, so not removed
Note, selecting 'nvidia-driver-bin' instead of 'nvidia-driver-bin-375.66'
Note, selecting 'nvidia-driver-libs-i386:i386' instead of 'nvidia-driver-libs-i386'
Note, selecting 'nvidia-kernel-support' instead of 'nvidia-kernel-support--v1'
Package 'libxvmcnvidia1' is not installed, so not removed
Note, selecting 'nvidia-legacy-304xx-kernel-dkms' instead of 'nvidia-legacy-304xx-kernel-304.135'
Note, selecting 'libnvidia-legacy-304xx-compiler' instead of 'libnvidia-compiler-304.135'
Note, selecting 'libnvidia-legacy-304xx-cuda1-i386:i386' instead of 'libnvidia-legacy-304xx-cuda1-i386'
Package 'libgl1-nvidia-glx-304.135' is not installed, so not removed
Note, selecting 'libnvidia-legacy-304xx-glcore' instead of 'libnvidia-glcore-304.135'
Note, selecting 'nvidia-legacy-304xx-alternative' instead of 'nvidia-legacy-304xx-alternative--kmod-alias'
Note, selecting 'nvidia-legacy-304xx-driver-bin' instead of 'nvidia-driver-bin-304.135'
Note, selecting 'nvidia-legacy-304xx-driver-libs-i386:i386' instead of 'nvidia-legacy-304xx-driver-libs-i386'
Note, selecting 'nvidia-legacy-304xx-kernel-support' instead of 'nvidia-legacy-304xx-kernel-support--v1'
Note, selecting 'nvidia-legacy-340xx-kernel-dkms' instead of 'nvidia-legacy-340xx-kernel-340.102'
Note, selecting 'libnvidia-legacy-340xx-compiler' instead of 'libnvidia-compiler-340.102'
Note, selecting 'libnvidia-legacy-340xx-cuda1-i386:i386' instead of 'libnvidia-legacy-340xx-cuda1-i386'
Note, selecting 'libnvidia-legacy-340xx-eglcore' instead of 'libnvidia-eglcore-340.102'
Package 'libgl1-nvidia-glx-340.102' is not installed, so not removed
Note, selecting 'libnvidia-legacy-340xx-glcore' instead of 'libnvidia-glcore-340.102'
Note, selecting 'nvidia-legacy-340xx-alternative' instead of 'nvidia-legacy-340xx-alternative--kmod-alias'
Note, selecting 'nvidia-legacy-340xx-driver-bin' instead of 'nvidia-driver-bin-340.102'
Note, selecting 'nvidia-legacy-340xx-driver-libs-i386:i386' instead of 'nvidia-legacy-340xx-driver-libs-i386'
Note, selecting 'nvidia-legacy-340xx-kernel-support' instead of 'nvidia-legacy-340xx-kernel-support--v1'
Package 'libgl1-nvidia-glx-i386:i386' is not installed, so not removed
Package 'libgl1-nvidia-legacy-304xx-glx-i386:i386' is not installed, so not removed
Package 'libgl1-nvidia-legacy-340xx-glx-i386:i386' is not installed, so not removed
Package 'boinc-client-nvidia-cuda' is not installed, so not removed
Package 'nvidia-persistenced' is not installed, so not removed
Package 'nvidia-settings' is not installed, so not removed
Package 'nvidia-settings-legacy-304xx' is not installed, so not removed
Package 'nvidia-settings-legacy-340xx' is not installed, so not removed
Package 'nvidia-xconfig' is not installed, so not removed
Package 'nvidia-cg-dev' is not installed, so not removed
Package 'nvidia-cg-doc' is not installed, so not removed
Package 'nvidia-cg-toolkit' is not installed, so not removed
Package 'nvidia-cuda-dev' is not installed, so not removed
Package 'nvidia-cuda-doc' is not installed, so not removed
Package 'nvidia-cuda-gdb' is not installed, so not removed
Package 'nvidia-cuda-toolkit' is not installed, so not removed
Package 'nvidia-nsight' is not installed, so not removed
Package 'nvidia-opencl-dev' is not installed, so not removed
Package 'nvidia-profiler' is not installed, so not removed
Package 'nvidia-visual-profiler' is not installed, so not removed
Package 'libgl1-nvidia-glx' is not installed, so not removed
Package 'libgles-nvidia1' is not installed, so not removed
Package 'libgles-nvidia2' is not installed, so not removed
Package 'libnvidia-cfg1' is not installed, so not removed
Package 'libnvidia-compiler' is not installed, so not removed
Package 'libnvidia-egl-wayland' is not installed, so not removed
Package 'libnvidia-encode1' is not installed, so not removed
Package 'libnvidia-fatbinaryloader' is not installed, so not removed
Package 'libnvidia-fbc1' is not installed, so not removed
Package 'libnvidia-ifr1' is not installed, so not removed
Package 'libnvidia-ptxjitcompiler' is not installed, so not removed
Package 'nvidia-cuda-mps' is not installed, so not removed
Package 'nvidia-driver' is not installed, so not removed
Package 'nvidia-kernel-source' is not installed, so not removed
Package 'nvidia-libopencl1' is not installed, so not removed
Package 'nvidia-opencl-common' is not installed, so not removed
Package 'nvidia-opencl-icd' is not installed, so not removed
Package 'nvidia-smi' is not installed, so not removed
Package 'nvidia-vulkan-common' is not installed, so not removed
Package 'nvidia-vulkan-icd' is not installed, so not removed
Package 'libgl1-nvidia-legacy-304xx-glx' is not installed, so not removed
Package 'libnvidia-legacy-304xx-cfg1' is not installed, so not removed
Package 'libnvidia-legacy-304xx-compiler' is not installed, so not removed
Package 'libnvidia-legacy-304xx-cuda1' is not installed, so not removed
Package 'libnvidia-legacy-304xx-glcore' is not installed, so not removed
Package 'libnvidia-legacy-304xx-ml1' is not installed, so not removed
Package 'libnvidia-legacy-304xx-nvcuvid1' is not installed, so not removed
Package 'nvidia-legacy-304xx-alternative' is not installed, so not removed
Package 'nvidia-legacy-304xx-driver' is not installed, so not removed
Package 'nvidia-legacy-304xx-driver-bin' is not installed, so not removed
Package 'nvidia-legacy-304xx-driver-libs' is not installed, so not removed
Package 'nvidia-legacy-304xx-kernel-dkms' is not installed, so not removed
Package 'nvidia-legacy-304xx-kernel-source' is not installed, so not removed
Package 'nvidia-legacy-304xx-kernel-support' is not installed, so not removed
Package 'nvidia-legacy-304xx-opencl-icd' is not installed, so not removed
Package 'nvidia-legacy-304xx-smi' is not installed, so not removed
Package 'nvidia-legacy-304xx-vdpau-driver' is not installed, so not removed
Package 'xserver-xorg-video-nvidia-legacy-304xx' is not installed, so not removed
Package 'libegl1-nvidia-legacy-340xx' is not installed, so not removed
Package 'libgl1-nvidia-legacy-340xx-glx' is not installed, so not removed
Package 'libgles1-nvidia-legacy-340xx' is not installed, so not removed
Package 'libgles2-nvidia-legacy-340xx' is not installed, so not removed
Package 'libnvidia-legacy-340xx-cfg1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-compiler' is not installed, so not removed
Package 'libnvidia-legacy-340xx-cuda1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-eglcore' is not installed, so not removed
Package 'libnvidia-legacy-340xx-encode1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-fbc1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-glcore' is not installed, so not removed
Package 'libnvidia-legacy-340xx-ifr1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-ml1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-nvcuvid1' is not installed, so not removed
Package 'nvidia-legacy-340xx-alternative' is not installed, so not removed
Package 'nvidia-legacy-340xx-driver' is not installed, so not removed
Package 'nvidia-legacy-340xx-driver-bin' is not installed, so not removed
Package 'nvidia-legacy-340xx-driver-libs' is not installed, so not removed
Package 'nvidia-legacy-340xx-kernel-dkms' is not installed, so not removed
Package 'nvidia-legacy-340xx-kernel-source' is not installed, so not removed
Package 'nvidia-legacy-340xx-kernel-support' is not installed, so not removed
Package 'nvidia-legacy-340xx-opencl-icd' is not installed, so not removed
Package 'nvidia-legacy-340xx-smi' is not installed, so not removed
Package 'nvidia-legacy-340xx-vdpau-driver' is not installed, so not removed
Package 'xserver-xorg-video-nvidia-legacy-340xx' is not installed, so not removed
The following packages will be REMOVED:
  glx-alternative-nvidia* glx-diversions* libegl-nvidia0*
  libegl1-glvnd-nvidia* libgl1-glvnd-nvidia-glx* libgl1-nvidia-glvnd-glx*
  libglx-nvidia0* libglx0-glvnd-nvidia* libnvidia-eglcore* libnvidia-glcore*
  libnvidia-ml1* nvidia-alternative* nvidia-detect* nvidia-driver-bin*
  nvidia-driver-libs* nvidia-egl-common* nvidia-egl-icd*
  nvidia-installer-cleanup* nvidia-kernel-common* nvidia-kernel-dkms*
  nvidia-kernel-support* nvidia-legacy-check* nvidia-modprobe* nvidia-support*
  nvidia-vdpau-driver* xserver-xorg-video-nvidia*
0 upgraded, 0 newly installed, 26 to remove and 6 not upgraded.
After this operation, 111 MB disk space will be freed.
Do you want to continue? [Y/n]
y
(Reading database ... 169524 files and directories currently installed.)
Removing xserver-xorg-video-nvidia (375.66-1) ...
Removing nvidia-kernel-dkms (375.66-1) ...

------------------------------
Deleting module version: 375.66
completely from the DKMS tree.
------------------------------
Done.
Removing nvidia-kernel-support (375.66-1) ...
Removing nvidia-vdpau-driver:amd64 (375.66-1) ...
Removing nvidia-driver-libs:amd64 (375.66-1) ...
Removing nvidia-egl-icd:amd64 (375.66-1) ...
Removing libegl-nvidia0:amd64 (375.66-1) ...
Removing libegl1-glvnd-nvidia:amd64 (375.66-1) ...
Removing libgl1-nvidia-glvnd-glx:amd64 (375.66-1) ...
Removing libgl1-glvnd-nvidia-glx:amd64 (375.66-1) ...
Removing libglx-nvidia0:amd64 (375.66-1) ...
Removing libglx0-glvnd-nvidia:amd64 (375.66-1) ...
Removing libnvidia-eglcore:amd64 (375.66-1) ...
Removing libnvidia-glcore:amd64 (375.66-1) ...
Removing nvidia-driver-bin (375.66-1) ...
Removing libnvidia-ml1:amd64 (375.66-1) ...
Removing nvidia-detect (375.66-1) ...
Removing nvidia-egl-common (375.66-1) ...
Removing nvidia-kernel-common (20151021+4) ...
Removing nvidia-modprobe (375.26-1) ...
Removing nvidia-support (20151021+4) ...
Removing nvidia-alternative (375.66-1) ...
Removing glx-alternative-nvidia (0.7.4) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/nvidia because link group glx is broken
update-alternatives: warning: skip creation of /usr/lib/x86_64-linux-gnu/libEGL.so.1 because associated file /usr/lib/x86_64-linux-gnu/nvidia/libEGL.so.1 (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /usr/lib/x86_64-linux-gnu/libGL.so.1 because associated file /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1 (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /usr/lib/xorg/modules/linux/libglx.so because associated file /usr/lib/nvidia/libglx.so (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /etc/modprobe.d/nvidia-blacklists-nouveau.conf because associated file /etc/nvidia/nvidia-blacklists-nouveau.conf (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /usr/bin/nvidia-bug-report.sh because associated file /usr/lib/nvidia/nvidia-bug-report.sh (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass.conf because associated file /etc/nvidia/nvidia-drm-outputclass.conf (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /etc/modules-load.d/nvidia.conf because associated file /etc/nvidia/nvidia-load.conf (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /etc/modprobe.d/nvidia.conf because associated file /etc/nvidia/nvidia-modprobe.conf (of link group glx) doesn't exist
update-alternatives: warning: skip creation of /usr/lib/xorg/modules/drivers/nvidia_drv.so because associated file /usr/lib/nvidia/nvidia_drv.so (of link group glx) doesn't exist
update-alternatives: using /usr/lib/mesa-diverted to provide /usr/lib/glx (glx) in auto mode
Removing glx-diversions (0.7.4) ...
Removing nvidia-legacy-check (375.66-1) ...
Removing nvidia-installer-cleanup (20151021+4) ...
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for glx-alternative-mesa (0.7.4) ...
(Reading database ... 168905 files and directories currently installed.)
Purging configuration files for nvidia-kernel-common (20151021+4) ...
Purging configuration files for glx-alternative-nvidia (0.7.4) ...
Purging configuration files for nvidia-installer-cleanup (20151021+4) ...
Purging configuration files for nvidia-support (20151021+4) ...
Purging configuration files for nvidia-alternative (375.66-1) ...
Purging configuration files for nvidia-kernel-support (375.66-1) ...
Purging configuration files for glx-diversions (0.7.4) ...
Purging configuration files for nvidia-legacy-check (375.66-1) ...
Purging configuration files for xserver-xorg-video-nvidia (375.66-1) ...
Processing triggers for libc-bin (2.24-11) ...

I noticed a LOT of things were not removed because they never get installed in the first place, for reason or reasons unknown.

Then I did the reinstall:

Code: Select all
# apt-get install nvidia-driver --no-install-recommends
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  glx-alternative-nvidia glx-diversions libegl-nvidia0 libegl1-glvnd-nvidia
  libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libglx-nvidia0
  libglx0-glvnd-nvidia libnvidia-eglcore libnvidia-glcore libnvidia-ml1
  nvidia-alternative nvidia-driver-bin nvidia-driver-libs nvidia-egl-common
  nvidia-egl-icd nvidia-installer-cleanup nvidia-kernel-common
  nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check nvidia-modprobe
  nvidia-support nvidia-vdpau-driver xserver-xorg-video-nvidia
Recommended packages:
  nvidia-settings nvidia-persistenced nvidia-driver-libs-i386
  libopengl0-glvnd-nvidia libgles-nvidia1 libgles-nvidia2 libnvidia-cfg1
  nvidia-vulkan-icd
The following NEW packages will be installed:
  glx-alternative-nvidia glx-diversions libegl-nvidia0 libegl1-glvnd-nvidia
  libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx libglx-nvidia0
  libglx0-glvnd-nvidia libnvidia-eglcore libnvidia-glcore libnvidia-ml1
  nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-driver-libs
  nvidia-egl-common nvidia-egl-icd nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support
  nvidia-legacy-check nvidia-modprobe nvidia-support nvidia-vdpau-driver
  xserver-xorg-video-nvidia
0 upgraded, 26 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B/27.4 MB of archives.
After this operation, 112 MB of additional disk space will be used.
Do you want to continue? [Y/n]
y
Preconfiguring packages ...
Selecting previously unselected package nvidia-installer-cleanup.
(Reading database ... 168896 files and directories currently installed.)
Preparing to unpack .../nvidia-installer-cleanup_20151021+4_amd64.deb ...
Unpacking nvidia-installer-cleanup (20151021+4) ...
Setting up nvidia-installer-cleanup (20151021+4) ...
Selecting previously unselected package glx-diversions.
(Reading database ... 168904 files and directories currently installed.)
Preparing to unpack .../glx-diversions_0.7.4_amd64.deb ...
Unpacking glx-diversions (0.7.4) ...
Selecting previously unselected package nvidia-legacy-check.
Preparing to unpack .../nvidia-legacy-check_375.66-1_amd64.deb ...
Unpacking nvidia-legacy-check (375.66-1) ...
Selecting previously unselected package glx-alternative-nvidia.
Preparing to unpack .../glx-alternative-nvidia_0.7.4_amd64.deb ...
Unpacking glx-alternative-nvidia (0.7.4) ...
Setting up nvidia-legacy-check (375.66-1) ...
Selecting previously unselected package nvidia-alternative.
(Reading database ... 168934 files and directories currently installed.)
Preparing to unpack .../00-nvidia-alternative_375.66-1_amd64.deb ...
Unpacking nvidia-alternative (375.66-1) ...
Selecting previously unselected package libglx0-glvnd-nvidia:amd64.
Preparing to unpack .../01-libglx0-glvnd-nvidia_375.66-1_amd64.deb ...
Unpacking libglx0-glvnd-nvidia:amd64 (375.66-1) ...
Selecting previously unselected package libgl1-glvnd-nvidia-glx:amd64.
Preparing to unpack .../02-libgl1-glvnd-nvidia-glx_375.66-1_amd64.deb ...
Unpacking libgl1-glvnd-nvidia-glx:amd64 (375.66-1) ...
Selecting previously unselected package libnvidia-glcore:amd64.
Preparing to unpack .../03-libnvidia-glcore_375.66-1_amd64.deb ...
Unpacking libnvidia-glcore:amd64 (375.66-1) ...
Selecting previously unselected package libglx-nvidia0:amd64.
Preparing to unpack .../04-libglx-nvidia0_375.66-1_amd64.deb ...
Unpacking libglx-nvidia0:amd64 (375.66-1) ...
Selecting previously unselected package libgl1-nvidia-glvnd-glx:amd64.
Preparing to unpack .../05-libgl1-nvidia-glvnd-glx_375.66-1_amd64.deb ...
Unpacking libgl1-nvidia-glvnd-glx:amd64 (375.66-1) ...
Selecting previously unselected package nvidia-egl-common.
Preparing to unpack .../06-nvidia-egl-common_375.66-1_amd64.deb ...
Unpacking nvidia-egl-common (375.66-1) ...
Selecting previously unselected package libegl1-glvnd-nvidia:amd64.
Preparing to unpack .../07-libegl1-glvnd-nvidia_375.66-1_amd64.deb ...
Unpacking libegl1-glvnd-nvidia:amd64 (375.66-1) ...
Selecting previously unselected package libnvidia-eglcore:amd64.
Preparing to unpack .../08-libnvidia-eglcore_375.66-1_amd64.deb ...
Unpacking libnvidia-eglcore:amd64 (375.66-1) ...
Selecting previously unselected package libegl-nvidia0:amd64.
Preparing to unpack .../09-libegl-nvidia0_375.66-1_amd64.deb ...
Unpacking libegl-nvidia0:amd64 (375.66-1) ...
Selecting previously unselected package nvidia-egl-icd:amd64.
Preparing to unpack .../10-nvidia-egl-icd_375.66-1_amd64.deb ...
Unpacking nvidia-egl-icd:amd64 (375.66-1) ...
Selecting previously unselected package nvidia-driver-libs:amd64.
Preparing to unpack .../11-nvidia-driver-libs_375.66-1_amd64.deb ...
Unpacking nvidia-driver-libs:amd64 (375.66-1) ...
Selecting previously unselected package libnvidia-ml1:amd64.
Preparing to unpack .../12-libnvidia-ml1_375.66-1_amd64.deb ...
Unpacking libnvidia-ml1:amd64 (375.66-1) ...
Selecting previously unselected package nvidia-driver-bin.
Preparing to unpack .../13-nvidia-driver-bin_375.66-1_amd64.deb ...
Unpacking nvidia-driver-bin (375.66-1) ...
Selecting previously unselected package nvidia-support.
Preparing to unpack .../14-nvidia-support_20151021+4_amd64.deb ...
Unpacking nvidia-support (20151021+4) ...
Selecting previously unselected package xserver-xorg-video-nvidia.
Preparing to unpack .../15-xserver-xorg-video-nvidia_375.66-1_amd64.deb ...
Unpacking xserver-xorg-video-nvidia (375.66-1) ...
Selecting previously unselected package nvidia-vdpau-driver:amd64.
Preparing to unpack .../16-nvidia-vdpau-driver_375.66-1_amd64.deb ...
Unpacking nvidia-vdpau-driver:amd64 (375.66-1) ...
Selecting previously unselected package nvidia-kernel-common.
Preparing to unpack .../17-nvidia-kernel-common_20151021+4_amd64.deb ...
Unpacking nvidia-kernel-common (20151021+4) ...
Selecting previously unselected package nvidia-modprobe.
Preparing to unpack .../18-nvidia-modprobe_375.26-1_amd64.deb ...
Unpacking nvidia-modprobe (375.26-1) ...
Selecting previously unselected package nvidia-kernel-support.
Preparing to unpack .../19-nvidia-kernel-support_375.66-1_amd64.deb ...
Unpacking nvidia-kernel-support (375.66-1) ...
Selecting previously unselected package nvidia-kernel-dkms.
Preparing to unpack .../20-nvidia-kernel-dkms_375.66-1_amd64.deb ...
Unpacking nvidia-kernel-dkms (375.66-1) ...
Selecting previously unselected package nvidia-driver.
Preparing to unpack .../21-nvidia-driver_375.66-1_amd64.deb ...
Unpacking nvidia-driver (375.66-1) ...
Setting up nvidia-kernel-common (20151021+4) ...
Processing triggers for mime-support (3.60) ...
Setting up libnvidia-eglcore:amd64 (375.66-1) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Setting up nvidia-support (20151021+4) ...
Setting up libnvidia-glcore:amd64 (375.66-1) ...
Processing triggers for libc-bin (2.24-11) ...
Setting up nvidia-egl-common (375.66-1) ...
Setting up glx-diversions (0.7.4) ...
Setting up nvidia-modprobe (375.26-1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for glx-alternative-mesa (0.7.4) ...
update-alternatives: using /usr/lib/mesa-diverted to provide /usr/lib/glx (glx) in auto mode
Setting up glx-alternative-nvidia (0.7.4) ...
Processing triggers for glx-alternative-nvidia (0.7.4) ...
Setting up nvidia-alternative (375.66-1) ...
Processing triggers for nvidia-alternative (375.66-1) ...
update-alternatives: using /usr/lib/nvidia/current to provide /usr/lib/nvidia/nvidia (nvidia) in auto mode
Setting up libglx0-glvnd-nvidia:amd64 (375.66-1) ...
Setting up nvidia-kernel-support (375.66-1) ...
Setting up nvidia-vdpau-driver:amd64 (375.66-1) ...
Setting up libegl1-glvnd-nvidia:amd64 (375.66-1) ...
Setting up libegl-nvidia0:amd64 (375.66-1) ...
Setting up libnvidia-ml1:amd64 (375.66-1) ...
Setting up xserver-xorg-video-nvidia (375.66-1) ...
Setting up nvidia-driver-bin (375.66-1) ...
Setting up libgl1-glvnd-nvidia-glx:amd64 (375.66-1) ...
Setting up libglx-nvidia0:amd64 (375.66-1) ...
Setting up nvidia-egl-icd:amd64 (375.66-1) ...
Setting up libgl1-nvidia-glvnd-glx:amd64 (375.66-1) ...
Setting up nvidia-driver-libs:amd64 (375.66-1) ...
Processing triggers for nvidia-alternative (375.66-1) ...
update-alternatives: updating alternative /usr/lib/nvidia/current because link group nvidia has changed slave links
Setting up nvidia-kernel-dkms (375.66-1) ...
Loading new nvidia-current-375.66 DKMS files...
BUILDING FOR 4.9.0-3-AMD64
MODULE BUILD FOR KERNEL 4.9.0-3-AMD64 WAS SKIPPED SINCE THE
KERNEL HEADERS FOR THIS KERNEL DOES NOT SEEM TO BE INSTALLED.
Setting up nvidia-driver (375.66-1) ...
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for update-glx (0.7.4) ...
Processing triggers for glx-alternative-nvidia (0.7.4) ...
update-alternatives: using /usr/lib/nvidia to provide /usr/lib/glx (glx) in auto mode
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-3-amd64

(All-caps above are mine.)

This time I DID see an attempt to do a build. Now I have something I can work with.

I'll study the steps Steve gave me and let you both know how it worked.

Caitlin
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby stevepusser » 2017-07-22 16:51

Well... now we see the build failure that I kept saying was happening really is there. The solution is simple--make sure you have the kernel module build environment set up correctly. Module-assistant and "m-a prepare" is your friend there --who can remember that header install command in the wiki offhand?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8935
Joined: 2009-10-06 05:53

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-23 14:00

Well, I tried it again.

I had a bit of difficulty figuring out in what ORDER the steps should be done, but this is what I tried (after backing out my previous attempt):

First, I installed module-assistant:

Code: Select all
# apt-get install module-assistant --no-install-recommends

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  module-assistant
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B/101 kB of archives.
After this operation, 399 kB of additional disk space will be used.
Selecting previously unselected package module-assistant.
(Reading database ... 170257 files and directories currently installed.)
Preparing to unpack .../module-assistant_0.11.9_all.deb ...
Unpacking module-assistant (0.11.9) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up module-assistant (0.11.9) ...

So far so good.

Next I did the exports and attempted to "prepare":

Code: Select all
# export PERL5LIB=.
# export HOST_COMPILER=clang++-3.8
# m-a prepare

Getting source for kernel version: 4.9.0-3-amd64
apt-get install linux-headers-4.9.0-3-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-3-common linux-kbuild-4.9
The following NEW packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-3-amd64
  linux-headers-4.9.0-3-common linux-kbuild-4.9
0 upgraded, 4 newly installed, 0 to remove and 6 not upgraded.
Need to get 9,049 kB of archives.
After this operation, 51.4 MB of additional disk space will be used.
Do you want to continue? [Y/n]
y
Err:1 http://security.debian.org/debian-security stretch/updates/main amd64 linux-compiler-gcc-6-x86 amd64 4.9.30-2+deb9u1
  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
Ign:2 http://security.debian.org/debian-security stretch/updates/main amd64 linux-headers-4.9.0-3-common all 4.9.30-2+deb9u1
Err:3 http://security.debian.org/debian-security stretch/updates/main amd64 linux-kbuild-4.9 amd64 4.9.30-2+deb9u1
  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
Err:4 http://security.debian.org/debian-security stretch/updates/main amd64 linux-headers-4.9.0-3-amd64 amd64 4.9.30-2+deb9u1
  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
Err:2 http://security.debian.org/debian-security stretch/updates/main i386 linux-headers-4.9.0-3-common all 4.9.30-2+deb9u1
  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
E: Failed to fetch http://security.debian.org/debian-security/pool/updates/main/l/linux/linux-compiler-gcc-6-x86_4.9.30-2+deb9u1_amd64.deb  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
E: Failed to fetch http://security.debian.org/debian-security/pool/updates/main/l/linux/linux-headers-4.9.0-3-common_4.9.30-2+deb9u1_all.deb  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
E: Failed to fetch http://security.debian.org/debian-security/pool/updates/main/l/linux/linux-kbuild-4.9_4.9.30-2+deb9u1_amd64.deb  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
E: Failed to fetch http://security.debian.org/debian-security/pool/updates/main/l/linux/linux-headers-4.9.0-3-amd64_4.9.30-2+deb9u1_amd64.deb  404  Not Found [IP: 2001:a78:5:0:216:35ff:fe7f:be4f 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.3).
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

Done!

Alright, that didn't work, so I did the update as recommended and tried again:

Code: Select all
# apt-get update

Get:1 http://security.debian.org/debian-security stretch/updates InRelease [62.9 kB]
Get:2 http://deb.debian.org/debian stretch-updates InRelease [88.5 kB]
Get:3 http://deb.debian.org/debian stretch-backports InRelease [87.3 kB]
Ign:4 http://deb.debian.org/debian stretch InRelease
Get:5 http://deb.debian.org/debian stretch Release [118 kB]
Get:6 http://deb.debian.org/debian stretch Release.gpg [2,373 B]
Get:7 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [82.1 kB]
Get:8 http://security.debian.org/debian-security stretch/updates/main i386 Packages [82.9 kB]
Get:9 http://security.debian.org/debian-security stretch/updates/main Translation-en [39.1 kB]
Get:10 http://deb.debian.org/debian stretch-backports/main amd64 Packages [51.3 kB]
Get:11 http://deb.debian.org/debian stretch-backports/main i386 Packages [51.3 kB]
Get:12 http://deb.debian.org/debian stretch-backports/main Translation-en [28.9 kB]
Get:13 http://deb.debian.org/debian stretch-backports/non-free amd64 Packages [804 B]
Get:14 http://deb.debian.org/debian stretch-backports/non-free i386 Packages [808 B]
Get:15 http://deb.debian.org/debian stretch-backports/non-free Translation-en [598 B]
Get:16 http://deb.debian.org/debian stretch/main amd64 Packages [7,095 kB]
Get:17 http://deb.debian.org/debian stretch/main i386 Packages [7,074 kB]
Get:18 http://deb.debian.org/debian stretch/main Translation-en [5,393 kB]
Get:19 http://deb.debian.org/debian stretch/non-free i386 Packages [68.9 kB]
Get:20 http://deb.debian.org/debian stretch/non-free amd64 Packages [77.9 kB]
Get:21 http://deb.debian.org/debian stretch/non-free Translation-en [79.2 kB]
Fetched 20.5 MB in 6s (3,364 kB/s)
Reading package lists... Done

# m-a prepare

Getting source for kernel version: 4.9.0-3-amd64
apt-get install linux-headers-4.9.0-3-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-3-common linux-kbuild-4.9
The following NEW packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-3-amd64
  linux-headers-4.9.0-3-common linux-kbuild-4.9
0 upgraded, 4 newly installed, 0 to remove and 69 not upgraded.
Need to get 9,049 kB of archives.
After this operation, 51.4 MB of additional disk space will be used.
Do you want to continue? [Y/n]
y
Get:1 http://security.debian.org/debian-security stretch/updates/main amd64 linux-compiler-gcc-6-x86 amd64 4.9.30-2+deb9u2 [462 kB]
Get:2 http://security.debian.org/debian-security stretch/updates/main amd64 linux-headers-4.9.0-3-common all 4.9.30-2+deb9u2 [7,470 kB]
Get:3 http://security.debian.org/debian-security stretch/updates/main amd64 linux-kbuild-4.9 amd64 4.9.30-2+deb9u2 [668 kB]
Get:4 http://security.debian.org/debian-security stretch/updates/main amd64 linux-headers-4.9.0-3-amd64 amd64 4.9.30-2+deb9u2 [448 kB]
Fetched 9,049 kB in 1s (5,764 kB/s)
Selecting previously unselected package linux-compiler-gcc-6-x86.
(Reading database ... 170299 files and directories currently installed.)
Preparing to unpack .../linux-compiler-gcc-6-x86_4.9.30-2+deb9u2_amd64.deb ...
Unpacking linux-compiler-gcc-6-x86 (4.9.30-2+deb9u2) ...
Selecting previously unselected package linux-headers-4.9.0-3-common.
Preparing to unpack .../linux-headers-4.9.0-3-common_4.9.30-2+deb9u2_all.deb ...
Unpacking linux-headers-4.9.0-3-common (4.9.30-2+deb9u2) ...
Selecting previously unselected package linux-kbuild-4.9.
Preparing to unpack .../linux-kbuild-4.9_4.9.30-2+deb9u2_amd64.deb ...
Unpacking linux-kbuild-4.9 (4.9.30-2+deb9u2) ...
Selecting previously unselected package linux-headers-4.9.0-3-amd64.
Preparing to unpack .../linux-headers-4.9.0-3-amd64_4.9.30-2+deb9u2_amd64.deb ...
Unpacking linux-headers-4.9.0-3-amd64 (4.9.30-2+deb9u2) ...
Setting up linux-headers-4.9.0-3-common (4.9.30-2+deb9u2) ...
Setting up linux-compiler-gcc-6-x86 (4.9.30-2+deb9u2) ...
Setting up linux-kbuild-4.9 (4.9.30-2+deb9u2) ...
Setting up linux-headers-4.9.0-3-amd64 (4.9.30-2+deb9u2) ...
apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.3).
0 upgraded, 0 newly installed, 0 to remove and 69 not upgraded.

Done!

Much better. Now I tried the install proper, with the build:

Code: Select all
# apt-get install nvidia-cuda-dev nvidia-cuda-toolkit nvidia-driver --no-install-recommends

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  glx-alternative-nvidia glx-diversions libcuda1 libcuinj64-8.0 libegl-nvidia0
  libegl1-glvnd-nvidia libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx
  libglx-nvidia0 libglx0-glvnd-nvidia libnvidia-eglcore
  libnvidia-fatbinaryloader libnvidia-glcore libnvidia-ml1
  libnvidia-ptxjitcompiler nvidia-alternative nvidia-driver-bin
  nvidia-driver-libs nvidia-egl-common nvidia-egl-icd nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support
  nvidia-legacy-check nvidia-modprobe nvidia-opencl-dev nvidia-profiler
  nvidia-support nvidia-vdpau-driver xserver-xorg-video-nvidia
Suggested packages:
  nvidia-cuda-mps libcupti-dev
Recommended packages:
  nvidia-smi nvidia-persistenced libcuda1-i386 libgl1-mesa-dev | libgl-dev
  libvdpau-dev libnvcuvid1 nvidia-cuda-doc nvidia-cuda-gdb
  nvidia-visual-profiler nvidia-settings nvidia-driver-libs-i386
  libopengl0-glvnd-nvidia libgles-nvidia1 libgles-nvidia2 libnvidia-cfg1
  nvidia-vulkan-icd nvidia-opencl-icd
The following NEW packages will be installed:
  glx-alternative-nvidia glx-diversions libcuda1 libcuinj64-8.0 libegl-nvidia0
  libegl1-glvnd-nvidia libgl1-glvnd-nvidia-glx libgl1-nvidia-glvnd-glx
  libglx-nvidia0 libglx0-glvnd-nvidia libnvidia-eglcore
  libnvidia-fatbinaryloader libnvidia-glcore libnvidia-ml1
  libnvidia-ptxjitcompiler nvidia-alternative nvidia-cuda-dev
  nvidia-cuda-toolkit nvidia-driver nvidia-driver-bin nvidia-driver-libs
  nvidia-egl-common nvidia-egl-icd nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support
  nvidia-legacy-check nvidia-modprobe nvidia-opencl-dev nvidia-profiler
  nvidia-support nvidia-vdpau-driver xserver-xorg-video-nvidia
0 upgraded, 34 newly installed, 0 to remove and 69 not upgraded.
Need to get 0 B/301 MB of archives.
After this operation, 802 MB of additional disk space will be used.
Do you want to continue? [Y/n]
y
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package nvidia-installer-cleanup.
(Reading database ... 186141 files and directories currently installed.)
Preparing to unpack .../nvidia-installer-cleanup_20151021+4_amd64.deb ...
Unpacking nvidia-installer-cleanup (20151021+4) ...
Setting up nvidia-installer-cleanup (20151021+4) ...
Selecting previously unselected package glx-diversions.
(Reading database ... 186149 files and directories currently installed.)
Preparing to unpack .../glx-diversions_0.7.4_amd64.deb ...
Unpacking glx-diversions (0.7.4) ...
Selecting previously unselected package nvidia-legacy-check.
Preparing to unpack .../nvidia-legacy-check_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-legacy-check (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-support.
Preparing to unpack .../nvidia-support_20151021+4_amd64.deb ...
Unpacking nvidia-support (20151021+4) ...
Selecting previously unselected package glx-alternative-nvidia.
Preparing to unpack .../glx-alternative-nvidia_0.7.4_amd64.deb ...
Unpacking glx-alternative-nvidia (0.7.4) ...
Setting up nvidia-legacy-check (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-alternative.
(Reading database ... 186185 files and directories currently installed.)
Preparing to unpack .../00-nvidia-alternative_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-alternative (375.66-2~deb9u1) ...
Selecting previously unselected package libnvidia-ptxjitcompiler:amd64.
Preparing to unpack .../01-libnvidia-ptxjitcompiler_375.66-2~deb9u1_amd64.deb ...
Unpacking libnvidia-ptxjitcompiler:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libnvidia-fatbinaryloader:amd64.
Preparing to unpack .../02-libnvidia-fatbinaryloader_375.66-2~deb9u1_amd64.deb ...
Unpacking libnvidia-fatbinaryloader:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libcuda1:amd64.
Preparing to unpack .../03-libcuda1_375.66-2~deb9u1_amd64.deb ...
Unpacking libcuda1:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libglx0-glvnd-nvidia:amd64.
Preparing to unpack .../04-libglx0-glvnd-nvidia_375.66-2~deb9u1_amd64.deb ...
Unpacking libglx0-glvnd-nvidia:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libgl1-glvnd-nvidia-glx:amd64.
Preparing to unpack .../05-libgl1-glvnd-nvidia-glx_375.66-2~deb9u1_amd64.deb ...
Unpacking libgl1-glvnd-nvidia-glx:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libnvidia-glcore:amd64.
Preparing to unpack .../06-libnvidia-glcore_375.66-2~deb9u1_amd64.deb ...
Unpacking libnvidia-glcore:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libglx-nvidia0:amd64.
Preparing to unpack .../07-libglx-nvidia0_375.66-2~deb9u1_amd64.deb ...
Unpacking libglx-nvidia0:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libgl1-nvidia-glvnd-glx:amd64.
Preparing to unpack .../08-libgl1-nvidia-glvnd-glx_375.66-2~deb9u1_amd64.deb ...
Unpacking libgl1-nvidia-glvnd-glx:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-egl-common.
Preparing to unpack .../09-nvidia-egl-common_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-egl-common (375.66-2~deb9u1) ...
Selecting previously unselected package libegl1-glvnd-nvidia:amd64.
Preparing to unpack .../10-libegl1-glvnd-nvidia_375.66-2~deb9u1_amd64.deb ...
Unpacking libegl1-glvnd-nvidia:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libnvidia-eglcore:amd64.
Preparing to unpack .../11-libnvidia-eglcore_375.66-2~deb9u1_amd64.deb ...
Unpacking libnvidia-eglcore:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libegl-nvidia0:amd64.
Preparing to unpack .../12-libegl-nvidia0_375.66-2~deb9u1_amd64.deb ...
Unpacking libegl-nvidia0:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-egl-icd:amd64.
Preparing to unpack .../13-nvidia-egl-icd_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-egl-icd:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-driver-libs:amd64.
Preparing to unpack .../14-nvidia-driver-libs_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-driver-libs:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package libnvidia-ml1:amd64.
Preparing to unpack .../15-libnvidia-ml1_375.66-2~deb9u1_amd64.deb ...
Unpacking libnvidia-ml1:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-driver-bin.
Preparing to unpack .../16-nvidia-driver-bin_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-driver-bin (375.66-2~deb9u1) ...
Selecting previously unselected package xserver-xorg-video-nvidia.
Preparing to unpack .../17-xserver-xorg-video-nvidia_375.66-2~deb9u1_amd64.deb ...
Unpacking xserver-xorg-video-nvidia (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-vdpau-driver:amd64.
Preparing to unpack .../18-nvidia-vdpau-driver_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-vdpau-driver:amd64 (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-kernel-common.
Preparing to unpack .../19-nvidia-kernel-common_20151021+4_amd64.deb ...
Unpacking nvidia-kernel-common (20151021+4) ...
Selecting previously unselected package nvidia-modprobe.
Preparing to unpack .../20-nvidia-modprobe_375.26-1_amd64.deb ...
Unpacking nvidia-modprobe (375.26-1) ...
Selecting previously unselected package nvidia-kernel-support.
Preparing to unpack .../21-nvidia-kernel-support_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-kernel-support (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-kernel-dkms.
Preparing to unpack .../22-nvidia-kernel-dkms_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-kernel-dkms (375.66-2~deb9u1) ...
Selecting previously unselected package nvidia-driver.
Preparing to unpack .../23-nvidia-driver_375.66-2~deb9u1_amd64.deb ...
Unpacking nvidia-driver (375.66-2~deb9u1) ...
Selecting previously unselected package libcuinj64-8.0:amd64.
Preparing to unpack .../24-libcuinj64-8.0_8.0.44-4_amd64.deb ...
Unpacking libcuinj64-8.0:amd64 (8.0.44-4) ...
Selecting previously unselected package nvidia-cuda-dev.
Preparing to unpack .../25-nvidia-cuda-dev_8.0.44-4_amd64.deb ...
Unpacking nvidia-cuda-dev (8.0.44-4) ...
Selecting previously unselected package nvidia-profiler.
Preparing to unpack .../26-nvidia-profiler_8.0.44-4_amd64.deb ...
Unpacking nvidia-profiler (8.0.44-4) ...
Selecting previously unselected package nvidia-opencl-dev:amd64.
Preparing to unpack .../27-nvidia-opencl-dev_8.0.44-4_amd64.deb ...
Unpacking nvidia-opencl-dev:amd64 (8.0.44-4) ...
Selecting previously unselected package nvidia-cuda-toolkit.
Preparing to unpack .../28-nvidia-cuda-toolkit_8.0.44-4_amd64.deb ...
Unpacking nvidia-cuda-toolkit (8.0.44-4) ...
Setting up nvidia-kernel-common (20151021+4) ...
Processing triggers for mime-support (3.60) ...
Setting up libnvidia-eglcore:amd64 (375.66-2~deb9u1) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Setting up nvidia-support (20151021+4) ...
Setting up nvidia-opencl-dev:amd64 (8.0.44-4) ...
Setting up libnvidia-glcore:amd64 (375.66-2~deb9u1) ...
Processing triggers for libc-bin (2.24-11) ...
Setting up nvidia-egl-common (375.66-2~deb9u1) ...
Setting up glx-diversions (0.7.4) ...
Setting up nvidia-modprobe (375.26-1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Setting up libnvidia-ptxjitcompiler:amd64 (375.66-2~deb9u1) ...
Setting up libnvidia-fatbinaryloader:amd64 (375.66-2~deb9u1) ...
Processing triggers for glx-alternative-mesa (0.7.4) ...
update-alternatives: using /usr/lib/mesa-diverted to provide /usr/lib/glx (glx) in auto mode
Setting up glx-alternative-nvidia (0.7.4) ...
Processing triggers for glx-alternative-nvidia (0.7.4) ...
Setting up nvidia-alternative (375.66-2~deb9u1) ...
Processing triggers for nvidia-alternative (375.66-2~deb9u1) ...
update-alternatives: using /usr/lib/nvidia/current to provide /usr/lib/nvidia/nvidia (nvidia) in auto mode
Setting up libglx0-glvnd-nvidia:amd64 (375.66-2~deb9u1) ...
Setting up nvidia-kernel-support (375.66-2~deb9u1) ...
Setting up nvidia-vdpau-driver:amd64 (375.66-2~deb9u1) ...
Setting up libegl1-glvnd-nvidia:amd64 (375.66-2~deb9u1) ...
Setting up libegl-nvidia0:amd64 (375.66-2~deb9u1) ...
Setting up libnvidia-ml1:amd64 (375.66-2~deb9u1) ...
Setting up libcuda1:amd64 (375.66-2~deb9u1) ...

                       Conflicting libcuda1:amd64

 Conflicting nouveau kernel module loaded

 The free nouveau kernel module is currently loaded and conflicts with
 the non-free nvidia kernel module.

 The easiest way to fix this is to reboot the machine once the
 installation has finished.

                                 <Ok>

Setting up xserver-xorg-video-nvidia (375.66-2~deb9u1) ...
Setting up nvidia-driver-bin (375.66-2~deb9u1) ...
Setting up libgl1-glvnd-nvidia-glx:amd64 (375.66-2~deb9u1) ...
Setting up libglx-nvidia0:amd64 (375.66-2~deb9u1) ...
Setting up nvidia-egl-icd:amd64 (375.66-2~deb9u1) ...
Setting up libcuinj64-8.0:amd64 (8.0.44-4) ...
Setting up libgl1-nvidia-glvnd-glx:amd64 (375.66-2~deb9u1) ...
Setting up nvidia-profiler (8.0.44-4) ...
Setting up nvidia-driver-libs:amd64 (375.66-2~deb9u1) ...
Setting up nvidia-cuda-dev (8.0.44-4) ...
Setting up nvidia-cuda-toolkit (8.0.44-4) ...
Processing triggers for nvidia-alternative (375.66-2~deb9u1) ...
update-alternatives: updating alternative /usr/lib/nvidia/current because link group nvidia has changed slave links
Setting up nvidia-kernel-dkms (375.66-2~deb9u1) ...
Loading new nvidia-current-375.66 DKMS files...
Building for 4.9.0-3-amd64
Building initial module for 4.9.0-3-amd64       NO MORE MESSAGES FOR ABOUT 5 MINUTES -- A GOOD SIGN
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-3-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-3-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-3-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-3-amd64/updates/dkms/

depmod...

DKMS: install completed.
Setting up nvidia-driver (375.66-2~deb9u1) ...
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for update-glx (0.7.4) ...
Processing triggers for glx-alternative-nvidia (0.7.4) ...
update-alternatives: using /usr/lib/nvidia to provide /usr/lib/glx (glx) in auto mode
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-3-amd64                 I THINK THIS MEANS IT WORKED

Now it wanted me to check if I can adjust the screen brightness. I don't know where the control to do this is; I checked both System -> Control Center and System -> Preferences (under MATE) and there is no brightness control anywhere. I went to update either /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/20-nvidia.conf (per the instructions) but those files don't exist.

I moved on to attempt to install the CUDA samples.

I downloaded the CUDA .run file and executed it:

Code: Select all
# sh /edisk/download/cuda_8.0.61_375.26_linux.run

-------------------------------------------------------------
Do you accept the previously read EULA?
accept/decline/quit: accept

You are attempting to install on an unsupported configuration. Do you wish to continue?
(y)es/(n)o [ default is no ]: y

Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 375.26?
(y)es/(n)o/(q)uit: n

Install the CUDA 8.0 Toolkit?
(y)es/(n)o/(q)uit: n

Install the CUDA 8.0 Samples?
(y)es/(n)o/(q)uit: y

Enter CUDA Samples Location
 [ default is /root ]:

Enter Toolkit Location
 [ default is /usr/local/cuda-8.0 ]:

Error: cannot find Toolkit in /usr/local/cuda-8.0
Enter Toolkit Location
 [ default is /usr/local/cuda-8.0 ]:

Error: cannot find Toolkit in /usr/local/cuda-8.0
Enter Toolkit Location
 [ default is /usr/local/cuda-8.0 ]:
Could not find toolkit after three attempts. Exiting...

The instructions say to install the samples but NOT the toolkit, but I think it wants the toolkit to be able to install the samples. I stopped at this point.

Question: if the driver is installed at this point, why do I need the samples, anyway?

Another question: I'm supposed to add "-ccbin clang-3.8" to the nvcc command line. Where do I find the nvcc command line?

Then I rebooted. The monitor resolution was altered; easy enough to fix, but it did show something was changed. Still no way to adjust the brightness and the files I'm supposed to edit to let me do so are still not there.

I was able to run Quadrapassel but not Pharaoh (under WINE). I think Nvidia de-installed something. A quick check on Synaptic shows that wine and wine64 are installed, but wine32 isn't.

I am open to suggestions.

Caitlin
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby Caitlin » 2017-07-24 13:44

I installed wine32 and now BOTH my favorite games are working.

But am I done? I still haven't installed the samples, and don't even know if I really NEED the samples.

Caitlin
Caitlin
 
Posts: 237
Joined: 2012-05-24 07:32

Re: NVIDIA Driver Won't Let My Computer Wake Up

Postby stivencox » 2017-07-25 11:21

If I have any problem with PC I always re-install OS. It solves everything usually
User avatar
stivencox
 
Posts: 3
Joined: 2017-01-05 12:41

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable