Old WiFi adapter not working after upgrade [Solved]

If none of the more specific forums is the right place to ask

Old WiFi adapter not working after upgrade [Solved]

Postby Gip-Gip » 2017-08-03 16:47

I upgraded my Debian installation to Stretch and so far I'm annoyed by a few things; most annoying being my WiFi adapter not working. It appears when I run
Code: Select all
ip link show
but when I try to use something like wicd-curses no networks show up. Even when I try to set it up through the command line it fails to connect.

It previously worked so what happened?

SOLUTION:
The interface worked after installing the firmware-ralink package. This may/may not have been due to user error as well, because my driver is normally built into the kernel. Worth a shot if you're having trouble.
Last edited by Gip-Gip on 2017-08-04 00:22, edited 1 time in total.
Gip-Gip
 
Posts: 5
Joined: 2017-08-03 16:38

Re: Old WiFi adapter not working after upgrade

Postby Lysander » 2017-08-03 17:21

I'm sure we had a similar topic to this just very recently. Seems to be an ongoing issue, not just with Debian, but many Linux distros.

Anyway, I use wired internet so have no experience of this directly, but if you enter the query into a search engine, you will see quite a few results, some of which, I'm sure, would assist you.

https://lmsptfy.com/?q=wifi%20not%20wor ... %20stretch
http://lmgtfy.com/?q=wifi+not+working+debian+stretch
User avatar
Lysander
 
Posts: 360
Joined: 2017-02-23 10:07
Location: London

Re: Old WiFi adapter not working after upgrade

Postby Gip-Gip » 2017-08-03 18:05

Lysander wrote:I'm sure we had a similar topic to this just very recently. Seems to be an ongoing issue, not just with Debian, but many Linux distros.

Anyway, I use wired internet so have no experience of this directly, but if you enter the query into a search engine, you will see quite a few results, some of which, I'm sure, would assist you.

https://lmsptfy.com/?q=wifi%20not%20wor ... %20stretch
http://lmgtfy.com/?q=wifi+not+working+debian+stretch


The one time I googled it I only got results for people with proprietary drivers. Not everyone has StartPage :roll:

I'll try that fix when I get the chance
Gip-Gip
 
Posts: 5
Joined: 2017-08-03 16:38

Re: Old WiFi adapter not working after upgrade

Postby stevepusser » 2017-08-03 18:26

A lot depends on what hardware you have, and whether the driver is in the kernel or if you had to build your own driver for it.

Also, the name of the interface may have been changed, and you would have to let wicd know about the change.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8937
Joined: 2009-10-06 05:53

Re: Old WiFi adapter not working after upgrade

Postby Gip-Gip » 2017-08-03 18:59

stevepusser wrote:A lot depends on what hardware you have, and whether the driver is in the kernel or if you had to build your own driver for it.

Also, the name of the interface may have been changed, and you would have to let wicd know about the change.


I already changed it in wicd, so no luck

I use the rt2500usb driver, which as far as I know is ancient and has been supported since the v2 Linux kernel. Why it would stop working after many years of essentially plug-n-play I have no idea
Gip-Gip
 
Posts: 5
Joined: 2017-08-03 16:38

Re: Old WiFi adapter not working after upgrade

Postby stevepusser » 2017-08-03 20:47

Did you enable the non-free section and install firmware-ralink?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8937
Joined: 2009-10-06 05:53

Re: Old WiFi adapter not working after upgrade

Postby Gip-Gip » 2017-08-03 22:23

stevepusser wrote:Did you enable the non-free section and install firmware-ralink?

I've honestly never heard of the package. I'll install it and see what happens
Gip-Gip
 
Posts: 5
Joined: 2017-08-03 16:38

Re: Old WiFi adapter not working after upgrade

Postby Gip-Gip » 2017-08-04 00:18

stevepusser wrote:Did you enable the non-free section and install firmware-ralink?


After installing it I went to the wicd-curses control panel and noticed an extra Wireless Interface field. Either I completely missed the text box it or installing the drivers actually worked :D
Gip-Gip
 
Posts: 5
Joined: 2017-08-03 16:38

Re: Old WiFi adapter not working after upgrade [Solved]

Postby Bulkley » 2017-08-04 00:56

Thanks for posting your fix. It may help someone else.
Bulkley
 
Posts: 5360
Joined: 2006-02-11 18:35


Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable