[SOLVED ]Error upgrading packages, conflict libc6 amd64 i386

If none of the more specific forums is the right place to ask

[SOLVED ]Error upgrading packages, conflict libc6 amd64 i386

Postby amasglobulaires » 2017-08-08 13:39

Hello everyone !

Since few days, I can't upgrade my debian desktop because of a conflict between two different version of libc6 , when I run
Code: Select all
sudo apt-get upgrade
.
I get this error :
Code: Select all
Preconfiguring packages ...
dpkg: error processing package libc6:amd64 (--configure):
 package libc6:amd64 2.19-18+deb8u10 cannot be configured because libc6:i386 is at a different version (2.19-18+deb8u9)
Errors were encountered while processing:
 libc6:amd64


I don't really know how to handle this problem, I would like to replace this old libc6:i386 package by the 64 bit version of it.
If you have any advice on how to simply do it, I would be very grateful !!

Thanks in advance !
Last edited by amasglobulaires on 2017-08-08 22:47, edited 1 time in total.
amasglobulaires
 
Posts: 8
Joined: 2017-08-08 13:04

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby kedaha » 2017-08-08 19:03

# apt-get autoremove && apt-get install -f
What does that show?
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2800
Joined: 2008-05-24 12:26

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby amasglobulaires » 2017-08-08 19:14

First of all thank you for helping me !

As root
Code: Select all
apt-get autoremove

return this error
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 117 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package libc6:amd64 (--configure):
 package libc6:amd64 2.19-18+deb8u10 cannot be configured because libc6:i386 is at a different version (2.19-18+deb8u9)
Errors were encountered while processing:
 libc6:amd64



and
Code: Select all
apt-get install -f
return this :
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 117 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package libc6:amd64 (--configure):
 package libc6:amd64 2.19-18+deb8u10 cannot be configured because libc6:i386 is at a different version (2.19-18+deb8u9)
Errors were encountered while processing:
 libc6:amd64

amasglobulaires
 
Posts: 8
Joined: 2017-08-08 13:04

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby dasein » 2017-08-08 19:25

amasglobulaires wrote:I would like to replace this old libc6:i386 package by the 64 bit version of it.

And what exactly makes you think that this is necessary or desirable? Please be specific.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby amasglobulaires » 2017-08-08 19:34

I would like to use the 64 bit package since this computer is a 64 bit machine . And also because this conflict between this two package seems to cause problems and prevent any upgrades.

For information
Code: Select all
uname -m
:
gives
Code: Select all
x86_64



I would like to understand why there is a conflict between these two packages.
Code: Select all
dpkg --print-architecture
amd64

Normally dpkg doesn't accept i386 packages right ? .
So why it doesn't want to replace the old libc6:i386 package by the 64 bit version ?
amasglobulaires
 
Posts: 8
Joined: 2017-08-08 13:04

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby dasein » 2017-08-08 19:51

amasglobulaires wrote:I would like to use the 64 bit package since this computer is a 64 bit machine

Let me rephrase the question: What makes you think that the architecture of your machine is the overriding consideration underlying your question?

(In case it isn't obvious, depending on any number of factors, you are potentially one small mistake away from a major problem. You would be smart to do a backup before you do anything else.)
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby amasglobulaires » 2017-08-08 20:32

Well my main problem here is that I can't make any kind of upgrades, so my debian environment is actually stuck and won't take advantage of any security or features updates for any applications, and this problem seems to come from a conflict between a libc6 32 bit package and a 64 bit one .

In order to retrieve a safe environment by finally making these upgrades, do I have the choice between overriding the libc6 32 bit package or keeping it ? Can I have both ?
amasglobulaires
 
Posts: 8
Joined: 2017-08-08 13:04

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby dasein » 2017-08-08 21:00

amasglobulaires wrote:Well my main problem here is that I can't make any kind of upgrades...

No. Your main problem is that you have no idea about the implications of what you're trying to do and cannot articulate a coherent rationale for your actions.

Back up now. Seriously.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby amasglobulaires » 2017-08-08 21:34

You have no idea about the implications of what you're trying to do and cannot articulate a coherent rationale for your actions


Yeah, that's why I asked for some advice and some explications, and I actually didnt took any action except trying to upgrade the environnement ( the normal way )and gathering some informations and errors . Moreover my actual rationale mind made me post my problem and my questions on this forum to gather some experience by people who understand my problem, and of course before doing anything stupid on my own.

The backup is done since a long time but thank you for having warned me.
amasglobulaires
 
Posts: 8
Joined: 2017-08-08 13:04

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby kedaha » 2017-08-08 21:40

Hi again,
So you're running Debian 8. Have you made any changes to /etc/apt/sources.list?
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2800
Joined: 2008-05-24 12:26

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby amasglobulaires » 2017-08-08 21:50

My actual sources from apt are these :
Code: Select all
deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://httpredir.debian.org/debian/ jessie-updates main contrib non-free

deb http://httpredir.debian.org/debian/ jessie main contrib non-free
deb-src http://httpredir.debian.org/debian/ jessie main contrib non-free

deb http://repo.linrunner.de/debian jessie main
amasglobulaires
 
Posts: 8
Joined: 2017-08-08 13:04

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby kedaha » 2017-08-08 21:53

I'm thinking that maybe you can just remove the offending package with the dpkg package manager
Code: Select all
# dpkg -r libc6:i386

followed by
Code: Select all
# dpkg --configure -a

Since your running everything on an amd64 system, getting rid of it shouldn't mess anything up and besides, you've already backed up your files. :wink:
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2800
Joined: 2008-05-24 12:26

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby stevepusser » 2017-08-08 22:02

Many machines have both i386 and amd64 versions of that and other libraries installed; mine for example. The versions have to match, and they do on mine.

I would bet that you haven't run "apt-get update" to refresh your package database for a while, since it seems to be trying to use an older version of a library--or maybe you removed multiarch support somehow?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8935
Joined: 2009-10-06 05:53

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby amasglobulaires » 2017-08-08 22:19

Well thank you for your help everyone !
maybe you removed multiarch support somehow?


You were right stevepusser, it missed the i386 architecture, I probably have an application i forgot about that need the libc6:i386
Code: Select all
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install -f
sudo apt-get upgrade

And I can properly make the upgrade !
Last edited by amasglobulaires on 2017-08-08 22:53, edited 1 time in total.
amasglobulaires
 
Posts: 8
Joined: 2017-08-08 13:04

Re: Error upgrading packages, conflict libc6 amd64 i386

Postby kedaha » 2017-08-08 22:23

I'd give it a go.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2800
Joined: 2008-05-24 12:26

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable