Problem settin g up a thumb drive for backup storage

If none of the more specific forums is the right place to ask

Problem settin g up a thumb drive for backup storage

Postby qyron » 2017-08-08 22:45

Recently I bought a 125GiB thumb to use as a backup medium but I'm having problems with it.

Originally, it arrived formatted to exFAT but I erased it and changed the file system to FAT32, in order to be able to move files freely between computers. It worked without any problems, moving small amounts of files between computers but when I decided to start backing up my entire HDD to perform a fresh instal, to move up to Debian9, for some reason I started having problem with it.

I first moved my entire photo album to it; took approximately 45 minutes to transfer and the operation was successful but as soon as I started moving movie files - no files are over 1GB - the errors started appearing. The transfers would stop, the system would unmount the drive, then after disconnecting and reconnecting the pen, the access was locked and everything was read only. No files could be moved or copied from or into the drive.
I tried to check the file system with GParted but the program would get stuck on checking for the drives and never recognize the drive. I was able to fix the file system with the least expected candidate: Windows. Out of despair, I plugged the pen into another system I use for gaming, and the OS resolved the errors and I was able to recover all the files in the drive and secure it into that computer's HDD.

I returned to my usual desktop and decided to search a bit and decided to use ext4 on the drive. Formatted it and set it up. GParted is able to perform all tasks but a warning sign is on the thumb drive, saying some libraries could be missing on the system in order to access the thumb drive. No clue of which libraries could those be and that does not make sense to me, as I installed my system using ext4 for my HDD. I try to mount the thumb and I get a message saying it is not possible to access the volume due to missing libraries on the system. Again, no hint or clue of which might be.

Again, I erase the drive. Full clean. No errors, the thumb drive responds fine. I decided to format it to ext3. Takes immense time for the action to be concluded (over one hour), again, with the exact same message and the drive will not mount.

FAT32 never failed me before but after the mishap I had yesterday, I'm not willing to risk it again. exFAT, to all the readings I've done, is the agreed standard for large capacity flash drives but GParted won't create it. ext3 and ext4 flipped me off and will effectively lock me out of moving files between computers with different systems.

My immediate need is to only backup the entire content of my HDD for OS installation but nonetheless I need to set up the drive in a way it will usable after accomplishing that goal.

Can someone share some wisdom on this situation?
Stop hitting me with anvils!|Parem de me bater com bigornas!
Willie E. Coyote

Running Debian 9.2
User avatar
Posts: 169
Joined: 2008-07-21 20:47

Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests