Apper hanging and other issues on new installation

If none of the more specific forums is the right place to ask

Apper hanging and other issues on new installation

Postby fixer1234 » 2017-08-17 16:07

I just downloaded and installed the latest stable 9.1.0 KDE using the installer default options (it's on a USB hard drive). So this is a virgin, out-of-the-box installation. I ran Apper several times to load updates and add a package. Each time, Apper did its job, completed the task, posted a status of "finished", and then hung. All button options remained greyed out, it was not responsive to the link to return to the main screen, and would not close using the close button. Eventually a message would appear that Apper was unresponsive, and asking whether I wanted to kill it (which successfully killed it each time).

Is this a known bug? Is there a simple fix?

Update: I've rebooted a number of times and this particular hanging recurs about half of the times I use Apper (it has happened several times after installing software; it has even installed a package without a problem and then hung after installing another package).

Also occurring with equal frequency (perhaps concurrent with conditions that lead to the hanging, but occurring while Apper is still operational), the mouse becomes "captured" by Apper. While Apper is working, the mouse buttons work only within Apper. The mouse can navigate elsewhere, but is not recognized when hovering over any hoverable icons and nothing outside of Apper responds to either the left or right mouse buttons.

In addition, several other flaky behaviors have appeared:

* I pinned Apper to the tray from the menu. Hovering on the icon displays a description on the desktop identifying it, just as other pinned apps do. However, unlike other pinned apps, that display doesn't disappear if Apper is launched; it remains in the foreground blocking the view of a large chunk of screen real estate. It disappears only when Apper is closed (either via the close button if Apper remained operational, or following termination via the system's "not responding" message). After closure, an error message is displayed: KDEInit could not launch 'usr/bin/apper', which makes no sense because it was just open.

It isn't clear whether there are several unrelated issues that have strangely coincidental overlap or some underlying common denominator, but several other things also misbehave:

* I installed xscreensaver from Apper. The preview button often is unresponsive, and the app hung several times after using the Advanced tab, the same way Apper previously hung after use. I was able to kill it after getting a system prompt that it was unresponsive.

* There are several issues with the mouse cursor. I added a couple of themes using the "Get new Theme" button on the cursor tab of System Settings. Opening that tab, the selected theme is highlighted. It shows the cursor sample on the left, but all text (theme name and description) is invisible. The other two bundled themes are also highlighted, raising a question of whether multiple cursor themes are active and conflicting with each other. The two themes I added are not in use and are not highlighted.

I would dismiss this as a cosmetic issue except the system becomes unresponsive to mouse hovering and button clicks. In addition to this happening routinely with Apper, as described above, it also occurred after the screensaver came on and subsequently disappeared after user input. When this happened after the screensaver, I had to reboot using the power button to regain control. In most cases of Apper capturing the mouse, control was returned after Apper was terminated.

Debian is installed on an external USB drive, running on an off-the-shelf Acer laptop with plenty of resources.

Update 2: I started to explore the bundled apps I'm not familiar with. The first one I opened was "Contact Print Theme Editor". The handbook link in Help points to "Documentation not found". When I closed it, a message flashed briefly saying that it had to be closed due to some type of error. It said please report this error and looked like it had a couple of bug report buttons. The similarly named "Contact Theme Editor" also presented the same error message on closing. These both appear to be KDE utilities and Apper produces a KDE error message, so it's possible that problems with the KDE implementation underlie at least some of the issues.
Posts: 3
Joined: 2016-03-23 23:12

Return to General Questions

Who is online

Users browsing this forum: Soapm and 6 guests