Loss of Sound

If none of the more specific forums is the right place to ask

Loss of Sound

Postby NewToLinux » 2017-09-27 11:59

Can anyone please help with the following problem ?

The sound on a desktop PC running Debian Jessie has stopped working - no
sound from any websites (e.g. BBC or YouTube) and trying to play a
standard sound file I have saved which is used to test the sound with
vlc gives:

Audio output failed:
The audio device "default" could not be used:
Device or resource busy.

and in the terminal window it says:

VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[00000000013f0608] pulse audio output error: PulseAudio server
connection failure: Connection refused
[0000000001318118] core libvlc: Running vlc with the default interface.
Use 'cvlc' to use vlc without interface.
[00000000013f0608] alsa audio output error: cannot open ALSA device
"default": Device or resource busy
[00000000013f0608] core audio output error: module not functional
[00007fc2a8c02b08] core decoder error: failed to create audio output

The sound was then suddenly regained.

The sound has now been suddenly lost again.

Loose wiring is not suspected.

The only file in /etc/pulse is client.conf
NewToLinux
 
Posts: 7
Joined: 2017-09-17 11:30

Re: Loss of Sound

Postby debiman » 2017-09-28 07:28

obvious question nr. 1:
if it worked before, and doesn't work now, what happened between before and now?
software installation/removal? upgrade? something else?
User avatar
debiman
 
Posts: 1619
Joined: 2013-03-12 07:18

Re: Loss of Sound problem solved

Postby NewToLinux » 2017-11-15 13:29

Problem solved by commenting out the line :-

load-module module-console-kit

in /etc/pulse/default.pa

This allows pulseaudio to start.

(module-console-kit had not been installed on the system. Before the above line
was commented out, pulseaudio was prevented from starting via /etc/pulse/default.pa ).
NewToLinux
 
Posts: 7
Joined: 2017-09-17 11:30


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable