[SOLVED] Grub2 on Debian: problem loading intel-ucode

If none of the more specific forums is the right place to ask

[SOLVED] Grub2 on Debian: problem loading intel-ucode

Postby LPC11 » 2017-10-21 13:18

Grub2 is used to manage a multi-boot system, and Grub2 is installed on debian stable. This is a UEFI system; the EFI is installed at /boot/efi/EFI/debian/grubx64.efi.

One of the installs on the same machine is Arch. Executing update-grub runs the os-prober script (which searches for other operating systems), and it correctly finds the Arch installation, then adds it to the grub menu. But, because Arch requires an intel-ucode.img file to be loaded in addition to the initramfs-linux.img file, update-grub does not add the intel-ucode.img to the initrd line of grub.cfg.

Instead the initrd line looks like this:
Code: Select all
initrd /initramfs-linux.img

I can manually modify grub.cfg so the line correctly reads:
Code: Select all
initrd /intel-ucode.img /initramfs-linux.img

Then, Arch loads the microcode correctly, but I would rather avoid having to do manual updates each time I run update-grub. Can the
grub configuration be changed so that update-grub will add the intel-ucode.img file to the initrd line?
Last edited by LPC11 on 2017-10-25 19:59, edited 1 time in total.
Posts: 16
Joined: 2016-10-27 20:21

Re: Grub2 on Debian: problem loading intel-ucode with Arch i

Postby Head_on_a_Stick » 2017-10-21 13:31

Use /etc/grub.d/40_custom to add a menuentry for Arch with the correct details.
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Posts: 8315
Joined: 2014-06-01 17:46
Location: /dev/chair

Return to General Questions

Who is online

Users browsing this forum: No registered users and 4 guests