Installing Plymouth with Nvidia Proprietary drivers

If none of the more specific forums is the right place to ask

Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-28 12:57

Hi guys :D
I followed the followingto set up my old graphics card in Debian 9 and chose 340.102 driver for my card because nvidia-detect gave the following:
Code: Select all
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G94 [GeForce 9600 GT] [10de:0622] (rev a1)

Checking card:  NVIDIA Corporation G94 [GeForce 9600 GT] (rev a1)
Your card is only supported up to the 340 legacy drivers series.
It is recommended to install the
    nvidia-legacy-340xx-driver
package.



So I installed the above driver and then ran nvidia-xconfig:

Code: Select all
$ sudo  nvida-xconfig (to create my xorg.conf file)

After reboot I had then add my screen resolutions to /etc/X11/xorg.conf
Code: Select all
  GNU nano 2.7.4                                       Fil: /etc/X11/xorg.conf                                               

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Philips 190B8CS"
    ModelName      "Unknown"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768"
    EndSubSection
EndSection


On reboot I had my drivers working and the right screen resolution...no problems

I have followed this standard"How To" for Plymouth and am not getting any where...

I understand that I can't use the following:

For Nouveau (nVidia):

# KMS
drm
nouveau modeset=1


becuase that isn't the right info for my nvidia driver....just not sure how to proceed....
Can someone give the heads up on this...
Tell me what you need to know and I will post it.... :D

bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby Head_on_a_Stick » 2017-10-28 13:20

I'm pretty sure you need the open drivers to use Plymouth.

I could be wrong though 'cos I don't use either :D
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6666
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-28 13:25

Hi Head_on_a_Stick :D
Not sure...I did read that Plymouth should work with Probrietary drviers now...

bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby Head_on_a_Stick » 2017-10-28 13:27

Oh yes, so it does, we need v364.12:

https://www.reddit.com/r/linux/comments ... ry_nvidia/
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6666
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-28 14:01

Thanks...my graphics card wont run that driver....

No boot splash then....

bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby ruffwoof » 2017-10-28 14:05

bookie wrote:I understand that I can't use the following:

For Nouveau (nVidia):

# KMS
drm
nouveau modeset=1


becuase that isn't the right info for my nvidia driver....just not sure how to proceed....

Under Jessie I included that (/etc/initramfs-tools/modules) entry with the Nvidia 8600GT that I was using a little while back, and had the quiet and splash kernel boot parameters added as per https://wiki.debian.org/plymouth

I listed the available plymouth themes

# plymouth-set-default-theme -l

and opted for the glow theme

# plymouth-set-default-theme -R glow

and after that it all worked fine (I was also using the legacy nvidia 340 driver).

The nvidia web site suggests that the 340 is also the correct driver for your 9600GT card.
ruffwoof
 
Posts: 211
Joined: 2016-08-20 21:00

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-28 14:17

Hi ruffwoof :D
Something must be wrong then because I am getting 3 bars on the screen then a line of text flashes on the screen ...before my login...?

I have set the resolution to 1280x1024 and my screen is capable...
So something is going wrong...
How do I check for issues?

bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby ruffwoof » 2017-10-28 23:06

bookie wrote:Hi ruffwoof :D
Something must be wrong then because I am getting 3 bars on the screen then a line of text flashes on the screen ...before my login...?

I have set the resolution to 1280x1024 and my screen is capable...
So something is going wrong...
How do I check for issues?

bookie32

I believe that's the default Plymouth theme. 3 boxes with one slightly darker than the others that steps through 1st, 2nd 3rd ... before Plymouth stops and you go back to the console for a second or few before the login.

If you press the escape key whilst the plymouth gui is showing it reverts to the console (text) screen.

Switch it to another choice as I mentioned earlier i.e. (as root)

# plymouth-set-default-theme -l

and opt for one of the other themes i.e.

# plymouth-set-default-theme -R glow

glow is like circle that fills in a clock like manner - something like https://youtu.be/c1bwlG6G8f8 (mine is a different colour)
ruffwoof
 
Posts: 211
Joined: 2016-08-20 21:00

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-29 07:29

Hi ruffwoof :D
Nada...
OK now I am going to show you some info and then we can decide where to go next.... :)

When I set up /etc/initramfs-tools/modules with the settings as advised:
Code: Select all
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod
# KMS
drm
nouveau modeset=1


Here is grub...note I tried grubbakground as well but same problem:
Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="net.ifnames=0"
#GRUBBACKGROUND="usr/share/images/grub/Lake_mapourika_NZ.tga"
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1280x1024x24

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


I updated grub and got this:

Code: Select all
martyn@DN-Server:~$ sudo update-grub
[sudo] lösenord för martyn:
Generera konfigurationsfil för grub …
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Hittade linux-avbildning: /boot/vmlinuz-4.9.0-4-amd64
Hittade initrd-avbildning: /boot/initrd.img-4.9.0-4-amd64
Found iPXE image: /boot/ipxe.lkrn
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
färdigt
martyn@DN-Server:~$

I set my plymouth as shown here:
Code: Select all
martyn@DN-Server:~$ su
Lösenord:
root@DN-Server:/home/martyn# plymouth-set-default-theme -l
details
fade-in
glow
joy
lines
script
softwaves
solar
spacefun
spinfinity
spinner
text
tribar
root@DN-Server:/home/martyn# plymouth-set-default-theme -R glow
update-initramfs: Generating /boot/initrd.img-4.9.0-4-amd64
root@DN-Server:/home/martyn#


I have tried the other way:
Code: Select all
martyn@DN-Server:~$ su
Lösenord:
root@DN-Server:/home/martyn# /usr/sbin/plymouth-set-default-theme --list
details
fade-in
glow
joy
lines
script
softwaves
solar
spacefun
spinfinity
spinner
text
tribar
root@DN-Server:/home/martyn# /usr/sbin/plymouth-set-default-theme glow
root@DN-Server:/home/martyn# update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.9.0-4-amd64
root@DN-Server:/home/martyn#


Now all that said...it is still the same on start...for some reason my grub or initramfs isn't reflecting what I am doing....Grub should be OK because it is actually giving me the 3 bars....but nothing changes the default...?

Is there anything else we can look at?

I couldn't attach any pics etc....attachment quota reached....but I have no attachments....?

bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-29 08:31

Hi again!
Just out of curiosity....
How do I revert to the nouveau driver to test the splash with that.

bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-29 14:09

Hi guys :D
OK... I have done some testing....while I like the nvidia driver installed... I will wait until I upgrade the graphics card so that it works better with plymouth etc...

So, I removed the nvidia drivers and rebooted:

Code: Select all
$ sudo apt-get remove --purge nvidia-*


I had of course the dreaded blinking cursor so I Ctrl+Alt+F1 to come to a terminal...

I then set my xorg.conf with nouveau and not nvidia...

I then ran:
Code: Select all
$ sudo dpkg-reconfigure xorg-xserver


I then rebooted and could come to my welcoming login screen :D

Problem is even though I have added screen resolutions in xorg.conf the best I had was 1024x768...so I set about to fix that....

I don't understand xrandr that well yet but am learning....

I did some tests and created a new mode as shown below:

Code: Select all
martyn@DN-Server:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
DVI-I-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00*
   800x600       60.32    56.25 
   848x480       60.00 
   640x480       59.94 
DVI-I-2 disconnected (normal left inverted right x axis y axis)
  1280x1024 109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --newmode 1280x1024 (0x3b7) 109.000MHz -HSync +VSync
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock  63.67KHz
        v: height 1024 start 1027 end 1034 total 1063           clock  59.89Hz
martyn@DN-Server:~$ cvt 1280 1024
# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
martyn@DN-Server:~$ xrandr --newmode "1280x1024" 109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
martyn@DN-Server:~$ xrander --addmode DVI-I-1 "1280x1024"
bash: xrander: kommandot finns inte
martyn@DN-Server:~$ xrandr --addmode DVI-I-1 "1280x1024"
martyn@DN-Server:~$ xrandr --output DVI-I-1 --mode "1280x1024"
martyn@DN-Server:~$


As you can see I made mistakes but I got to my resolution but couldn't figure out how to save the settings after reboot with xrandr...so I went another way...

Code: Select all
  GNU nano 2.7.4                                       Fil: /etc/X11/xorg.conf                                               


Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Modeline       "1280x1024" 109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync   
    VendorName     "Philips 190B8CS"
    ModelName      "Unknown"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nouveau"
    VendorName     "Nouveau"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768"
    EndSubSection
EndSection


I added the information for xrandr and the resolution I wanted here under "Section Monitor"

I could then go back to my plymouth splash which is now set to "Solar"

After reboot I had the right resolution for login window but still 1024x768 resolution but could go to screen settings and choose the right one and now it works well...

So all well and ends well....

If anyone knows the command för xrandr to save settings after reboot....then please say :D


bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby Head_on_a_Stick » 2017-10-29 15:32

bookie wrote:If anyone knows the command för xrandr to save settings after reboot....then please say :D

The usual trick is to add the `xrandr` command to your desktop startup script(s).

Which desktop environment (or window manager) are you using?
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6666
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-29 16:03

Head_on_a_Stick wrote:
bookie wrote:If anyone knows the command för xrandr to save settings after reboot....then please say :D

The usual trick is to add the `xrandr` command to your desktop startup script(s).

Which desktop environment (or window manager) are you using?


Xfce...
bookie
 
Posts: 284
Joined: 2007-12-07 11:49

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby Head_on_a_Stick » 2017-10-29 16:40

I think XFCE has a "startup script" option buried away in the menus somewhere.

Or you could drop a .desktop file in ~/.config/autostart which runs your `xrandr` command (this is what the XFCE GUI does for you), see https://standards.freedesktop.org/autos ... atest.html for details.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6666
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Installing Plymouth with Nvidia Proprietary drivers

Postby bookie » 2017-10-29 17:33

Head_on_a_Stick wrote:I think XFCE has a "startup script" option buried away in the menus somewhere.

Or you could drop a .desktop file in ~/.config/autostart which runs your `xrandr` command (this is what the XFCE GUI does for you), see https://standards.freedesktop.org/autos ... atest.html for details.

Thanks so much for your help....brilliant :D

bookie32
bookie
 
Posts: 284
Joined: 2007-12-07 11:49


Return to General Questions

Who is online

Users browsing this forum: calkekecal and 5 guests

fashionable