VLC not working

If none of the more specific forums is the right place to ask

VLC not working

Postby pawRoot » 2017-10-28 21:01

Hi
Installed VLC from Debian repository, and when running it i get this error:

VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[000055d04e27e148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000055d04e36a028] core interface error: corrupt module: /usr/lib/x86_64-linux-gnu/vlc/plugins/gui/libqt4_plugin.so
[00007f9bc8029148] core generic error: corrupt module: /usr/lib/x86_64-linux-gnu/vlc/plugins/gui/libqt4_plugin.so
[000055d04e36a028] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[000055d04e36a028] skins2 interface error: cannot instantiate qt4 dialogs provider
[000055d04e36a028] [cli] lua interface: Listening on host "*console".
VLC media player 2.2.6 Umbrella
Command Line Interface initialized. Type `help' for help.
>


Ideas? :cry:
OS: Debian unstable sid
Kernel: x86_64 Linux 4.13.0-1-amd64
WM: Gnome3
CPU: Intel Core i5-4690K CPU @ 3.9GHz
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 187
Joined: 2016-12-28 18:26
Location: Poland

Re: VLC not working

Postby stevepusser » 2017-10-29 00:12

Is this on Sid?

What do you get for

Code: Select all
apt policy vlc
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8903
Joined: 2009-10-06 05:53

Re: VLC not working

Postby TonyT » 2017-10-29 01:18

core interface error: corrupt module

reinstall it.
How dd you install? Synaptic? apt-get?
reinstall it.
TonyT
 
Posts: 525
Joined: 2006-09-04 11:57

Re: VLC not working

Postby pawRoot » 2017-10-29 01:29

stevepusser wrote:Is this on Sid?

What do you get for

Code: Select all
apt policy vlc


vlc:
Installed: 2.2.6-6
Candidate: 2.2.6-6
Version table:
*** 2.2.6-6 500
500 http://ftp.uk.debian.org/debian unstable/main amd64 Packages
100 /var/lib/dpkg/status


And yes, its on sid.

TonyT wrote:
core interface error: corrupt module

reinstall it.
How dd you install? Synaptic? apt-get?
reinstall it.


with apt install vlc, never had problems installing like that.

problem happens also on my laptop.
OS: Debian unstable sid
Kernel: x86_64 Linux 4.13.0-1-amd64
WM: Gnome3
CPU: Intel Core i5-4690K CPU @ 3.9GHz
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 187
Joined: 2016-12-28 18:26
Location: Poland

Re: VLC not working

Postby sunrat » 2017-10-29 22:53

Sid just had a major Qt upgrade. Not sure if it may be related but try a dist-upgrade.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2036
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: VLC not working

Postby pawRoot » 2017-10-29 22:56

sunrat wrote:Sid just had a major Qt upgrade. Not sure if it may be related but try a dist-upgrade.


Nothing to upgrade
OS: Debian unstable sid
Kernel: x86_64 Linux 4.13.0-1-amd64
WM: Gnome3
CPU: Intel Core i5-4690K CPU @ 3.9GHz
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 187
Joined: 2016-12-28 18:26
Location: Poland

Re: VLC not working

Postby debiman » 2017-10-31 06:22

i recently saw an identical complaint, and in the end the package that takes care of porting gtk themes to qt was responsible.

that said and imho mpv is a much better choice for media player on any gnu/linux.
User avatar
debiman
 
Posts: 1528
Joined: 2013-03-12 07:18

Re: VLC not working

Postby pawRoot » 2017-10-31 19:43

I can now confirm that this issue also exist in Buster.

More than that, im not able to get ANY video player to work, when i for example try to run MPV, i get this:

mpv: symbol lookup error: /usr/lib/x86_64-linux-gnu/libass.so.9: undefined symbol: FT_Outline_EmboldenXY
OS: Debian unstable sid
Kernel: x86_64 Linux 4.13.0-1-amd64
WM: Gnome3
CPU: Intel Core i5-4690K CPU @ 3.9GHz
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 187
Joined: 2016-12-28 18:26
Location: Poland

Re: VLC not working

Postby pawRoot » 2017-11-02 16:44

Should i report this as a bug or what?
OS: Debian unstable sid
Kernel: x86_64 Linux 4.13.0-1-amd64
WM: Gnome3
CPU: Intel Core i5-4690K CPU @ 3.9GHz
MOBO: MSI Z97 Gaming 3
User avatar
pawRoot
 
Posts: 187
Joined: 2016-12-28 18:26
Location: Poland

Re: VLC not working

Postby HuangLao » 2017-11-02 18:37

yes report it...this is a reminder of what happens with the non stable branches....If you are going to use those branches then you just became a bug reporter.... :P
User avatar
HuangLao
 
Posts: 332
Joined: 2015-01-27 01:31


Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable