simple-cdd errors

If none of the more specific forums is the right place to ask

simple-cdd errors

Postby Stauricus » 2017-11-02 20:19

hello everybody
i'm trying to create a custom debian cd, but i'm stuck with some errors.

fisrt, i have a file "~/cddapa/profiles/NAME.packages", which contains these packages:
geany
python-tk
playonlinux
codeblocks
codeblocks-contrib
libsfml-dev
libboost-dev
libogre-1.9-dev
vlc
flashplugin-nonfree


and this is what i get when i try to run "build-simple-cdd"
Code: Select all
diego@lenovoG475:~/cddapa$ build-simple-cdd
2017-11-02 18:14:50 WARNING Found uninstallable packages in /home/diego/cddapa/tmp/mirror/dists/buster/main/binary-i386/Packages:
2017-11-02 18:14:50 WARNING   output-version: 1.2
2017-11-02 18:14:50 WARNING   report:
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-atomic1.62-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-atomic1.62-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev (= 1.62.0+dfsg-4+b2)
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-chrono1.62-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-chrono1.62-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev (= 1.62.0+dfsg-4+b2)
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-date-time1.62-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-date-time1.62-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev (= 1.62.0+dfsg-4+b2)
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0.1
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0.1
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-serialization1.62-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-serialization1.62-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev (= 1.62.0+dfsg-4+b2)
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-system1.62-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-system1.62-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev (= 1.62.0+dfsg-4+b2)
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-thread-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0.1
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-thread-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0.1
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost-thread1.62-dev
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-thread1.62-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev (= 1.62.0+dfsg-4+b2)
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost-thread1.62-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-thread1.62-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev (= 1.62.0+dfsg-4+b2)
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libboost1.62-dev
2017-11-02 18:14:50 WARNING     version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING    -
2017-11-02 18:14:50 WARNING     package: libogre-1.9-dev
2017-11-02 18:14:50 WARNING     version: 1.9.0+dfsg1-9
2017-11-02 18:14:50 WARNING     architecture: i386
2017-11-02 18:14:50 WARNING     status: broken
2017-11-02 18:14:50 WARNING     reasons:
2017-11-02 18:14:50 WARNING      -
2017-11-02 18:14:50 WARNING       missing:
2017-11-02 18:14:50 WARNING        pkg:
2017-11-02 18:14:50 WARNING         package: libboost1.62-dev
2017-11-02 18:14:50 WARNING         version: 1.62.0+dfsg-4+b2
2017-11-02 18:14:50 WARNING         architecture: i386
2017-11-02 18:14:50 WARNING         unsat-dependency: libstdc++-4.8-dev | libstdc++-dev
2017-11-02 18:14:50 WARNING        depchains:
2017-11-02 18:14:50 WARNING         -
2017-11-02 18:14:50 WARNING          depchain:
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libogre-1.9-dev
2017-11-02 18:14:50 WARNING            version: 1.9.0+dfsg1-9
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost-dev
2017-11-02 18:14:50 WARNING           -
2017-11-02 18:14:50 WARNING            package: libboost-dev
2017-11-02 18:14:50 WARNING            version: 1.62.0.1
2017-11-02 18:14:50 WARNING            architecture: i386
2017-11-02 18:14:50 WARNING            depends: libboost1.62-dev
2017-11-02 18:14:50 WARNING   
2017-11-02 18:14:50 WARNING   total-packages: 682
2017-11-02 18:14:50 WARNING   broken-packages: 10
2017-11-02 18:14:50 WARNING   
2017-11-02 18:14:51 ERROR build/debian-cd exited with code 2
2017-11-02 18:14:51 ERROR Last 3 lines of standard error:
2017-11-02 18:14:51 ERROR build/debian-cd: failed to read exclude file /home/diego/cddapa/tmp/debian-cd/data/buster/exclude-udebs at ../tools/generate_di_list line 86.
2017-11-02 18:14:51 ERROR build/debian-cd: cp: não foi possível obter estado de '/home/diego/cddapa/tmp/debian-cd/tasks/buster/*': Arquivo ou diretório não encontrado
2017-11-02 18:14:51 ERROR build/debian-cd: make: *** [/home/diego/cddapa/tmp/cd-build/buster/tasks] Error 1
2017-11-02 18:14:51 ERROR build/debian-cd exited with code 2, full log can be found in /home/diego/cddapa/tmp/log/build-debian-cd


i couldn't find anything on google. any help is apreciated. thanks! :mrgreen:
User avatar
Stauricus
 
Posts: 26
Joined: 2013-11-06 11:51

Re: simple-cdd errors

Postby Dai_trying » 2017-11-03 07:49

It looks like you do not have the dependencies on the cd along with the packages that require them.
Dai_trying
 
Posts: 332
Joined: 2016-01-07 12:25

Re: simple-cdd errors

Postby Stauricus » 2017-11-06 10:04

i tried selecting the dependencies, but got the same errors. so i just gave up and brought the whole cpu to where i had internet connection :(
User avatar
Stauricus
 
Posts: 26
Joined: 2013-11-06 11:51


Return to General Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable