I can't install VirtualBox on debian 9

If none of the more specific forums is the right place to ask

I can't install VirtualBox on debian 9

Postby osmak » 2017-11-03 15:02

I tried with this .deb (my pc is x64 so I tried to install first the amd64 version)
virtualbox-5.2_5.2.0-118431-Debian-stretch_amd64.deb
virtualbox-5.2_5.2.0-118431-Debian-stretch_i386.deb



Code: Select all
~/Downloads$ sudo dpkg -i virtualbox-5.2_5.2.0-118431-Debian-stretch_amd64.deb
(Reading database ... 359023 files and directories currently installed.)
Preparing to unpack virtualbox-5.2_5.2.0-118431-Debian-stretch_amd64.deb ...
Unpacking virtualbox-5.2 (5.2.0-118431~Debian~stretch) over (5.2.0-118431~Debian~stretch) ...
dpkg: dependency problems prevent configuration of virtualbox-5.2:
 virtualbox-5.2 depends on libqt5core5a (>= 5.7.0).
 virtualbox-5.2 depends on libqt5gui5 (>= 5.4.0).
 virtualbox-5.2 depends on libqt5opengl5 (>= 5.0.2).
 virtualbox-5.2 depends on libqt5printsupport5 (>= 5.0.2).
 virtualbox-5.2 depends on libqt5widgets5 (>= 5.7.0).
 virtualbox-5.2 depends on libqt5x11extras5 (>= 5.6.0).

dpkg: error processing package virtualbox-5.2 (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (232-25+deb9u1) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Processing triggers for shared-mime-info (1.8-1) ...
Errors were encountered while processing:
 virtualbox-5.2


Can anyone help me?
osmak
 
Posts: 1
Joined: 2017-11-03 14:52

Re: I can't install VirtualBox on debian 9

Postby acewiza » 2017-11-03 16:22

Looks like you're missing some dependencies. dpkg isn't the best way to install stuff like that (stuff with lots of dependencies).
Nobody would ever ask questions If everyone possessed encyclopedic knowledge of the man pages.
User avatar
acewiza
 
Posts: 267
Joined: 2013-05-28 12:38
Location: Out West

Re: I can't install VirtualBox on debian 9

Postby stevepusser » 2017-11-03 16:55

Either run
Code: Select all
apt-get -f install
to fix the problem, or it's better to use gdebi or apt for that task.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8899
Joined: 2009-10-06 05:53

Re: I can't install VirtualBox on debian 9

Postby Dai_trying » 2017-11-04 10:32

If you are running Stretch you could simply add the backport repository and use the version included there (5.1.30-dfsg-1~bpo9+1), I'm not sure you would get updates by using the installation method you are using here.
Dai_trying
 
Posts: 332
Joined: 2016-01-07 12:25

Re: I can't install VirtualBox on debian 9

Postby None1975 » 2017-11-04 13:55

[quote="Dai_trying" I'm not sure you would get updates by using the installation method you are using here.[/quote]
According Debian backports FAQ:
Q: Is there security support for packages from backports.debian.org?
A: Unfortunately not. This is done on a best effort basis by the people who track the package, usually the ones who originally did upload the package into backports. When security related bugs are fixed in Debian unstable the backporter is permitted to upload the package from directly there instead of having to wait until the fix hits testing. You can see the open issues for jessie-backports in the security tracker (though there may be false positives too, the version compare isn't perfect yet)
OS: Debian 8.9 / WM: xmonad
Debian Wiki | DontBreakDebian
User avatar
None1975
 
Posts: 189
Joined: 2015-11-29 18:23
Location: Lithuania

Re: I can't install VirtualBox on debian 9

Postby acewiza » 2017-11-04 16:18

Dai_trying wrote:I'm not sure you would get updates by using the installation method you are using here.

Oracle provides in-app update notification, with a download link.
Nobody would ever ask questions If everyone possessed encyclopedic knowledge of the man pages.
User avatar
acewiza
 
Posts: 267
Joined: 2013-05-28 12:38
Location: Out West

Re: I can't install VirtualBox on debian 9

Postby Dai_trying » 2017-11-04 19:03

OK, i get it, but the rule of thumb I always use is to use Debian repositories unless absolutely unavoidable mainly because of security updates... I thought I had read somewhere that even backports got security updates, but could be mistaken. But a package not available in the repositories wouldn't (normally) get any updates.
Dai_trying
 
Posts: 332
Joined: 2016-01-07 12:25

Re: I can't install VirtualBox on debian 9

Postby acewiza » 2017-11-04 20:19

Dai_trying wrote:OK, i get it... But a package not available in the repositories wouldn't (normally) get any updates.

I don't think you do. This issue might depend more on your definition of "normal" than anything else. The most currently available Virtualbox code has always come only from the software maker themselves - Oracle in this case. Now that it's no longer in Stable, anything in the Debian repos is going to be older versions in some dated patch level state. I suppose Virtualbox update frequency might have been at least part of the reason why Debian decided to drop it from Stretch.
Nobody would ever ask questions If everyone possessed encyclopedic knowledge of the man pages.
User avatar
acewiza
 
Posts: 267
Joined: 2013-05-28 12:38
Location: Out West

Re: I can't install VirtualBox on debian 9

Postby Dai_trying » 2017-11-04 22:26

The point I was making is that installing from a deb file where there is not a matching package in the debian repository will result in no updates/patches. we could go on being pedantic about it and hijack the thread further with irrelevant posts but let's not eh?
Dai_trying
 
Posts: 332
Joined: 2016-01-07 12:25

Re: I can't install VirtualBox on debian 9

Postby acewiza » 2017-11-04 23:54

Dai_trying wrote:The point I was making is that installing from a deb file where there is not a matching package in the debian repository will result in no updates/patches.

Only if you yourself choose not to perform an update, manually.

You may let apt do this automatically to receive whatever patches filter down into backports at the time of their choosing for whatever version(s) the Debianites may (or may not) feel compelled to provide. Or not(?). That depends on alot of people besides you. You know, the ones who chose not to keep VBox in the stable repo, which appears to be what started the OP's issue in the 1st place.

As always, one of the things most love about Linux, your choice obviously. :lol:
Nobody would ever ask questions If everyone possessed encyclopedic knowledge of the man pages.
User avatar
acewiza
 
Posts: 267
Joined: 2013-05-28 12:38
Location: Out West

Re: I can't install VirtualBox on debian 9

Postby kujirasan » 2017-11-05 05:57

Delete what you got completely and all the left overs , go to VirtualBox VMs, and delete the files directories inside it,






you must install oracle jdk/jre or openjdk first.

When downloading Virtuabox, be a good practice to down load its extension pack, as without it not much could be don, the extension pack has to match the same version as the virtual box, a mismatch can be disastrous, so install them together!

Go to: https://www.virtualbox.org/wiki/Downloads,
and downlload the extension pack first :
click : VirtualBox 5.2.0 Oracle VM VirtualBox Extension Pack  All supported platforms 


then click on VirtualBox 5.2.0 for Linux hosts,

go to the last line :
All distributions (built on EL5 and therefore do not require recent system libraries)  i386 |  AMD64

and download this one, depending on your system (64, 32 bit), once download is complete use you file manager to change its name by clicking on rename option and delete .txt (the dot included) this will produce a new icon which is a script type, now use the terminal command line do this:
#chmod +x .................................. and then: install using :

# ./VirtualBox-5.2.0-118431-Linux_amd64.run

....................................................
after installation is completed , install the extension pack:

#VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-5.2.0-118431.vbox-extpack
..........................................




Installing gust additions to get a full screen option:

restart the computer and go to opt directory, you will see the VirtualBox go to it, then go to additions directory you will see virtualbox guest addition and do the following


chmod +x VBoxGuestAdditions.iso...............


# mount -o loop VBoxGuestAdditions.iso /mnt

then go to mnt directory issue the command as follows,
you will get a message like this: mount: /dev/loop0 is write-protected, mounting read-only, ignore it.
go to mnt directory
#cd /
#cd mnt
and :

#./VBoxLinuxAdditions.run

the setup is completed.
kujirasan
 
Posts: 182
Joined: 2009-03-08 23:07


Return to General Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable