install viber on debian 9

If none of the more specific forums is the right place to ask

install viber on debian 9

Postby lilyana » 2017-11-17 14:44

I'm trying to install viber on debian by use this command
Code: Select all
   # wget http://download.cdn.viber.com/cdn/desktop/Linux/Viber.zip
# unzip Viber.zip
# cd Viber
# ./Viber.sh

the first time I have this message
Code: Select all
Failed to load module "canberra-gtk-module

after that I install it by
Code: Select all
sudo apt-get install libcanberra-gtk-module

the other error is
Code: Select all
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

when use update I have the same problem I can not install canberra-gtk-module , how can solve it??
lilyana
 
Posts: 15
Joined: 2017-11-07 15:28

Re: install viber on debian 9

Postby steve_v » 2017-11-17 16:12

For a start, post the complete output of 'apt install canberra-gtk-module'.
The error you mentioned points to download issues, it should be available in Stretch, so it might be worth trying another mirror.
steve_v
 
Posts: 529
Joined: 2012-10-06 05:31
Location: New Zealand

Re: install viber on debian 9

Postby lilyana » 2017-11-17 17:26

steve_v wrote:For a start, post the complete output of 'apt install canberra-gtk-module'.
The error you mentioned points to download issues, it should be available in Stretch, so it might be worth trying another mirror.

Code: Select all
sudo apt-get install libcanberra-gtk-module
[sudo] password for sara:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libcanberra-gtk0
The following NEW packages will be installed:
  libcanberra-gtk-module libcanberra-gtk0
0 upgraded, 2 newly installed, 0 to remove and 41 not upgraded.
Need to get 0 B/32.7 kB of archives.
After this operation, 88.1 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
lilyana
 
Posts: 15
Joined: 2017-11-07 15:28

Re: install viber on debian 9

Postby stevepusser » 2017-11-17 20:45

Your system is damaged. Have you been adding non-Debian repositories?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8938
Joined: 2009-10-06 05:53

Re: install viber on debian 9

Postby lilyana » 2017-11-18 08:59

I'm try now !!!
Code: Select all
$ sudo apt-get install libcanberra-gtk-module
[sudo] password for sara:
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
lilyana
 
Posts: 15
Joined: 2017-11-07 15:28

Re: install viber on debian 9

Postby debiman » 2017-11-18 09:40

lilyana wrote:
Code: Select all
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)

wow, something is really broken here.
since we cannot come to your house and fix it for you, i suggest a reinstall.
and be more careful in the future. this includes running downloaded scripts without knowing what they're doing, esp. if they're asking for your password or have to be executed with superuser privileges.
User avatar
debiman
 
Posts: 1626
Joined: 2013-03-12 07:18

Re: install viber on debian 9

Postby steve_v » 2017-11-18 09:52

lilyana wrote:
Code: Select all
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Exactly as it says. You likely have some GUI package manager running, or apt in another console. Either that or you have forcibly killed dpkg at some point and need to remove the lockfile.

You have bigger problems than being unable to install viber, if your system is missing ldconfig and start-stop daemon. Check that these binaries actually exist. If they do, your PATH variable is messed up, if not, you have somehow managed to remove critical parts of the base system. In the latter case, you may be able to reinstall the relevant packages (dpkg & libc-bin)... but a reinstall will probably be easier.

I'm curious as to how an install can get into this state to begin with, TBH.
steve_v
 
Posts: 529
Joined: 2012-10-06 05:31
Location: New Zealand

Re: install viber on debian 9

Postby Wheelerof4te » 2017-11-19 18:46

My advice is to reinstall Debian Stable, since you have broken it.

To install Viber on Debian 9, you will need one package from Debian 8 (Jessie), libssl1.0.0

Get it from here.
User avatar
Wheelerof4te
 
Posts: 451
Joined: 2015-08-30 20:14

Re: install viber on debian 9

Postby lilyana » 2017-11-21 08:25

I cannot reinstall again . :(
lilyana
 
Posts: 15
Joined: 2017-11-07 15:28

Re: install viber on debian 9

Postby lilyana » 2017-11-21 08:28

Wheelerof4te wrote:My advice is to reinstall Debian Stable, since you have broken it.

To install Viber on Debian 9, you will need one package from Debian 8 (Jessie), libssl1.0.0

Get it from here.


Can you give me the command how can install after download it please.
lilyana
 
Posts: 15
Joined: 2017-11-07 15:28

Re: install viber on debian 9

Postby steve_v » 2017-11-21 09:36

lilyana wrote:Can you give me the command how can install after download it please.

dpkg -i <package filename.deb>

But again, if you are missing parts of dpkg and libc-bin your install is horribly borked. We have no idea what else is broken or how it got that way (FrankenDebian, anyone?), so there's no guarantee any advice given here will actually work.
Your best option is to reinstall the OS. Failing that, ignore this viber thing for a minute and concentrate on fixing the bigger problem. Then, when the rest of the system is in a predictable not-borked state, installing viber will go smoothly.

A good start would be to figure out how broken this install is.
Have you checked if ldconfig and start-stop-daemon exist in /sbin/?
What's in your sources.list, and what does 'echo $PATH' say when run as root?
steve_v
 
Posts: 529
Joined: 2012-10-06 05:31
Location: New Zealand

Re: install viber on debian 9

Postby arochester » 2017-11-21 10:33

I cannot reinstall again. :(
Why?
"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN." - oswaldkelso
arochester
 
Posts: 1118
Joined: 2010-12-07 19:55

Re: install viber on debian 9

Postby Wheelerof4te » 2017-11-21 16:23

lilyana wrote:dpkg -i <package filename.deb>


That is the old way. New one, which will solve dependencies too, is
Code: Select all
apt install ./<package filename.deb>

You need to be in the directory where the .deb file is.
User avatar
Wheelerof4te
 
Posts: 451
Joined: 2015-08-30 20:14

Re: install viber on debian 9

Postby debiman » 2017-11-21 17:03

User avatar
debiman
 
Posts: 1626
Joined: 2013-03-12 07:18

Re: install viber on debian 9

Postby lilyana » 2017-11-21 17:47

arochester wrote:
I cannot reinstall again. :(
Why?


All my work on this OS and the installation take time
lilyana
 
Posts: 15
Joined: 2017-11-07 15:28

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable