python-protobuf error when installing yowsup-cli[SOLVED]

If none of the more specific forums is the right place to ask

python-protobuf error when installing yowsup-cli[SOLVED]

Postby ramack » 2017-11-21 02:19

I'm running into an error from python-protobuf when installing yowsup-cli

Code: Select all
$ sudo apt-get install yowsup-cli
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  python-axolotl python-axolotl-curve25519 python-yowsup
The following NEW packages will be installed:
  python-axolotl python-axolotl-curve25519 python-yowsup yowsup-cli
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/208 kB of archives.
After this operation, 1,268 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Selecting previously unselected package python-axolotl-curve25519.
(Reading database ... 328272 files and directories currently installed.)
Preparing to unpack .../python-axolotl-curve25519_0.1-3_amd64.deb ...
Unpacking python-axolotl-curve25519 (0.1-3) ...
Selecting previously unselected package python-axolotl.
Preparing to unpack .../python-axolotl_0.1.35-3_all.deb ...
Unpacking python-axolotl (0.1.35-3) ...
Selecting previously unselected package python-yowsup.
Preparing to unpack .../python-yowsup_2.5.0~git20160904.d69c1ff-1_all.deb ...
Unpacking python-yowsup (2.5.0~git20160904.d69c1ff-1) ...
Selecting previously unselected package yowsup-cli.
Preparing to unpack .../yowsup-cli_2.5.0~git20160904.d69c1ff-1_all.deb ...
Unpacking yowsup-cli (2.5.0~git20160904.d69c1ff-1) ...
Setting up python-axolotl-curve25519 (0.1-3) ...
Setting up python-protobuf (3.0.0-9) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-protobuf (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for man-db (2.7.6.1-2) ...
dpkg: dependency problems prevent configuration of python-axolotl:
 python-axolotl depends on python-protobuf (>= 3.0.0); however:
  Package python-protobuf is not configured yet.

dpkg: error processing package python-axolotl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yowsup-cli:
 yowsup-cli depends on python-axolotl (>= 0.1.35); however:
  Package python-axolotl is not configured yet.

dpkg: error processing package yowsup-cli (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-yowsup:
 python-yowsup depends on python-axolotl; however:
  Package python-axolotl is not configured yet.

dpkg: error processing package python-yowsup (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-protobuf
 python-axolotl
 yowsup-cli
 python-yowsup
E: Sub-process /usr/bin/dpkg returned an error code (1)


I can apt-get purge yowsup-cli, but still left with the errors from python-protobuf and can't figure out how to resolve the issue. Any ideas?
Thanks.
Last edited by ramack on 2017-11-21 14:10, edited 1 time in total.
homemade AMD64, Acer AspireOne 150, Asus eeePC 900, i386; Testing
i386,Dell Vostro 1000 AMD64, Dell Inspiron 1100; Sid
XFCE on all.
ramack
 
Posts: 437
Joined: 2008-01-28 15:31
Location: Centennial, CO

Re: python-protobuf error when installing yowsup-cli

Postby dilberts_left_nut » 2017-11-21 04:22

https://duckduckgo.com/?q=ImportError%3 ... fpas&ia=qa

Looks like a python 2.7 vs python 3 issue.
What is your setup?
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4703
Joined: 2009-10-05 07:54
Location: enzed

Re: python-protobuf error when installing yowsup-cli

Postby ramack » 2017-11-21 14:08

Thanks, yes it is a version conflict. I'm running Stable.

How I ended up resolving the issue was manually changing to Python 2

Code: Select all
$ sudo update-alternatives --config python
There are 2 choices for the alternative python (providing /usr/bin/python).

  Selection    Path                Priority   Status
------------------------------------------------------------
  0            /usr/bin/python3.5   2         auto mode
* 1            /usr/bin/python2.7   1         manual mode
  2            /usr/bin/python3.5   2         manual mode

Press <enter> to keep the current choice[*], or type selection number: 2
update-alternatives: using /usr/bin/python3.5 to provide /usr/bin/python (python) in manual mode


Then running sudo apt-get purge yowsup-cli to clean everything up. I configured python back to its original setting. Band-aid fix, but the errors are gone. I'm marking as [SOLVED],
homemade AMD64, Acer AspireOne 150, Asus eeePC 900, i386; Testing
i386,Dell Vostro 1000 AMD64, Dell Inspiron 1100; Sid
XFCE on all.
ramack
 
Posts: 437
Joined: 2008-01-28 15:31
Location: Centennial, CO


Return to General Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable