Windows share not mounting at boot

If none of the more specific forums is the right place to ask

Windows share not mounting at boot

Postby Mafamaticks » 2017-11-26 13:13

I'm generally new to Linux.

I'm running Debian 9.2 with LXDE inside of a Windows Hyper-v host
My /etc/fstab entry looks like the following:

Code: Select all
//servername/sharename  /media/windowsshare  cifs  username=username,password=password,uid=1000,gid=1000      0     0


When I run mount -a it mounts properly and I'm able to read and write to it.

When I restart, it fails to mount at boot and gives me a quick flash of check systemctl.

I'm thinking it's trying to mount too early but I'm not sure.

Any ideas?
Mafamaticks
 
Posts: 3
Joined: 2017-11-26 13:04

Re: Windows share not mounting at boot

Postby 4D696B65 » 2017-11-26 13:30

Mafamaticks wrote:Any ideas?

yes
Mafamaticks wrote:check systemctl.
User avatar
4D696B65
 
Posts: 2040
Joined: 2009-06-28 06:09

Re: Windows share not mounting at boot

Postby p.H » 2017-11-26 15:04

You may try to add _netdev to the option list in fstab.

From man mount :
_netdev
The filesystem resides on a device that requires network access (used to prevent the system from attempting to mount these filesystems until the network has been enabled on the system).

p.H
 
Posts: 177
Joined: 2017-09-17 07:12

Re: Windows share not mounting at boot

Postby Mafamaticks » 2017-11-26 15:40

4D696B65 wrote:
Mafamaticks wrote:Any ideas?

yes
Mafamaticks wrote:check systemctl.



Okay. How? What do I look for? When should I do it?

I'm new to Linux so would you mind going in depth?
Mafamaticks
 
Posts: 3
Joined: 2017-11-26 13:04

Re: Windows share not mounting at boot

Postby Mafamaticks » 2017-11-26 15:41

p.H wrote:You may try to add _netdev to the option list in fstab.

From man mount :
_netdev
The filesystem resides on a device that requires network access (used to prevent the system from attempting to mount these filesystems until the network has been enabled on the system).



I'm googling it now. Am I supposed to add that to the .conf file?

edit.

Looks like the line should read

Code: Select all
//servername/sharename  /media/windowsshare  cifs  _netdev,username=username,password=password,uid=1000,gid=1000      0     0
Mafamaticks
 
Posts: 3
Joined: 2017-11-26 13:04

Re: Windows share not mounting at boot

Postby p.H » 2017-11-26 16:42

Guess so, but I have never used it. Does it work ?
Which .conf file were you talking about ?
p.H
 
Posts: 177
Joined: 2017-09-17 07:12


Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable