Update on Debian Stretch caused Display flickers

If none of the more specific forums is the right place to ask

Update on Debian Stretch caused Display flickers

Postby nathanid95 » 2017-12-12 23:29

Hi guys,

I ran an apt upgrade yesterday, and now I'm having issues with my display. When I move my mouse between displays, I get a black flicker on the lower half of the display the mouse is leaving. Sometimes the display shuts off entirely until I move the mouse back to that display. I'm running Stretch with the latest updates on a Lenovo Thinkpad T510. I'm trying to figure out what package to revert to get this fixed, as it's distracting when I'm trying to work. I'm using Gnome shell on x11, but I tried switching my session to Gnome on Wayland and the problem persisted. I don't see any packages in my dpkg log that seem like they would cause this problem unless it's a kernel issue, but on my particular hardware I'd expect kernel issues to be rare (oldish Thinkpad and all).

Here's my /var/log/dpkg.log (the upgrade that cause the problem was run on 12/11/17) :

Code: Select all
2017-12-05 14:43:39 upgrade exim4-config:all 4.89-2+deb9u1 4.89-2+deb9u2
2017-12-05 14:43:39 upgrade exim4-base:amd64 4.89-2+deb9u1 4.89-2+deb9u2
2017-12-05 14:43:39 upgrade exim4-daemon-light:amd64 4.89-2+deb9u1 4.89-2+deb9u2
2017-12-11 09:04:32 upgrade firefox-esr:amd64 52.5.0esr-1~deb9u1 52.5.2esr-1~deb9u1
2017-12-11 09:04:38 upgrade libxcursor-dev:amd64 1:1.1.14-1+b4 1:1.1.14-1+deb9u1
2017-12-11 09:04:39 upgrade libxcursor1:amd64 1:1.1.14-1+b4 1:1.1.14-1+deb9u1
2017-12-11 09:04:40 upgrade libxcursor1:i386 1:1.1.14-1+b4 1:1.1.14-1+deb9u1
2017-12-11 12:02:02 upgrade base-files:amd64 9.9+deb9u2 9.9+deb9u3
2017-12-11 12:02:02 upgrade libdbus-1-dev:amd64 1.10.22-0+deb9u1 1.10.24-0+deb9u1
2017-12-11 12:02:02 upgrade dbus:amd64 1.10.22-0+deb9u1 1.10.24-0+deb9u1
2017-12-11 12:02:03 upgrade dbus-user-session:all 1.10.22-0+deb9u1 1.10.24-0+deb9u1
2017-12-11 12:02:03 upgrade dbus-x11:amd64 1.10.22-0+deb9u1 1.10.24-0+deb9u1
2017-12-11 12:02:03 upgrade libdbus-1-3:amd64 1.10.22-0+deb9u1 1.10.24-0+deb9u1
2017-12-11 12:02:03 upgrade libdbus-1-3:i386 1.10.22-0+deb9u1 1.10.24-0+deb9u1
2017-12-11 12:02:03 upgrade google-chrome-stable:amd64 62.0.3202.94-1 63.0.3239.84-1
2017-12-11 12:02:10 upgrade python2.7-dev:amd64 2.7.13-2 2.7.13-2+deb9u2
2017-12-11 12:02:10 upgrade python2.7:amd64 2.7.13-2 2.7.13-2+deb9u2
2017-12-11 12:02:10 upgrade libpython2.7-dev:amd64 2.7.13-2 2.7.13-2+deb9u2
2017-12-11 12:02:13 upgrade libpython2.7:amd64 2.7.13-2 2.7.13-2+deb9u2
2017-12-11 12:02:13 upgrade libsqlite3-0:amd64 3.16.2-5 3.16.2-5+deb9u1
2017-12-11 12:02:13 upgrade libpython2.7-stdlib:amd64 2.7.13-2 2.7.13-2+deb9u2
2017-12-11 12:02:13 upgrade python2.7-minimal:amd64 2.7.13-2 2.7.13-2+deb9u2
2017-12-11 12:02:14 upgrade libpython2.7-minimal:amd64 2.7.13-2 2.7.13-2+deb9u2
2017-12-11 12:02:15 upgrade iproute2:amd64 4.9.0-1 4.9.0-1+deb9u1
2017-12-11 12:02:16 upgrade openssh-sftp-server:amd64 1:7.4p1-10+deb9u1 1:7.4p1-10+deb9u2
2017-12-11 12:02:16 upgrade openssh-server:amd64 1:7.4p1-10+deb9u1 1:7.4p1-10+deb9u2
2017-12-11 12:02:16 upgrade openssh-client:amd64 1:7.4p1-10+deb9u1 1:7.4p1-10+deb9u2
2017-12-11 12:02:16 upgrade fig2dev:amd64 1:3.2.6a-2 1:3.2.6a-2+deb9u1
2017-12-11 12:02:16 upgrade gdm3:amd64 3.22.3-3 3.22.3-3+deb9u1
2017-12-11 12:02:17 upgrade libgdm1:amd64 3.22.3-3 3.22.3-3+deb9u1
2017-12-11 12:02:18 upgrade gir1.2-gdm-1.0:amd64 3.22.3-3 3.22.3-3+deb9u1
2017-12-11 12:02:18 upgrade libicu-dev:amd64 57.1-6 57.1-6+deb9u1
2017-12-11 12:02:22 upgrade icu-devtools:amd64 57.1-6 57.1-6+deb9u1
2017-12-11 12:02:22 upgrade libicu57:amd64 57.1-6 57.1-6+deb9u1
2017-12-11 12:02:23 upgrade libicu57:i386 57.1-6 57.1-6+deb9u1
2017-12-11 12:02:25 upgrade libxkbcommon-dev:amd64 0.7.1-1 0.7.1-2~deb9u1
2017-12-11 12:02:27 upgrade libxkbcommon-x11-0:amd64 0.7.1-1 0.7.1-2~deb9u1
2017-12-11 12:02:27 upgrade libxkbcommon0:amd64 0.7.1-1 0.7.1-2~deb9u1
2017-12-11 12:02:27 upgrade linux-compiler-gcc-6-x86:amd64 4.9.51-1 4.9.65-3
2017-12-11 12:02:27 upgrade linux-headers-4.9.0-4-amd64:amd64 4.9.51-1 4.9.65-3
2017-12-11 12:02:30 upgrade linux-headers-4.9.0-4-common:all 4.9.51-1 4.9.65-3
2017-12-11 12:02:35 upgrade linux-kbuild-4.9:amd64 4.9.51-1 4.9.65-3
2017-12-11 12:02:35 upgrade linux-image-4.9.0-4-amd64:amd64 4.9.51-1 4.9.65-3
2017-12-11 12:02:49 upgrade linux-libc-dev:amd64 4.9.51-1 4.9.65-3
2017-12-11 12:02:49 upgrade live-config-doc:all 5.20170112 5.20170112+deb9u1
2017-12-11 12:02:49 upgrade slack-desktop:amd64 2.9.0 3.0.0
2017-12-11 12:03:02 upgrade syslinux:amd64 3:6.03+dfsg-14.1 3:6.03+dfsg-14.1+deb9u1
2017-12-11 12:03:02 upgrade syslinux-common:all 3:6.03+dfsg-14.1 3:6.03+dfsg-14.1+deb9u1
2017-12-11 12:03:02 upgrade syslinux-utils:amd64 3:6.03+dfsg-14.1 3:6.03+dfsg-14.1+deb9u1
2017-12-11 12:03:02 upgrade transfig:all 1:3.2.6a-2 1:3.2.6a-2+deb9u1
2017-12-11 12:03:02 upgrade iproute:all 1:4.9.0-1 1:4.9.0-1+deb9u1
2017-12-11 12:03:02 upgrade liblouis-data:all 3.0.0-3 3.0.0-3+deb9u1
2017-12-11 12:03:03 upgrade liblouis12:amd64 3.0.0-3+b1 3.0.0-3+deb9u1
2017-12-11 12:03:03 upgrade python3-louis:all 3.0.0-3 3.0.0-3+deb9u1


I'd appreciate any suggestions!
nathanid95
 
Posts: 7
Joined: 2017-02-23 04:38

Re: Update on Debian Stretch caused Display flickers

Postby Capitain_Jack » 2017-12-19 12:29

Take a look into this post, it may be related to your problem, and one guy strugled to find this solution:
This affected me too. Finally after weeks of frustration I found the solution posted in a Launchpad bug (https://bugs.launchpad.net/ubuntu/+sour ... ug/1382462).
In short:
Install CCSM (sudo apt-get install compizconfig-settings-manager)
In CCSM go to "General Options" --> "Display Settings" and do the following:
Un-check "Detect Outputs"
In the Outputs array, set the resolutions of each of your screens.
In my case it was:
Code: Select all
1920x1080+0+0
         1920x1080+1920+0

Now edit your display configuration as usual. In Unity: Dash --> Screen Display

https://askubuntu.com/questions/638875/ ... ng-station
"Great spirits have always encountered violent opposition from mediocre minds."
Albert Einstein
"All wrong-doing arises because of mind. If mind is transformed can wrong-doing remain?"
Buddha
User avatar
Capitain_Jack
 
Posts: 150
Joined: 2017-12-15 12:07
Location: Brazil capital, Brasilia, At the favela.

Re: Update on Debian Stretch caused Display flickers

Postby Wheelerof4te » 2017-12-19 17:26

nathanid95 wrote:unless it's a kernel issue, but on my particular hardware I'd expect kernel issues to be rare

It is a kernel issue, if you are on Intel graphics.
See:
https://www.mail-archive.com/debian-ker ... 09466.html
User avatar
Wheelerof4te
 
Posts: 547
Joined: 2015-08-30 20:14


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable