[SOLVED] Seccomp prevented execution of syscall at apt-get

If none of the more specific forums is the right place to ask

[SOLVED] Seccomp prevented execution of syscall at apt-get

Postby Capitain_Jack » 2017-12-28 11:51

Not sure what causes this, as I cannot replicate on every system, but if you face this error, there is a work around that worked all times.

The solution
Must be issued as root, sudo won't do it.

For systems with sudoers NOPASSWD flag (sudo don't ask for password):
Code: Select all
sudo su

Code: Select all

Than issue this:
Code: Select all
echo 'apt::sandbox::seccomp "false";' > /etc/apt/apt.conf.d/999seccomp

Proceed to normal use of apt-get.
"Great spirits have always encountered violent opposition from mediocre minds."
Albert Einstein
"All wrong-doing arises because of mind. If mind is transformed can wrong-doing remain?"
User avatar
Posts: 153
Joined: 2017-12-15 12:07
Location: Brazil capital, Brasilia, At the favela.

Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests