Can't install Steam on Debian Sid

If none of the more specific forums is the right place to ask

Can't install Steam on Debian Sid

Postby dragodin » 2018-02-06 18:43

**Solution at the bottom**

Hi everyone,
I'm trying to install steam on Debian Sid. I followed this guide:

and I get this result:

Code: Select all
    draco@draco:~$ sudo apt install steam
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     steam:i386 : Depends: libtxc-dxtn0:i386 but it is not installable
              Recommends: libxss1:i386 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

I've tried these commands to fix the broken packages but it looks like there are none:

Code: Select all
    apt-get update –fix-missing
    dpkg --configure -a
    apt-get install -f

I've also tried synaptics -> Edit -> fix broken packages, to no vail.

Any ideas?

Thanks in advance

**Edit Solution**: libtxc-dxtn0 is provided by llibtxc-dxtn-s2tc, which currently isn't available for sid. You need to take the package from testing (buster).
Add a buster line in your /etc/apt/sources.list

==> deb buster main non-free contrib


Code: Select all
    sudo apt-get update
    sudo apt-get -t buster install libtxc-dxtn-s2tc:i386

Remove the buster line from sources.list
Code: Select all
    sudo apt update
    sudo apt install steam

it will tell you to install a bunch of stuff and should work
Last edited by dragodin on 2018-02-06 21:53, edited 4 times in total.
Posts: 8
Joined: 2018-01-02 08:38

Re: Can't install Steam on Debian Sid

Postby dilberts_left_nut » 2018-02-06 19:04

It's Sid - that's quite normal.

You'll need to look at those dependencies to see what's preventing them from installing.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
Posts: 4924
Joined: 2009-10-05 07:54
Location: enzed

Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests