Some repos not working through apt-cacher-ng

If none of the more specific forums is the right place to ask

Some repos not working through apt-cacher-ng

Postby Thewafflication » 2018-02-11 19:50

I am running debian stretch on my computer.
I am running debian jessie on my WD-MyCloud with apt-cacher-ng running on it. (Along with OpenMediaVault).

In my apt.conf I have:
Code: Select all
Aquire::http::Proxy "http://10.51.1.46:3142";


and it works very well for official debian repos.

Today I tried installing docker from these instructions:
https://docs.docker.com/install/linux/docker-ce/debian/

I get this when I run apt update:
Code: Select all
Ign:1 https://download.docker.com/linux/debian stretch InRelease
Err:2 https://download.docker.com/linux/debian stretch Release
  Received HTTP code 403 from proxy after CONNECT
Ign:3 http://ftp.us.debian.org/debian stretch InRelease
Hit:4 http://security.debian.org/debian-security stretch/updates InRelease
Ign:5 http://download.opensuse.org/repositories/home:/smplayerdev/Debian_9.0  InRelease
Hit:6 http://ftp.us.debian.org/debian stretch-updates InRelease
Hit:7 http://download.opensuse.org/repositories/home:/smplayerdev/Debian_9.0  Release
Hit:8 http://ftp.us.debian.org/debian stretch Release
Reading package lists... Done                   
E: The repository 'https://download.docker.com/linux/debian stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


It works if I comment out my Proxy in apt.conf. Any ideas how to get it to work through apt-cacher-ng?
Thewafflication
 
Posts: 1
Joined: 2018-02-02 00:56

Re: Some repos not working through apt-cacher-ng

Postby jibberjabber » 2018-03-26 07:56

Have you seen this ? :
https://wiki.debian.org/AptCacherNg
HTTPS repositories

apt-cacher-ng will obviously fail to serve HTTPS repositories. There are many solutions upstream but I have found the simplest solution to be to simply tunnel HTTPS connections directly on the proxy, by putting this in /etc/apt-cacher-ng/acng.conf: --- snip--


Use the above link for all the details, if you have not read it, or read it again.
jibberjabber
 
Posts: 119
Joined: 2016-01-10 16:58


Return to General Questions

Who is online

Users browsing this forum: prashanth272 and 7 guests

fashionable