Debian 9 Stable, Samsung NVME 950 Pro locks up and freezes!

If none of the more specific forums is the right place to ask

Debian 9 Stable, Samsung NVME 950 Pro locks up and freezes!

Postby banshee28 » 2018-03-03 01:33

Hello, so I have a fresh install of Debian and having issues with it locking up after just a few mins.

Background: I have Arch installed currently on SSD, with the NVME installed just not used as the primary OS drive. Its been there for about 1 year with no issues.

Recently I decided to install Debian and figured I would install to the NVME. I got it installed and booted fine, but randomly from 5-60 mins, it constantly crashes. Crashes range from screen freeze, (although mouse moves but cant click), constant long beep and freeze, and even some small beeps. I have to physically reboot it each time. I am not sure if this is hardware-related since the NVME drive has been installed for years under Arch with no real issues.

Settings/changes: I have since updated the BIOS (Asus X99 Sabertooth) to the very latest: 3801. I have updated the Samsung NVME firmware to the latest 2B0QBXX7. I installed the latest Debian kernel using backports: 4.14.x I also tried to disable the APST setting it in the grub menu on boot (Autonomous Power State Transition) and it still locks up after a few mins the same exact way.

I HAVE booted to the Debian grub menu, and dropped down to the grub command line, and left it there overnight. It was perfect and was fully functioning in the morning. So something with booting a Linux kernel running on the NVME seems to be the issue?

I seen a few other posts regarding a possible bug with NVME and the Kernel, but figured by now this latest kernel should have fixed the issues?

https://bugs.debian.org/cgi-bin/bugrepo ... bug=866511
https://lists.infradead.org/pipermail/l ... 11382.html

Any help is appreciated! :)
banshee28
 
Posts: 2
Joined: 2018-03-03 01:28

Re: Debian 9 Stable, Samsung NVME 950 Pro locks up and freez

Postby banshee28 » 2018-03-04 20:50

I think this is solved now. It appears to have been not having the correct Nvidia drivers for my Video card! I installed the Nvida 340 Legacy drivers and its been working great for about a day now, where before it would lock up in a few mins. For anyone having random lockups on a new system: Make sure ALL your firmware/drivers are correct. :mrgreen:
banshee28
 
Posts: 2
Joined: 2018-03-03 01:28

Re: Debian 9 Stable, Samsung NVME 950 Pro locks up and freez

Postby Head_on_a_Stick » 2018-03-04 21:35

Nouveau ftw!
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8315
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable