python multiarch installation problem

If none of the more specific forums is the right place to ask

python multiarch installation problem

Postby badfish99 » 2018-03-05 11:26

I'm running a 64-bit aarch64 machine on which I've installed 32-bit python:armhf in order to use a 3rd-party library which is not open source (yes, I know, I'm sorry).
If I try to install the python-requests package (which is architecture-independent) via 'apt-get install python-requests' then apt-get wants to remove all my python:armhf packages and replace them with the aarch64 equivalents.
Is this bug in the packaging of python-requests? Is there a way to persuade apt-get to install it? I've tried reading the multiarch documentation, but it's not very obvious what should happen.
badfish99
 
Posts: 1
Joined: 2018-03-05 11:06

Re: python multiarch installation problem

Postby makh » 2018-03-15 22:54

Hi

try chroot/schroot... it may help.

Thankyou
HP Probook 440 G2: Arch, Debian Stable
Server: none
Past: Debian, Centos, Ubuntu, Opensuse
GUI: Openbox, Cinnamon
Chroot: Debian, Ubuntu, Fedora
VM: Devuan

Employing the best:
Arabic
Debian
Homeopathic

For new: Try Linux Mint
User avatar
makh
 
Posts: 622
Joined: 2011-10-09 09:16


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable