[SOLVED] Deb Stretch lacks libssl1.0.0_1.0.1t-1+deb8u8_amd64

If none of the more specific forums is the right place to ask

[SOLVED] Deb Stretch lacks libssl1.0.0_1.0.1t-1+deb8u8_amd64

Postby _nobody_ » 2018-05-05 14:55

Interesting... The newest Debian stretch release (Debian 9.4.0 amd64) does NOT have libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb included in the set of neither basic, neither extended packages??? :mrgreen:

Why, that is the question?

As one of main/one of the examples, viber installation does NOT work without libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb .

Debian admins should fix this issue, don't you agree!? :shock:

To fix this problem, the following should be done:
Code: Select all
[1] go to: https://packages.debian.org/jessie/amd64/libssl1.0.0/download
[2] Download: security.debian.org/debian-security/pool/updates/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb
[3] cd ~/Download
[4] sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb

Do we, Debian people, have major problem here? :evil:

_nobody_
Last edited by _nobody_ on 2018-05-06 04:51, edited 1 time in total.
_nobody_
 
Posts: 19
Joined: 2018-04-10 02:07

Re: Debian stretch rel. lacks libssl1.0.0_1.0.1t-1+deb8u8_am

Postby bw123 » 2018-05-05 15:18

_nobody_ wrote:Why, that is the question?


Maybe it is not needed for any of the other pkgs in stretch? Why would a single older ver of a lib be included if it's not needed?


Debian admins should fix this issue, don't you agree!? :shock:


I think viber should fix their software, or make it open-source so other people can fix it. I think you could request that the libssl1.0.0 pkg be added back to the repo, and if you were willing to maintain it, maybe it would be accepted for buster?

found these on a search
viewtopic.php?t=127111
https://www.reddit.com/r/debian/comment ... iber_fail/
https://en.wikipedia.org/wiki/Viber#Security
Are you aware of any security implications of using the older ver? Not saying there are, but I would consider that before advising other people to do it.
User avatar
bw123
 
Posts: 3139
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Debian stretch rel. lacks libssl1.0.0_1.0.1t-1+deb8u8_am

Postby pvidic » 2018-05-05 16:13

It looks like we have "Muhammad vs mountain" problem. Who will come to who? In the story, Muhammad finally came to the mountain but what will be the case in our story? Viber is www application, Debian users need Viber and Viber obviously does not need to follow the Debian's evolution pace. Conclusion?
pvidic
 
Posts: 1
Joined: 2018-04-09 15:49

Re: Debian stretch rel. lacks libssl1.0.0_1.0.1t-1+deb8u8_am

Postby _nobody_ » 2018-05-05 17:35

pvidic wrote:It looks like we have "Muhammad vs mountain" problem. Who will come to who? In the story, Muhammad finally came to the mountain but what will be the case in our story? Viber is www application, Debian users need Viber and Viber obviously does not need to follow the Debian's evolution pace. Conclusion?

Chicken or the egg problem... ??? That is the conclusion! :mrgreen: :mrgreen: :mrgreen:

_nobody_
_nobody_
 
Posts: 19
Joined: 2018-04-10 02:07

Re: Debian stretch rel. lacks libssl1.0.0_1.0.1t-1+deb8u8_am

Postby stevepusser » 2018-05-05 19:14

It will do you no good to kvetch here. Debian is not going to add an obsolete library to please you or Viber. It falls to the Viber packagers to build against Stretch. If they refuse, you may have success with an Ubuntu package that was built against newer ssl libraries.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.11, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.1.0
User avatar
stevepusser
 
Posts: 9718
Joined: 2009-10-06 05:53

Re: Debian stretch rel. lacks libssl1.0.0_1.0.1t-1+deb8u8_am

Postby Wheelerof4te » 2018-05-05 19:50

_nobody_ wrote:Do we, Debian people, have major problem here? :evil:

If googling for an answer and downloading *one* older lib is a problem to you, how did you manage to install Debian in the first place? :mrgreen:
But then again, I see a bunch of smileys in your post, so I suspect it's sarcasm.
User avatar
Wheelerof4te
 
Posts: 1034
Joined: 2015-08-30 20:14

Re: Debian stretch rel. lacks libssl1.0.0_1.0.1t-1+deb8u8_am

Postby _nobody_ » 2018-05-06 04:49

All you, people, are correct.

The curent libssl used in Stretch is: https://packages.debian.org/stretch/libssl1.0.2

So, to solve Viber problem in Stretch, the following is required:
Code: Select all
Download: security.debian.org/debian-security/pool/updates/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb
cd ~/Download
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb

This issue is solved! Admins, please, lock this thread. :!:

Thank you,
_nobody_
_nobody_
 
Posts: 19
Joined: 2018-04-10 02:07

Re: [SOLVED] Deb Stretch lacks libssl1.0.0_1.0.1t-1+deb8u8_a

Postby cds60601 » 2018-05-06 15:17

... and to add a more logical side as to perhaps why Debian does not include SSL 1.0.0 -
https://security.stackexchange.com/questions/41658/what-was-ssl-1-0

To be fair to the point of the op, I too had this issue when installing Eagle 7.7.0 - it also required SSL 1.0.0
Fortunately since I also use the latest build from Eagle (now AutoCad), they include the lib and I simply do a sim-link.

Cheers,
Chris
Yeah, 220, 221. Whatever it takes.
User avatar
cds60601
 
Posts: 87
Joined: 2017-11-25 05:58


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable