[SOLVED]Error Installing Docker-CE on Debian Stretch

If none of the more specific forums is the right place to ask

[SOLVED]Error Installing Docker-CE on Debian Stretch

Postby bcinteractive » 2018-05-06 23:26

Hi,

I have an error installing Docke-CE using this instruction: https://docs.docker.com/install/linux/docker-ce/debian/

I got stuck on ap-get update with the following error:

Code: Select all
Err:13 https://download.docker.com/linux/debian stretch/stable amd64 Packages 
  gnutls_handshake() failed: Public key signature verification has failed.
.....
W: The repository 'https://download.docker.com/linux/debian stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://download.docker.com/linux/debian/dists/stretch/stable/binary-amd64/Packages  gnutls_handshake() failed: Public key signature verification has failed.


I also got this:
Code: Select all
apt-key fingerprint 0EBFCD88
pub   rsa4096 2017-02-22 [SCEA]
      9DC8 5822 9FC7 DD38 854A  E2D8 8D81 803C 0EBF CD88
uid           [ unknown] Docker Release (CE deb) <docker@docker.com>
sub   rsa4096 2017-02-22 [S]


There's an [ unknown] word in the apt-key command. What is this and how do I troubleshoot this.

Thank you.
Last edited by bcinteractive on 2018-05-13 03:27, edited 1 time in total.
:) Things Change
:) Just Do It
Heavy Gnome Desktop User
User avatar
bcinteractive
 
Posts: 297
Joined: 2005-11-03 15:15

Re: Error Installing Docker-CE on Debian Stretch

Postby Bulkley » 2018-05-06 23:36

What's wrong with the Docker in Debian's repository?

Code: Select all
apt install docker
Bulkley
 
Posts: 5538
Joined: 2006-02-11 18:35

Re: Error Installing Docker-CE on Debian Stretch

Postby bcinteractive » 2018-05-06 23:46

Follow up on the matter when I issue

Code: Select all
apt-key list


I found out that all entries have [ unknown] in them. Is this cause for alarm?

Please help.

Also, can I delete key entries related to other debian versions that is not stretch?
:) Things Change
:) Just Do It
Heavy Gnome Desktop User
User avatar
bcinteractive
 
Posts: 297
Joined: 2005-11-03 15:15

Re: Error Installing Docker-CE on Debian Stretch

Postby bcinteractive » 2018-05-07 04:41

This is really getting on my nerves. I’m now away from the desktop. And just installed docker on a third debian desktop successfully.

Code: Select all
apt-get update


looks into a lot of docker related URLs. On the third successful install, apt-get update only look into one docker url. I can’t list the urls as am now away from the desktop. But this is a good way of keeping tabs on my progress.
:) Things Change
:) Just Do It
Heavy Gnome Desktop User
User avatar
bcinteractive
 
Posts: 297
Joined: 2005-11-03 15:15

[SOLVED]Re: Error Installing Docker-CE on Debian Stretch

Postby bcinteractive » 2018-05-13 03:26

I visited this site for a solution

Code: Select all
# dpkg -l | grep libgnutls
ii  libgnutls-deb0-28:amd64                           3.3.8-6+deb8u7                              amd64        GNU TLS library - main runtime library
rc  libgnutls-deb0-28:i386                            3.3.8-6+deb8u7                              i386         GNU TLS library - main runtime library
ii  libgnutls-openssl27:amd64                         3.5.8-5+deb9u3                              amd64        GNU TLS library - OpenSSL wrapper
ii  libgnutls30:amd64                                 3.5.8-5+deb9u3                              amd64        GNU TLS library - main runtime library
ii  libgnutls30:i386                                  3.5.8-5+deb9u3                              i386         GNU TLS library - main runtime library


It looks like I have two (2) versions of libgnutls when I try to remove libgnutls-deb0-28

So I try to remove one of them - the older one with some errors that prevents me from completely removing the package:

Code: Select all
# apt-get remove --purge libgnutls-deb0-28
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl3-gnutls : Depends: librtmp1 (>= 2.4+20131018.git79459a2-3~) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


Using synaptic - I looked into BROKEN packages. Resolve this issue by deleting these packages and now I don't get error message using apt-get update for the docker repository.
:) Things Change
:) Just Do It
Heavy Gnome Desktop User
User avatar
bcinteractive
 
Posts: 297
Joined: 2005-11-03 15:15


Return to General Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable