Installing LibreOffice6 through backports on Stable

If none of the more specific forums is the right place to ask

Installing LibreOffice6 through backports on Stable

Postby Lysander » 2018-05-09 07:54

I use LO almost daily and in the last few days I've noticed some documents not opening properly and/or LO crashing. I wonder if upgrading LO would help prevent this. In particular:

- one .docx I sent someone was unopenable on their W7 machine and was reported as corrupted even though it was fine at my end.
- a friend sent me several .docx files and LO repeatedly crashed while trying to open them. Other documents he sent me were fine.

I'm running Debian 9.4, and I notice that LO6 has made it into backports. I see from here that backport packages are deactivated by default. Therefore I would presumably have to purge LO5 and install LO6 via:

Code: Select all
#apt purge libreoffice*
#apt clean
#apt autoremove
#apt -t stretch-backports install libreoffice


I do have backports in sources.list.

Is this the recommend route? Is there anything I am missing by doing it this way?
User avatar
Lysander
 
Posts: 500
Joined: 2017-02-23 10:07
Location: London

Re: Installing LibreOffice6 through backports on Stable

Postby anticapitalista » 2018-05-09 09:11

I would try the AppImage version first to see if version 6 'solves' the problems you are having.

https://www.libreoffice.org/download/appimage/
antiX "Killah P" - lean and mean.
http://antix.mepis.org
anticapitalista
 
Posts: 322
Joined: 2007-12-14 23:16

Re: Installing LibreOffice6 through backports on Stable

Postby Wheelerof4te » 2018-05-09 10:30

Yes, that procedure is correct. I don't know if LO 6 will solve your problem, though. If that someone uses Word 2010+, try sending them the same document as .odt file.
Why Debian isn't user-friendly?
HOWTO: Install ES3 Morrowind on Debian Sid and Stable
"My computer is a few electrical transistors I flip manually with registers made out of salt water and lemon juice in some cups." - some guy on Reddit
User avatar
Wheelerof4te
 
Posts: 882
Joined: 2015-08-30 20:14

Re: Installing LibreOffice6 through backports on Stable

Postby stevepusser » 2018-05-09 22:25

I wasn't aware that you should need to purge any Debian package before upgrading. If you need to do so, it means there's a bug in the packaging.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10, Pale Moon 27.9.1, Enlightenment 0.22, Calligra 3.1, VLC 3.0.2, Firefox 60.0, Krita 4.0.3
User avatar
stevepusser
 
Posts: 9531
Joined: 2009-10-06 05:53

Re: Installing LibreOffice6 through backports on Stable

Postby Lysander » 2018-05-10 09:59

anticapitalista + Wheeler - thanks for the helpful responses as always.

stevepusser wrote:I wasn't aware that you should need to purge any Debian package before upgrading. If you need to do so, it means there's a bug in the packaging.


I always purge as a matter of routine. Is this not entirely necessary? Stack Exchange seems to say [if I have understood correctly] that if one requests an upgrade then apt will offer the user a choice between versions. Now, when upgrading in Slackware, slackpkg offers a choice between .new and .old. Is this the same case here?
User avatar
Lysander
 
Posts: 500
Joined: 2017-02-23 10:07
Location: London

[SOLVED] Re: Installing LibreOffice6 through backports on St

Postby Lysander » 2018-05-10 17:34

stevepusser wrote:I wasn't aware that you should need to purge any Debian package before upgrading. If you need to do so, it means there's a bug in the packaging.


You were right - I didn't purge and went ahead with the install. LO was automatically upgraded and my configs were retained [this was good since I spent quite a bit of time getting LO5 to look how I wanted]. LO wouldn't launch from the Libre Office Writer shortcut [the main Libre Office one was fine], but this was solved after a reboot.

For anyone interested in the details:

Code: Select all
lysander@psychopig-xxxiii:~$ sudo apt -t stretch-backports install libreoffice
[sudo] password for lysander:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libetonyek-0.1-1 libgltf-0.0-0v5 libmwaw-0.3-3 liborcus-0.11-0 libreoffice-gtk2 libreoffice-pdfimport libreoffice-systray libwps-0.4-4
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  firebird3.0-common firebird3.0-common-doc firebird3.0-server-core fonts-liberation2 gir1.2-lokdocview-0.1 libboost-chrono1.62.0
  libboost-locale1.62.0 libfbclient2 libib-util liblibreofficekitgtk libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-evolution libreoffice-gnome
  libreoffice-gtk2 libreoffice-help-en-gb libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-l10n-en-gb libreoffice-math
  libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql
  libreoffice-style-breeze libreoffice-style-galaxy libreoffice-style-hicontrast libreoffice-style-sifr libreoffice-style-tango libreoffice-systray
  libreoffice-wiki-publisher libreoffice-writer libreofficekit-data libtommath1 python3-uno uno-libs3 ure
Suggested packages:
  firebird3.0-server gpa libreoffice-grammarcheck myspell-dictionary openclipart2-libreoffice | openclipart-libreoffice pstoedit unixodbc
  libreoffice-officebean libjtds-java libreoffice-mysql-connector | libmyodbc | libmysql-java libsqliteodbc | tdsodbc | mdbtools hyphen-en-gb
  libreoffice-grammarcheck-en-gb mythes-en-gb postgresql gtk2-engines mediawiki
Recommended packages:
  libreoffice-gtk3
The following packages will be REMOVED:
  libreoffice-gtk libreoffice-style-oxygen
The following NEW packages will be installed:
  firebird3.0-common firebird3.0-common-doc firebird3.0-server-core fonts-liberation2 libboost-chrono1.62.0 libboost-locale1.62.0 libfbclient2
  libib-util libreoffice-sdbc-firebird libtommath1
The following packages will be upgraded:
  gir1.2-lokdocview-0.1 liblibreofficekitgtk libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-evolution libreoffice-gnome
  libreoffice-gtk2 libreoffice-help-en-gb libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-l10n-en-gb libreoffice-math
  libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-breeze
  libreoffice-style-galaxy libreoffice-style-hicontrast libreoffice-style-sifr libreoffice-style-tango libreoffice-systray
  libreoffice-wiki-publisher libreoffice-writer libreofficekit-data python3-uno uno-libs3 ure
41 upgraded, 10 newly installed, 2 to remove and 91 not upgraded.
Need to get 109 MB of archives.
After this operation, 56.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-base-drivers amd64 1:6.0.4~rc1-4~bpo9+2 [497 kB]
Get:2 http://ftp.uk.debian.org/debian stretch/main amd64 firebird3.0-common-doc all 3.0.1.32609.ds4-14 [36.3 kB]
Get:3 http://ftp.uk.debian.org/debian stretch/main amd64 firebird3.0-common all 3.0.1.32609.ds4-14 [13.7 kB]
Get:4 http://ftp.uk.debian.org/debian stretch/main amd64 libtommath1 amd64 1.0-4 [56.0 kB] 
Get:5 http://ftp.uk.debian.org/debian stretch/main amd64 libfbclient2 amd64 3.0.1.32609.ds4-14 [505 kB]
Get:6 http://ftp.uk.debian.org/debian stretch/main amd64 libib-util amd64 3.0.1.32609.ds4-14 [3,346 B]
Get:7 http://ftp.uk.debian.org/debian stretch/main amd64 firebird3.0-server-core amd64 3.0.1.32609.ds4-14 [2,431 kB]
Get:8 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-base amd64 1:6.0.4~rc1-4~bpo9+2 [1,711 kB]
Get:9 http://ftp.uk.debian.org/debian stretch/main amd64 fonts-liberation2 all 2.00.1-3 [1,455 kB]
Get:10 http://ftp.uk.debian.org/debian stretch/main amd64 libboost-chrono1.62.0 amd64 1.62.0+dfsg-4 [36.0 kB]                                       
Get:11 http://ftp.uk.debian.org/debian stretch/main amd64 libboost-locale1.62.0 amd64 1.62.0+dfsg-4 [262 kB]                                         
Get:12 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-wiki-publisher all 1.2.0+LibO6.0.4~rc1-4~bpo9+2 [1,476 kB]             
Get:13 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-help-en-us all 1:6.0.4~rc1-4~bpo9+2 [2,429 kB]                         
Get:14 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-help-en-gb all 1:6.0.4~rc1-4~bpo9+2 [2,408 kB]                         
Get:15 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-style-tango all 1:6.0.4~rc1-4~bpo9+2 [1,308 kB]                         
Get:16 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-style-hicontrast all 1:6.0.4~rc1-4~bpo9+2 [349 kB]                     
Get:17 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-style-breeze all 1:6.0.4~rc1-4~bpo9+2 [1,017 kB]                       
Get:18 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-common all 1:6.0.4~rc1-4~bpo9+2 [26.2 MB]                               
Get:19 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-calc amd64 1:6.0.4~rc1-4~bpo9+2 [7,052 kB]                             
Get:20 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-draw amd64 1:6.0.4~rc1-4~bpo9+2 [2,695 kB]                             
Get:21 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-evolution amd64 1:6.0.4~rc1-4~bpo9+2 [79.9 kB]                         
Get:22 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-gnome amd64 1:6.0.4~rc1-4~bpo9+2 [50.1 kB]                             
Get:23 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-gtk2 amd64 1:6.0.4~rc1-4~bpo9+2 [205 kB]                               
Get:24 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-impress amd64 1:6.0.4~rc1-4~bpo9+2 [904 kB]                             
Get:25 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-pdfimport all 1:6.0.4~rc1-4~bpo9+2 [2,792 B]                           
Get:26 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-writer amd64 1:6.0.4~rc1-4~bpo9+2 [8,468 kB]                           
Get:27 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-core amd64 1:6.0.4~rc1-4~bpo9+2 [36.0 MB]                               
Get:28 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-style-galaxy all 1:6.0.4~rc1-4~bpo9+2 [1,539 kB]                       
Get:29 http://ftp.debian.org/debian stretch-backports/main amd64 uno-libs3 amd64 6.0.4~rc1-4~bpo9+2 [872 kB]                                         
Get:30 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-ogltrans amd64 1:6.0.4~rc1-4~bpo9+2 [71.9 kB]                           
Get:31 http://ftp.debian.org/debian stretch-backports/main amd64 ure amd64 6.0.4~rc1-4~bpo9+2 [1,707 kB]                                             
Get:32 http://ftp.debian.org/debian stretch-backports/main amd64 libreofficekit-data all 1:6.0.4~rc1-4~bpo9+2 [4,002 B]                             
Get:33 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-style-sifr all 1:6.0.4~rc1-4~bpo9+2 [672 kB]                           
Get:34 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-script-provider-python all 1:6.0.4~rc1-4~bpo9+2 [12.3 kB]               
Get:35 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-script-provider-js all 1:6.0.4~rc1-4~bpo9+2 [614 kB]                   
Get:36 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-script-provider-bsh all 1:6.0.4~rc1-4~bpo9+2 [32.7 kB]                 
Get:37 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-report-builder all 1:6.0.4~rc1-4~bpo9+2 [264 kB]                       
Get:38 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-l10n-en-gb all 1:6.0.4~rc1-4~bpo9+2 [524 kB]                           
Get:39 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-java-common all 1:6.0.4~rc1-4~bpo9+2 [1,839 kB]                         
Get:40 http://ftp.debian.org/debian stretch-backports/main amd64 gir1.2-lokdocview-0.1 amd64 1:6.0.4~rc1-4~bpo9+2 [4,522 B]                         
Get:41 http://ftp.debian.org/debian stretch-backports/main amd64 python3-uno amd64 1:6.0.4~rc1-4~bpo9+2 [185 kB]                                     
Get:42 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-systray amd64 1:6.0.4~rc1-4~bpo9+2 [12.8 kB]                           
Get:43 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-sdbc-hsqldb amd64 1:6.0.4~rc1-4~bpo9+2 [107 kB]                         
Get:44 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-report-builder-bin amd64 1:6.0.4~rc1-4~bpo9+2 [796 kB]                 
Get:45 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-math amd64 1:6.0.4~rc1-4~bpo9+2 [393 kB]                               
Get:46 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-base-core amd64 1:6.0.4~rc1-4~bpo9+2 [710 kB]                           
Get:47 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-avmedia-backend-gstreamer amd64 1:6.0.4~rc1-4~bpo9+2 [23.8 kB]         
Get:48 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice amd64 1:6.0.4~rc1-4~bpo9+2 [71.3 kB]                                   
Get:49 http://ftp.debian.org/debian stretch-backports/main amd64 liblibreofficekitgtk amd64 1:6.0.4~rc1-4~bpo9+2 [63.4 kB]                           
Get:50 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-sdbc-postgresql amd64 1:6.0.4~rc1-4~bpo9+2 [228 kB]                     
Get:51 http://ftp.debian.org/debian stretch-backports/main amd64 libreoffice-sdbc-firebird amd64 1:6.0.4~rc1-4~bpo9+2 [121 kB]                       
Fetched 109 MB in 2min 2s (888 kB/s)                                                                                                                 
Reading changelogs... Done
Extracting templates from packages: 100%
(Reading database ... 224070 files and directories currently installed.)
Removing libreoffice-gtk (1:5.2.7-1+deb9u4) ...
Removing libreoffice-style-oxygen (1:5.2.7-1+deb9u4) ...
Selecting previously unselected package firebird3.0-common-doc.
(Reading database ... 224063 files and directories currently installed.)
Preparing to unpack .../00-firebird3.0-common-doc_3.0.1.32609.ds4-14_all.deb ...
Unpacking firebird3.0-common-doc (3.0.1.32609.ds4-14) ...
Selecting previously unselected package firebird3.0-common.
Preparing to unpack .../01-firebird3.0-common_3.0.1.32609.ds4-14_all.deb ...
Unpacking firebird3.0-common (3.0.1.32609.ds4-14) ...
Selecting previously unselected package libtommath1:amd64.
Preparing to unpack .../02-libtommath1_1.0-4_amd64.deb ...
Unpacking libtommath1:amd64 (1.0-4) ...
Selecting previously unselected package libfbclient2:amd64.
Preparing to unpack .../03-libfbclient2_3.0.1.32609.ds4-14_amd64.deb ...
Unpacking libfbclient2:amd64 (3.0.1.32609.ds4-14) ...
Selecting previously unselected package libib-util:amd64.
Preparing to unpack .../04-libib-util_3.0.1.32609.ds4-14_amd64.deb ...
Unpacking libib-util:amd64 (3.0.1.32609.ds4-14) ...
Selecting previously unselected package firebird3.0-server-core:amd64.
Preparing to unpack .../05-firebird3.0-server-core_3.0.1.32609.ds4-14_amd64.deb ...
Unpacking firebird3.0-server-core:amd64 (3.0.1.32609.ds4-14) ...
Selecting previously unselected package fonts-liberation2.
Preparing to unpack .../06-fonts-liberation2_2.00.1-3_all.deb ...
Unpacking fonts-liberation2 (2.00.1-3) ...
Preparing to unpack .../07-libreoffice-base-drivers_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-base-drivers (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../08-libreoffice-base_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-base (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../09-libreoffice-wiki-publisher_1.2.0+LibO6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-wiki-publisher (1.2.0+LibO6.0.4~rc1-4~bpo9+2) over (1.2.0+LibO5.2.7-1+deb9u4) ...
Preparing to unpack .../10-libreoffice-help-en-us_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-help-en-us (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../11-libreoffice-help-en-gb_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-help-en-gb (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../12-libreoffice-style-tango_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-style-tango (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../13-libreoffice-style-hicontrast_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-style-hicontrast (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../14-libreoffice-style-breeze_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-style-breeze (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
dpkg: considering deconfiguration of libreoffice-common, which would be broken by installation of libreoffice-draw ...
dpkg: yes, will deconfigure libreoffice-common (broken by libreoffice-draw)
Preparing to unpack .../15-libreoffice-draw_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
De-configuring libreoffice-common (1:5.2.7-1+deb9u4) ...
Unpacking libreoffice-draw (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Replacing files in old package libreoffice-common (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../16-libreoffice-evolution_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-evolution (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../17-libreoffice-gnome_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-gnome (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../18-libreoffice-gtk2_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-gtk2 (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../19-libreoffice-impress_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-impress (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Replacing files in old package libreoffice-common (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../20-libreoffice-pdfimport_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-pdfimport (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../21-libreoffice-writer_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-writer (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Replacing files in old package libreoffice-common (1:5.2.7-1+deb9u4) ...
dpkg: considering deconfiguration of libreoffice-core, which would be broken by installation of libreoffice-style-galaxy ...
dpkg: yes, will deconfigure libreoffice-core (broken by libreoffice-style-galaxy)
Preparing to unpack .../22-libreoffice-style-galaxy_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
De-configuring libreoffice-core (1:5.2.7-1+deb9u4) ...
Unpacking libreoffice-style-galaxy (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../23-libreoffice-calc_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-calc (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Replacing files in old package libreoffice-common (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../24-libreoffice-core_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-core (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Replacing files in old package libreoffice-common (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../25-libreoffice-common_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-common (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../26-uno-libs3_6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking uno-libs3 (6.0.4~rc1-4~bpo9+2) over (5.2.7-1+deb9u4) ...
Preparing to unpack .../27-libreoffice-ogltrans_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-ogltrans (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../28-ure_6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking ure (6.0.4~rc1-4~bpo9+2) over (5.2.7-1+deb9u4) ...
Preparing to unpack .../29-libreofficekit-data_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreofficekit-data (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../30-libreoffice-style-sifr_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-style-sifr (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../31-libreoffice-script-provider-python_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-script-provider-python (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../32-libreoffice-script-provider-js_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-script-provider-js (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../33-libreoffice-script-provider-bsh_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-script-provider-bsh (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../34-libreoffice-report-builder_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-report-builder (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../35-libreoffice-l10n-en-gb_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-l10n-en-gb (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../36-libreoffice-java-common_1%3a6.0.4~rc1-4~bpo9+2_all.deb ...
Unpacking libreoffice-java-common (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../37-gir1.2-lokdocview-0.1_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking gir1.2-lokdocview-0.1 (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../38-python3-uno_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking python3-uno (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../39-libreoffice-systray_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-systray (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../40-libreoffice-sdbc-hsqldb_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-sdbc-hsqldb (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../41-libreoffice-report-builder-bin_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-report-builder-bin (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../42-libreoffice-math_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-math (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../43-libreoffice-base-core_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-base-core (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../44-libreoffice-avmedia-backend-gstreamer_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-avmedia-backend-gstreamer (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../45-libreoffice_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../46-liblibreofficekitgtk_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking liblibreofficekitgtk (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Preparing to unpack .../47-libreoffice-sdbc-postgresql_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-sdbc-postgresql (1:6.0.4~rc1-4~bpo9+2) over (1:5.2.7-1+deb9u4) ...
Selecting previously unselected package libboost-chrono1.62.0:amd64.
Preparing to unpack .../48-libboost-chrono1.62.0_1.62.0+dfsg-4_amd64.deb ...
Unpacking libboost-chrono1.62.0:amd64 (1.62.0+dfsg-4) ...
Selecting previously unselected package libboost-locale1.62.0:amd64.
Preparing to unpack .../49-libboost-locale1.62.0_1.62.0+dfsg-4_amd64.deb ...
Unpacking libboost-locale1.62.0:amd64 (1.62.0+dfsg-4) ...
Selecting previously unselected package libreoffice-sdbc-firebird.
Preparing to unpack .../50-libreoffice-sdbc-firebird_1%3a6.0.4~rc1-4~bpo9+2_amd64.deb ...
Unpacking libreoffice-sdbc-firebird (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libtommath1:amd64 (1.0-4) ...
Setting up firebird3.0-common-doc (3.0.1.32609.ds4-14) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Setting up fonts-liberation2 (2.00.1-3) ...
Setting up firebird3.0-common (3.0.1.32609.ds4-14) ...
Setting up libfbclient2:amd64 (3.0.1.32609.ds4-14) ...
Processing triggers for gnome-icon-theme (3.12.0-2) ...
Setting up libib-util:amd64 (3.0.1.32609.ds4-14) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Setting up firebird3.0-server-core:amd64 (3.0.1.32609.ds4-14) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for shared-mime-info (1.8-1) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Setting up uno-libs3 (6.0.4~rc1-4~bpo9+2) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Setting up ure (6.0.4~rc1-4~bpo9+2) ...
Setting up libboost-chrono1.62.0:amd64 (1.62.0+dfsg-4) ...
Processing triggers for fontconfig (2.11.0-6.7+b1) ...
Setting up libboost-locale1.62.0:amd64 (1.62.0+dfsg-4) ...
Setting up libreoffice-style-galaxy (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-style-tango (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-common (1:6.0.4~rc1-4~bpo9+2) ...
Installing new version of config file /etc/libreoffice/sofficerc ...
Setting up libreoffice-core (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-l10n-en-gb (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-gtk2 (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreofficekit-data (1:6.0.4~rc1-4~bpo9+2) ...
Setting up python3-uno (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-base-drivers (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-style-hicontrast (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-systray (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-style-breeze (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-gnome (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-pdfimport (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-draw (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-avmedia-backend-gstreamer (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-java-common (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-script-provider-python (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-impress (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-sdbc-firebird (1:6.0.4~rc1-4~bpo9+2) ...
Setting up liblibreofficekitgtk (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-math (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-wiki-publisher (1.2.0+LibO6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-sdbc-postgresql (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-base-core (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-sdbc-hsqldb (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-calc (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-style-sifr (1:6.0.4~rc1-4~bpo9+2) ...
Setting up gir1.2-lokdocview-0.1 (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-script-provider-bsh (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-ogltrans (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-script-provider-js (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-writer (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-base (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-help-en-gb (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-report-builder-bin (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-evolution (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-report-builder (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice-help-en-us (1:6.0.4~rc1-4~bpo9+2) ...
Setting up libreoffice (1:6.0.4~rc1-4~bpo9+2) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
lysander@psychopig-xxxiii:~$
...
lysander@psychopig-xxxiii:~$ sudo apt autoremove
[sudo] password for lysander:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libetonyek-0.1-1 libgltf-0.0-0v5 libmwaw-0.3-3 liborcus-0.11-0 libreoffice-gtk2 libreoffice-pdfimport libreoffice-systray libwps-0.4-4
0 upgraded, 0 newly installed, 8 to remove and 0 not upgraded.
After this operation, 13.1 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 224129 files and directories currently installed.)
Removing libetonyek-0.1-1:amd64 (0.1.6-5) ...
Removing libgltf-0.0-0v5:amd64 (0.0.2-5) ...
Removing libmwaw-0.3-3:amd64 (0.3.9-2) ...
Removing liborcus-0.11-0:amd64 (0.11.2-3+b1) ...
Removing libreoffice-gtk2 (1:6.0.4~rc1-4~bpo9+2) ...
Removing libreoffice-pdfimport (1:6.0.4~rc1-4~bpo9+2) ...
Removing libreoffice-systray (1:6.0.4~rc1-4~bpo9+2) ...
Removing libwps-0.4-4:amd64 (0.4.5-1) ...
Processing triggers for libreoffice-common (1:6.0.4~rc1-4~bpo9+2) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
lysander@psychopig-xxxiii:~$ sudo apt clean
lysander@psychopig-xxxiii:~$


EDIT: also libreoffice-gtk3 has to be installed through backports after autoremove.

I should have mentioned that LO6 is able to open those docs that LO5 couldn't.
User avatar
Lysander
 
Posts: 500
Joined: 2017-02-23 10:07
Location: London


Return to General Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable