[stretch] Can't get nvidia-driver with cuda v390 installed

If none of the more specific forums is the right place to ask

[stretch] Can't get nvidia-driver with cuda v390 installed

Postby ynnt » 2018-05-18 10:00

Hello,

I am running Debian 9 and trying to get Nvidia cuda toolkit and driver.

However, I get this error message:
Code: Select all
root@9547ad41599f:/tmp/deb# apt-get install -t stretch-backports nvidia-cuda-dev nvidia-cuda-toolkit  nvidia-driver
Reading package lists... Done
Building dependency tree
Reading state information... Done
nvidia-driver is already the newest version (390.48-2~bpo9+3).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver : Depends: nvidia-driver-libs (= 390.48-2~bpo9+3) but it is not going to be installed or
                          nvidia-driver-libs-nonglvnd (= 390.48-2~bpo9+3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Can you help me with this?
ynnt
 
Posts: 2
Joined: 2018-05-18 09:56

Re: [stretch] Can't get nvidia-driver with cuda v390 install

Postby ynnt » 2018-05-18 10:04

Oh, it seems that stretch-backports doesn't contain cuda at all...
ynnt
 
Posts: 2
Joined: 2018-05-18 09:56


Return to General Questions

Who is online

Users browsing this forum: giul51, peter_irich and 2 guests

fashionable