xfce4-screenshooter exits after each shot

If none of the more specific forums is the right place to ask

xfce4-screenshooter exits after each shot

Postby chisam » 2018-05-27 16:39

Hello,
I recently installed Stretch 9.4 64-bit with XFCE and it seems to have everything that I need. I am really happy with it. :D Out of many distros this Debian Stretch is one of a handful that partitioned my eSATA SSD with simplest possible MBR and managed LUKS encryption with aplomb.

What bothers me a bit is the Screenshot program. Coming from KDE I am used to having the KSnapshot of KDE remain active on the display while I prep the scenario for next shot. But for xfce4-screenshooter, I need to start it after every shot and then I need to redefine the shot coverage area. KSnapshot in contrast, remembers the last coverage area and will automatically poise itself to that area when you hit "Take a snapshot".

Is there a way to make xfce4-screenshooter remain alive between shots and remember the last coverage area? I'm doing rectangular areas only with no delay.

Have tried installing KSnapshot (using Synaptic) but it doesn't allow me to install saying it is a transitional package. Then I try Kde-spectacle which succeeds installing but promptly crashes and locks up the entire system on the very first execution.

By the way, this forum site does not seem to allow uploading images (at least to me)!

Thank you.
chisam
 
Posts: 4
Joined: 2018-05-27 15:57
Location: Eastern USA

Re: xfce4-screenshooter exits after each shot

Postby debiman » 2018-05-29 01:37

chisam wrote:Have tried installing KSnapshot (using Synaptic) but it doesn't allow me to install saying it is a transitional package.
that's not a reason to disallow installation, maybe you misinterpreted something there.

Then I try Kde-spectacle which succeeds installing but promptly crashes and locks up the entire system on the very first execution.

installing any KDE package basically pulls in the whole KDE desktop; that might well have wreaked havoc with your system.
User avatar
debiman
 
Posts: 2396
Joined: 2013-03-12 07:18

Re: xfce4-screenshooter exits after each shot

Postby MALsPa » 2018-05-29 02:03

Yeah, it's kinda annoying that xfce4-screenshooter doesn't stay open after taking a screenshot. You might want to try Shutter, or even scrot.
MALsPa
 
Posts: 633
Joined: 2007-12-07 19:20
Location: albuquerque

Re: xfce4-screenshooter exits after each shot

Postby chisam » 2018-05-29 17:47

Thanks to Debiman. I do have some 90+ orphaned packages that I dare not remove :(
Otherwise, the system so far has behaved very well indeed.

I shall certainly try out the Shutter and scrot.
Thanks.
chisam
 
Posts: 4
Joined: 2018-05-27 15:57
Location: Eastern USA

Re: xfce4-screenshooter exits after each shot

Postby debiman » 2018-05-31 16:16

chisam wrote:I do have some 90+ orphaned packages that I dare not remove :(

why not?
if you aren't installing anything from source or so, your system is extremely unlikely to miss anything.
the thing with autoremove is that you have to apply it everytime you get prompted to do so; that way, there won't be any surprises.
User avatar
debiman
 
Posts: 2396
Joined: 2013-03-12 07:18

Re: xfce4-screenshooter exits after each shot

Postby Wheelerof4te » 2018-05-31 16:22

chisam wrote: I do have some 90+ orphaned packages that I dare not remove :(

You are on Stable, so doing
Code: Select all
apt autoremove

should be fairly safe, unless you've messed with the sources.list in a bad way :D
User avatar
Wheelerof4te
 
Posts: 999
Joined: 2015-08-30 20:14


Return to General Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable