Debian OMV

If none of the more specific forums is the right place to ask

Debian OMV

Postby FrankRizz0 » 2018-06-23 13:34

Good morning all!

I'm a new user with Debian, but I do have some Linux skills (this is why I'm not posting in the beginners area). I'm trying to set up a NAS, but unfortunately FreeNAS, OMV, etc. are very limited in what a user can and can't do. I decided to try installing OMV on top of Debian using this wiki:

https://wiki.debian.org/InstallOpenMediaVaultOnDebian

which unfortunately returned these errors:

Code: Select all
The following packages have unmet dependencies:
 openmediavault : Depends: php5-fpm but it is not installable
                  Depends: php5-cgi but it is not installable
                  Depends: php5-cli but it is not installable
                  Depends: php5-pam but it is not going to be installed
                  Depends: openssh-blacklist-extra but it is not installable
                  Depends: php5-proctitle but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I'm assuming I need another repository to install these packages? Is there a tool Debian has for searching repositories? Or am I totally lost and there are other issues?

Thanks in advance for any assistance!
FrankRizz0
 
Posts: 21
Joined: 2007-11-24 17:27

Re: Debian OMV

Postby arochester » 2018-06-23 13:46

The wiki says
InstallOpenMediaVaultOnDebian (last modified 2015-03-24 02:53:56)
...a few years old.

Have you tried e.g. https://forum.openmediavault.org/index. ... 9-Stretch/
arochester
 
Posts: 1313
Joined: 2010-12-07 19:55

Re: Debian OMV

Postby FrankRizz0 » 2018-06-23 14:18

No I haven't, and thank you so much for this. I will give it a try and let you know how it went.
FrankRizz0
 
Posts: 21
Joined: 2007-11-24 17:27

Re: Debian OMV

Postby FrankRizz0 » 2018-06-23 15:18

Not the result I was hoping for :?

Code: Select all
> install postfix openmediavault
Reading package lists... Done
Building dependency tree       
Reading state information... Done
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:16 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:16 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:16 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:16 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:16 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:16 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11-icons-hidpi (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list:16 and /etc/apt/sources.list.d/google-chrome.list:3
E: Unable to locate package openmediavault
FrankRizz0
 
Posts: 21
Joined: 2007-11-24 17:27


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable