Missing libqt5core.so.5

If none of the more specific forums is the right place to ask

Missing libqt5core.so.5

Postby Bugs318 » 2018-06-24 23:34

A little while back, after running an update on testing (that currently says Buster/Sid for version), several packages would no longer run (that ran previously), giving me a "error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory"

I just let it be assuming it was an update that would sort itself out, and I used alternative packages in their place. Today, I needed a specific package and got the same error. I began looking around. locate shows me that libqtcore4 is what exists on the system, and even when I manually download the unstable 5a file and install it, it doesn't show up anywhere and several packages still cannot run. [Edited: I notice I accidentally searched for libqtcore and found 4, while locate libqt5core finds 5a installed but programs still don't run]

Any help would be greatly appreciated.
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Re: Missing libqt5core.so.5

Postby sunrat » 2018-06-25 07:11

libqt5core5a is the package that provides that file.

Code: Select all
# apt-file update
# apt-file search libQt5Core.so.5
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2356
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Missing libqt5core.so.5

Postby Bugs318 » 2018-06-25 19:02

Output:

libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.10
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.10.1
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.3
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.3.2
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Re: Missing libqt5core.so.5

Postby Bugs318 » 2018-06-26 00:47

Despite it being present on the system, no package that draws on it will run. Any ideas?
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Re: Missing libqt5core.so.5

Postby Bugs318 » 2018-06-27 12:08

Does anyone have any suggestions on how I can get apps to use this library and get them working again?
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Re: Missing libqt5core.so.5

Postby bw123 » 2018-06-27 14:03

Bugs318 wrote:Output:

libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.10
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.10.1
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.3
libqt5core5a: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.3.2


where did all of those others come from? I could not find libQt5Core.so.5.10 in debian pkg search.
https://packages.debian.org/search?suit ... re.so.5.10

okay, I found it in sid, but it duesnot say amd64, confusing...

maybe something in the env like a QTPATH= or something is set wrong?
User avatar
bw123
 
Posts: 3139
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Missing libqt5core.so.5

Postby L_V » 2018-06-27 20:31

Last edited by L_V on 2018-06-28 16:59, edited 1 time in total.
L_V
 
Posts: 719
Joined: 2007-03-19 09:04

Re: Missing libqt5core.so.5

Postby sunrat » 2018-06-28 00:22

OP said it's Testing. On Sid I have:
Code: Select all
$ locate libQt5Core.so.5
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5.10
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5.10.1


bw123's suggestion of QTPATH seems like a good place to start, but it's a strange problem I have no idea how to fix or how it would get broken in the first place.
Look for more error messages in logs. Run a program that requires it from a terminal.
I'm guessing it's not KDE as possibly nothing would work if that lib was faulty.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2356
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Missing libqt5core.so.5

Postby Bugs318 » 2018-06-29 00:37

I am not running KDE, but I do run a few packages that depend on parts of it. Maybe I should install the rest of it just to see, but strange that it worked then broke. Any tips on how to check the path? Thanks!
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Re: Missing libqt5core.so.5

Postby stevepusser » 2018-06-29 02:06

You also still have QT 5.3 packages/files from Jessie...that may be at the root of your problem.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.11, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.1.0
User avatar
stevepusser
 
Posts: 9717
Joined: 2009-10-06 05:53

Re: Missing libqt5core.so.5

Postby Bugs318 » 2018-06-29 22:21

apt-get remove says libQt5Core.so.5.3 not found?
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Re: Missing libqt5core.so.5

Postby bw123 » 2018-06-29 23:23

Bugs318 wrote:apt-get remove says libQt5Core.so.5.3 not found?

several posts have shown you how to find it, and the others. You should consider running stable. Don't mix pkgs from stable or oldstable with testing/sid.
User avatar
bw123
 
Posts: 3139
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Missing libqt5core.so.5

Postby stevepusser » 2018-06-29 23:33

A package contains many, many different files. You can search at packages.debian.org to see which Jessie package contained your particular one. I know it's a leftover from Jessie or wheezy-backports because Jessie or wheezy-backports had Qt 5.3. Stretch has 5.7.

https://packages.debian.org/search?sear ... e&arch=any

However...the upgrade to newer versions of that package is supposed to remove the older versions of the libraries, so you shouldn't even have those on your system at all. There seems to be more shenanigans going on with your system than a normal Jessie-Stretch-testing upgrade cycle can account for. Have you or anyone else messed with Qt files or added outside repositories that could have done this?

You can try repairing your particular issue by removing the 5.3 files and reinstalling the libqt5core5a package so the symlinks are set up correctly.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.11, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.1.0
User avatar
stevepusser
 
Posts: 9717
Joined: 2009-10-06 05:53

Re: Missing libqt5core.so.5

Postby Bugs318 » 2018-06-30 13:16

Okay, 5.3 removed, latest package removed, then reinstalled and still the issue remains.

I don't recall any attempt to alter the system around this. Any other suggestions?
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Re: Missing libqt5core.so.5

Postby Bugs318 » 2018-06-30 13:20

Hmmm. Removing before reinstall forced me to remove packages. On reinstalling one, I see this message:

"ldconfig: /usr/lib/libQt5Core.so.5 is not a symbolic link"

Should it be one? What should it point to if so?
Bugs318
 
Posts: 42
Joined: 2010-05-25 18:48

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable