Digikam installation problem

If none of the more specific forums is the right place to ask

Digikam installation problem

Postby sayansg » 2018-09-25 09:16

Hello Everyone,

I'm trying out a few image organizer and editing packages. So far tried almost all in debian repo. Loved Fotoxx and GIMP, and hated pretty much everything else. I wanted to try out digikam, heard a lot about it. But can't seem to be able to install the darn thing. apt bugs is showing 2 bug report. Here's the terminal output. I'm running stretch/buster/sid mixture. :| and LXDE. I don't want to install 2 buggy packages just to check out digikam but then again, I wanted to know if I'm doing something wrong. I'm still a pretty new debian user. Any suggestion is appreciated.


# apt install digikam
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
acl akonadi-contacts-data catdoc digikam-data digikam-private-libs enblend
enfuse ffmpegthumbs gcc-7-base gdal-data hugin hugin-data hugin-tools kio
kipi-plugins kipi-plugins-common kwayland-data kwayland-integration libaec0
libarmadillo9 libarpack2 libastro1 libcharls1 libdap25 libdapclient6v5
libdapserver7v5 libdbusmenu-qt5-2 libdmtx0a libepsilon1 libepub0 libfam0
libflann1.9 libfreexl1 libfyba0 libgdal20 libgdcm2.8 libgeos-3.7.0
libgeos-c1v5 libgeotiff2 libgfortran4 libgps23 libgsl23 libgslcblas0
libhdf4-0-alt libhdf5-100 libhfstospell9 libical3 libieee1284-3 libilmbase23
libjson-c3 libkf5akonadi-data libkf5akonadicontact5 libkf5akonadicore5abi1
libkf5akonadiprivate5abi1 libkf5akonadiwidgets5abi1 libkf5archive5
libkf5attica5 libkf5auth-data libkf5auth5 libkf5calendarcore5abi1
libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5
libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5
libkf5configwidgets-data libkf5configwidgets5 libkf5contacteditor5
libkf5contacts-data libkf5contacts5 libkf5coreaddons-data libkf5coreaddons5
libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5
libkf5doctools5 libkf5filemetadata-bin libkf5filemetadata-data
libkf5filemetadata3 libkf5globalaccel-bin libkf5globalaccel-data
libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5
libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data
libkf5iconthemes5 libkf5idletime5 libkf5itemmodels5 libkf5itemviews-data
libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5
libkf5kiontlm5 libkf5kiowidgets5 libkf5kipi-data libkf5kipi32.0.0
libkf5mediawiki5 libkf5mime-data libkf5mime5abi1 libkf5notifications-data
libkf5notifications5 libkf5notifyconfig-data libkf5notifyconfig5
libkf5prison5 libkf5sane-data libkf5sane5 libkf5service-bin
libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data
libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data
libkf5textwidgets5 libkf5threadweaver5 libkf5wallet-bin libkf5wallet-data
libkf5wallet5 libkf5waylandclient5 libkf5widgetsaddons-data
libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkmlbase1
libkmlconvenience1 libkmldom1 libkmlengine1 libkmlregionator1 libkmlxsd1
libkwalletbackend5-5 libmarblewidget-qt5-28 libmariadbclient18 libnetcdf13
libodbc1 libogdi3.2 libopencv-highgui3.2 libopencv-imgcodecs3.2
libopencv-ml3.2 libopencv-objdetect3.2 libopencv-videoio3.2 libopenexr23
libpano13-3 libpano13-bin libpolkit-qt5-1-1 libpoppler-qt5-1 libpq5
libproj13 libqhull7 libqrencode4 libqt5concurrent5 libqt5opengl5
libqt5serialport5 libqt5sql5-mysql libqt5texttospeech5 libqt5xmlpatterns5
libqtav1 libqtavwidgets1 libsane libsane-common libsane-extras
libsane-extras-common libshp2 libsocket++1 libspatialite7 libsuperlu5 libsz2
liburiparser1 libvigraimpex6 libvoikko1 libwxbase3.0-0v5 libwxgtk3.0-0v5
libxerces-c3.2 libzip4 libzstd1 make marble-data marble-plugins
marble-qt-data media-player-info minidlna mysql-common odbcinst
odbcinst1debian2 opencv-data proj-bin proj-data sane-utils sonnet-plugins
update-inetd
Suggested packages:
tk | wish digikam-doc systemsettings python-wxgtk3.0 gimp kmail konqueror
vorbis-tools fam geotiff-bin gdal-bin libgeotiff-epsg gpsd gsl-ref-psdoc
| gsl-doc-pdf | gsl-doc-info | gsl-ref-html libhdf4-doc libhdf4-alt-dev
hdf4-tools akonadi-server libmyodbc odbc-postgresql tdsodbc unixodbc-bin
ogdi-bin hplip voikko-fi make-doc unpaper hspell
The following NEW packages will be installed:
acl akonadi-contacts-data catdoc digikam digikam-data digikam-private-libs
enblend enfuse ffmpegthumbs gcc-7-base gdal-data hugin hugin-data
hugin-tools kio kipi-plugins kipi-plugins-common kwayland-data
kwayland-integration libaec0 libarmadillo9 libarpack2 libastro1 libcharls1
libdap25 libdapclient6v5 libdapserver7v5 libdbusmenu-qt5-2 libdmtx0a
libepsilon1 libepub0 libfam0 libflann1.9 libfreexl1 libfyba0 libgdal20
libgdcm2.8 libgeos-3.7.0 libgeos-c1v5 libgeotiff2 libgfortran4 libgps23
libgsl23 libgslcblas0 libhdf4-0-alt libhdf5-100 libhfstospell9 libical3
libieee1284-3 libilmbase23 libjson-c3 libkf5akonadi-data
libkf5akonadicontact5 libkf5akonadicore5abi1 libkf5akonadiprivate5abi1
libkf5akonadiwidgets5abi1 libkf5archive5 libkf5attica5 libkf5auth-data
libkf5auth5 libkf5calendarcore5abi1 libkf5codecs-data libkf5codecs5
libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data
libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
libkf5configwidgets5 libkf5contacteditor5 libkf5contacts-data
libkf5contacts5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5doctools5
libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3
libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5
libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5 libkf5idletime5
libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5
libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5 libkf5kiontlm5
libkf5kiowidgets5 libkf5kipi-data libkf5kipi32.0.0 libkf5mediawiki5
libkf5mime-data libkf5mime5abi1 libkf5notifications-data
libkf5notifications5 libkf5notifyconfig-data libkf5notifyconfig5
libkf5prison5 libkf5sane-data libkf5sane5 libkf5service-bin
libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data
libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data
libkf5textwidgets5 libkf5threadweaver5 libkf5wallet-bin libkf5wallet-data
libkf5wallet5 libkf5waylandclient5 libkf5widgetsaddons-data
libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkmlbase1
libkmlconvenience1 libkmldom1 libkmlengine1 libkmlregionator1 libkmlxsd1
libkwalletbackend5-5 libmarblewidget-qt5-28 libmariadbclient18 libnetcdf13
libodbc1 libogdi3.2 libopencv-highgui3.2 libopencv-imgcodecs3.2
libopencv-ml3.2 libopencv-objdetect3.2 libopencv-videoio3.2 libopenexr23
libpano13-3 libpano13-bin libpolkit-qt5-1-1 libpoppler-qt5-1 libpq5
libproj13 libqhull7 libqrencode4 libqt5concurrent5 libqt5opengl5
libqt5serialport5 libqt5sql5-mysql libqt5texttospeech5 libqt5xmlpatterns5
libqtav1 libqtavwidgets1 libsane libsane-common libsane-extras
libsane-extras-common libshp2 libsocket++1 libspatialite7 libsuperlu5 libsz2
liburiparser1 libvigraimpex6 libvoikko1 libxerces-c3.2 libzip4 libzstd1 make
marble-data marble-plugins marble-qt-data media-player-info minidlna
mysql-common odbcinst odbcinst1debian2 opencv-data proj-bin proj-data
sane-utils sonnet-plugins update-inetd
The following packages will be upgraded:
libwxbase3.0-0v5 libwxgtk3.0-0v5
2 upgraded, 201 newly installed, 0 to remove and 643 not upgraded.
Need to get 0 B/209 MB of archives.
After this operation, 515 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
serious bugs of libdmtx0a (→ 0.7.5-1) <Outstanding>
b1 - #908815 - [libdmtx0a] Structs in dmtx.h have changed without new ABI number
serious bugs of minidlna (→ 1.2.1+dfsg-1+b1) <Outstanding>
b2 - #909284 - minidlna: Minidlna needs libavcodec.so.57 which is not a dependancy
Summary:
libdmtx0a(1 bug), minidlna(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...]
sayansg
 
Posts: 21
Joined: 2018-09-13 17:05

Re: Digikam installation problem

Postby arzgi » 2018-09-25 10:30

It is good to learn to use code boxes for listings, and you could have pasted only few last lines, where the bugs are.

The first seems to related to sources, but as digikam is in repo, should not be a problem. The second one is more violatating Debian policy than digikam's usability. If you do not have libavcodec57 installed, you have to install it manually, as root:

Code: Select all
apt install libavcodec57


dikam beeing KDE program, it pulls such huge number of dependencies. If that is not a problem, just go ahead.

I used digikam when I had KDE3, and I liked it. Since changing to XFCE, I've used shotwell, which I think, is also very good.
arzgi
 
Posts: 387
Joined: 2008-02-21 17:03
Location: Finland

Re: Digikam installation problem

Postby sayansg » 2018-09-25 12:42

Thanks for the advice. I installed digikam. It's great, way better than shotwell, especially editing functionality.
sayansg
 
Posts: 21
Joined: 2018-09-13 17:05

Re: Digikam installation problem

Postby stevepusser » 2018-09-25 17:48

A Stretch/Testing/Sid combination is known as a FrankenDebian, and can only possibly work by being run by very experienced users with expert use of apt-pinning. Otherwise, your system is insane in the membrane.

https://wiki.debian.org/DontBreakDebian

Usually, there are much better and safer ways of getting Shiny New Stuff on Debian stable, such as stretch-backports, third-party backports, backporting them yourself, or using snaps, flatpaks, or AppImage packages.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kdenlive 18.08.1, Pale Moon 28.1.0, wine-staging 3.17, qBittorrent 4.1.3, Liquorix kernel 4.18-13, Audacity 2.3.0
User avatar
stevepusser
 
Posts: 10013
Joined: 2009-10-06 05:53


Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable