Problems installing python-skimage-lib

If none of the more specific forums is the right place to ask

Problems installing python-skimage-lib

Postby izemize » 2018-10-15 08:59

I'm trying to install python-skimage-lib but apt-get fails due to dependency conflicts. I have the following unmet requirements:
python-numpy (>= 1:1.8.0)
python-numpy-abi9
python (>= 2.7)
python (< 2.8 )

What I don't understand is that I actually do have those packages installed satisfying the specified version requirements. I have
python-numpy: 1:1.14.5-1+b1
python: 2.7.15-3
python-numpy-abi9 is a virtual package, and it's provided by python-numpy

Any ideas how to solve this? What information shall I provide so you can help me? I am using buster / sid.
izemize
 
Posts: 6
Joined: 2018-10-15 08:50

Re: Problems installing python-skimage-lib

Postby dilberts_left_nut » 2018-10-15 09:57

izemize wrote:I'm trying to install python-skimage-lib
How?
This looks different:
https://packages.debian.org/sid/python-skimage-lib
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4902
Joined: 2009-10-05 07:54
Location: enzed

Re: Problems installing python-skimage-lib

Postby izemize » 2018-10-15 11:56

The standard way:
Code: Select all
sudo apt-get install python-skimage-lib
izemize
 
Posts: 6
Joined: 2018-10-15 08:50

Re: Problems installing python-skimage-lib

Postby dilberts_left_nut » 2018-10-15 14:11

Code: Select all
apt-cache policy {python-skimage-lib,}
?
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4902
Joined: 2009-10-05 07:54
Location: enzed

Re: Problems installing python-skimage-lib

Postby izemize » 2018-10-15 14:22

Code: Select all
python-skimage-lib:
  Installed: (none)
  Candidate:    0.10.1-2
  Version table:
     0.10.1-2 500
        500 http://ftp.de.debian.org/debian jessie/main amd64 Packages
     0.6.1-1 500
        500 http://ftp.de.debian.org/debian oldoldstable/main amd64 Packages
izemize
 
Posts: 6
Joined: 2018-10-15 08:50

Re: Problems installing python-skimage-lib

Postby stevepusser » 2018-10-15 17:07

If you're running buster/sid as you said in your OP, why does apt-get policy only show Jessie available?

Like 99.9% of other posts where a package from the repos, a FrankenDebian is to blame, and like gawkers at a car wreck, we'd like to see your sources.list.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10122
Joined: 2009-10-06 05:53

Re: Problems installing python-skimage-lib

Postby stevepusser » 2018-10-17 17:20

Hello?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10122
Joined: 2009-10-06 05:53

Re: Problems installing python-skimage-lib

Postby izemize » 2018-10-19 07:33

Sorry for the delayed reply. I've written buster/sid, because this is what is stored in /etc/debian_version, /etc/os-release, and /etc/issue.

sources.list looks like the following:

Code: Select all
deb http://ftp.de.debian.org/debian/ jessie main non-free contrib
deb-src http://ftp.de.debian.org/debian/ jessie main non-free contrib

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free

# Backports repository
deb http://http.debian.net/debian jessie-backports main contrib non-free

# Testing repo
deb http://ftp.de.debian.org/debian/ testing main non-free contrib
deb-src http://ftp.de.debian.org/debian/ testing main non-free contrib

# Oldoldstable repo
deb http://ftp.de.debian.org/debian/ oldoldstable main non-free contrib
deb-src http://ftp.de.debian.org/debian/ oldoldstable main non-free contrib
izemize
 
Posts: 6
Joined: 2018-10-15 08:50

Re: Problems installing python-skimage-lib

Postby dilberts_left_nut » 2018-10-19 08:34

Well, there's your problem.
https://wiki.debian.org/DontBreakDebian
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4902
Joined: 2009-10-05 07:54
Location: enzed

Re: Problems installing python-skimage-lib

Postby izemize » 2018-10-19 09:18

Yes, could you be a bit more specific? :D I know where the conflict comes from, my question is

(1) what is exactly the problem, since according to the version requirements that apt throws at me, everything should be fine, see above
(2) how to solve it?
izemize
 
Posts: 6
Joined: 2018-10-15 08:50

Re: Problems installing python-skimage-lib

Postby dilberts_left_nut » 2018-10-19 09:42

izemize wrote:(1) what is exactly the problem,
You have a horrible mess of different packages from several different releases as well as development branch
(2) how to solve it?
Lots of tedious and pointless manual dependency chain following, and hoping you don't reach an impossible situation. Aptitude will be your best friend.
The good news is that you will get to repeat the process indefinitely with future installs and upgrades.
Good luck :)
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4902
Joined: 2009-10-05 07:54
Location: enzed

Re: Problems installing python-skimage-lib

Postby stevepusser » 2018-10-19 19:00

izemize wrote:....
(2) how to solve it?


The best way is to restore your system from the last backup you made before adding upstream repos to your sane Jessie repositories. Without a backup, save your data and reinstall...maybe Stretch with backports would be better this time.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10122
Joined: 2009-10-06 05:53

Re: Problems installing python-skimage-lib

Postby bw123 » 2018-10-19 21:29

yeah, once you do this, even if you manage to somehow straighten it out, you'll never be sure because you broke it. There's really no way, other than checking every single pkg. They all need to be from the same release.

why you did this?
User avatar
bw123
 
Posts: 3517
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Problems installing python-skimage-lib

Postby GarryRicketson » 2018-10-19 21:49

(2) how to solve it?

There is this topic Repo mix-and-match hit parade
In it there is lists of many examples, where people mixed in various versions of Debian and even other distros, in some of the threads listed, they did try doing some things to fix/solve it, most not very successful, a fresh clean installation is the easiest way to solve it, and then care taken to not repeat the same mistakes.
Be sure to read the first pages, of the original topic, not the lasts pages, sadly our local trolls started a discussion on a entirely different subject, and it ended up getting the topic closed, and locked, so no new "Mixed repos" problems are getting added.
User avatar
GarryRicketson
 
Posts: 5161
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Problems installing python-skimage-lib

Postby izemize » 2018-10-20 09:45

Thanks for everybody. I'll have a look into the suggested readings, and let you know if I succeeded.
izemize
 
Posts: 6
Joined: 2018-10-15 08:50


Return to General Questions

Who is online

Users browsing this forum: fred44nl and 8 guests

fashionable